Intranet access to web server through WRT54G

Discussion in 'Cisco/Linksys Wireless Routers' started by Guest, Oct 18, 2004.

  1. Guest

    Guest Guest

    Sorry if this has been answered before.

    What I am trying to do is set up a web server on my intranet to be used
    from the outside ( internet ). I only have 1 outside IP address from my
    ISP, I can get to the outside from all of my intranet PCs.

    Network topology:

    Internet<>WRT54g<>Lunix Web server( Soekris 4801, Redhat 9.0 ).

    The WRT54G has a public IP address, DHCP off, Admin>>Remore
    access enabled using port 8080. I have setup Appl&Game>>Port forward
    to allow http(80) access to point to intranet web server, also ssh.

    The intranet server is using a private IP address 10.x.x.x and is accessible
    from the intranet

    Both ssh and http from the outside times out. I can access the WRT54G
    from the outside through the Remore Access Port and using the diagnotic
    page I can ping the intranet PCs.

    I thought this was allowable, am I wrong??

    Do I need another outside IP address??

    If you have do this before, please Email your configuration to me.
  2. Guest

    Guest Guest

    I have made some progress, I add the default gateway to my web server to
    point to the wrt45g. It times out most of the time but not all of the time

    From some reason, the wrt45g is forgetting where the web sever is. Using
    tcpdump I see 'who has' traffic from route about the server. It looks likes a
    reverse DNS problem.
  3. AbNormal

    AbNormal Network Guru Member

    I hope this doesn't sound like a dumb question (or, answer), but have you forwarded the ports on your router to point to the address of your linux server?

  4. Lazybones

    Lazybones Network Guru Member

    Forward port 80 on the router to the webservers local ip address and you are done.
  5. jamesavery22

    jamesavery22 Network Guru Member

    Did you ever fix this?

    I already forwarded port 80 to my IIS webserver, I can ping the router from the internet/outside my LAN, and I can access my webserver via dns (IE I can go to and I get to my webserver) but only on my LAN, but atleast from another computer.

    So my DNS is working. The router is returning the ping, and I even tried it all after I turned off the firewall (to no avail so turned it right back on).

    I couldnt ping the router with "Block Anonymous Internet Requests" enabled. Should I still be able to see my webserver with that enabled? Just not ping?
  6. mindfrost82

    mindfrost82 Guest

    I had this exact same problem. I bought this router yesterday (v3) and it took me a while to figure it out.

    It's not a problem with the router or with the firmware.

    Under Security > Firewall, you MUST disable " Filter Internet NAT Redirection".

    My problem was that I could access my webserver using the Internal IP address, but not the Internet (Public) IP address. I couldn't SSH, browse, etc. However, when I setup remote access to the router, I could get to that just fine. I asked someone in a different location if they could get to my website, and they could. So it was only blocking internal computers from accessing the server with the public IP address.

    As soon as I disabled that feature in the firewall, it worked perfectly.
  7. Guyfromhe

    Guyfromhe Network Guru Member

    works some of the time eh? are you sure it's maintaining the same ip?
    is it assigned statically? (the linux servers internal ip)...
  8. jamesavery22

    jamesavery22 Network Guru Member

    I tried disabling the firewall completely on the router, and IIS server doesnt have a firewall. The behavior stayed the same. Could get to it via external IP and DNS name from internal computers, but could only ping from external.

    My ISP said they dont block port 80 but I emailed to verify.

    Anyone have any other ideas?
  9. Guyfromhe

    Guyfromhe Network Guru Member

    have you tried a different port incase your ISP is lying?
    have you tried the iis box directly to the modem?
    what ACTUAL address are you trying to go to? (whats the domain)
  10. jamesavery22

    jamesavery22 Network Guru Member

    Would be weird for the ISP to lie. I had to sign a "end user hosting content agreement" thing to make sure Id never host porn or something. I'll try forwarding 70-90 on the router and set the IIS to listen to something different and see. Still waiting on the email reply from them to double check they arent blocking port 80.

    Thanks for the idea of bypassing the router. Should have thought of that =\ I'll try that first.

    why do you want the domain? not really trying to advertise it =\
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice