iptables rdp 3389

Discussion in 'Tomato Firmware' started by shadowro, Sep 18, 2013.

  1. shadowro

    shadowro Serious Server Member

    iptables rdp 3389
    works fine inside lan
    3389 tcp/udp forwarded into router for pc's ip
    3389 tcp/udp allowed in pc's firewall - all connections

    in firewall script on the router, have the following:

    iptables -t nat -A PREROUTING -p tcp -d 135.23.x.x --dport 3389 -j DNAT --to-destination
    iptables -A FORWARD -i br0 -d -p tcp --dport 3389 -j ACCEPT

    135.23.x.x is my external ip - pc's ip address

    tried to connect from outside with external ip, dyndns

    still no luck

    worked fine before with ddwrt

    what can be? sorry, noob here at iptables
  2. shadowro

    shadowro Serious Server Member

    fixed it
    no firewall iptables needed
    problem was at forwarding in router, no src needed

    thank you tomato
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice