iptables-restore: line 132 failed

Discussion in 'Tomato Firmware' started by PGalati, Feb 12, 2012.

  1. PGalati

    PGalati Network Guru Member

    I am currently testing v1.28.7632 -Toastman-IPT-ND ND Std on a WRT54G. I have reflashed and reset nvram multiple times but after modifying something, I eventually get an error message lingering around some of the screens, see attached photo. If I enable uPNP the error number changes from 132 to 128.

    I did have to change the private IP address of the router to 10.0.0.x since our office network uses 192.168.1.x.

    Looking at the log screens, these messages appear several times:
    Feb 12 00:09:58 WRT54G user.err kernel: ipt_account [checkentry]: table found, rule network/netmask/shortlisting not match table network/netmask/shortlisting.
    Feb 12 00:09:58 WRT54G user.crit init[1]: Error while loading rules. See /etc/iptables.error file.

    The router seems to be running without trouble at this time, especially clocked at 250Mhz

    And idea what might be causing this error to surface?

    Attached Files:

  2. slamcat

    slamcat Network Guru Member

    Not sure but I got something similar running the VPN version initially (it referenced line 39 instead). I rebooted the router and all was well. Not sure yours will be as simple but couldn't hurt to try it.

    I should also note that mine was an Asus RT-N16...
  3. kthaddock

    kthaddock Network Guru Member

    After that did you change all other settings to 10.0.0.x network?
    DHCP, PORT-forwarding, ARP-binding, BW and Qos rules? (I have probably forget som rule)

    Line 132 what do it says?

    Ps: You could change to 192.168.2.x on you router.

  4. PGalati

    PGalati Network Guru Member

    I am not sure how to gain access to the iptable file to accurately tell you what either line 128 or 132 is. With a little coaching, I would certainly relay that info.
  5. kthaddock

    kthaddock Network Guru Member

    I think your problem are related to your change. Forget of error for a moment and tell if you:
  6. quietsy

    quietsy Network Guru Member

    I have the same error, it can also be seen under QoS > Classification.
    WRT54GL on tomato-WRT54G_WRT54GL-1.28.7632.3-Toastman-IPT-ND- Tiny.
    Attached the iptables dump.


    Attached Files:

  7. quietsy

    quietsy Network Guru Member

    I solved it by disabling the Web Monitor.
  8. Planiwa

    Planiwa Network Guru Member

    To display lines 128 through 132:
    sed -n 128,132p /etc/iptables
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice