Is Linksys working on a new firmware??

Discussion in 'Cisco/Linksys Network Storage Devices' started by birbjo, Mar 31, 2006.

  1. birbjo

    birbjo Network Guru Member

    Hoping that someone from LINKSYS is reading this, I would want to
    know is any work is beeing put into producing a new firmware?

    My problems with "..too many backup-jobs...." is still giving me nightmares. I can't get my backups to work since this product fails to deliver what it said it would.
    Should I give up on this unit and start looking for some other sollution?

    Regards from Sweden
  2. AsGF2MX

    AsGF2MX LI Guru Member

    Here's a bump...I'm having a hard time connecting to the server from my XDA Mini S (aka HTC Wizard, running Win Mobile 5). The NSLU2 just doesn't respond and a quick google shows it to be an issue with the R63 firmware :(
  3. Toxic

    Toxic Administrator Staff Member

  4. d__l

    d__l Network Guru Member

    birbjo, I've posted else where about my experiments with hard resets to erase the back up job memory. I failed so I concluded that those settings weren't stored on the NSLU2 in the same place as the IP, gateway and the like. The password, the shares, and the group info is of course stored on the HD.

    Perhaps those settings are stored in a CMOS-type memory that could be erased by removing the battery for a while, but to do so would invalidate your warranty.
  5. birbjo

    birbjo Network Guru Member

    Thanks for new ideas.....
    Ok, so if i were to open the unit up with my sledgehammar and the blowtorche, i would find a battery in there....? Like the on the mother board? Could there be a reset switch there as well?
    Anybody know?

    Have thought about going back to firmware 2.3R29, since the
    backups weren't a problem "back in those days"......but i don't understand what file to use...the firmware on Linksys that I downloaded was some 70mb large and had MILLIONS of different files.....i may be exaggerating.....a little....

    Any comments?
    Best Regards!
  6. AsGF2MX

    AsGF2MX LI Guru Member

    I have yet to install the ext3 fs driver for WinXP but if I connect my drive to my PC, I see three partitions (if you use the tools under computer management) which were created by the NSLU2 and I assume that 1 of those partitions contains usernames, permissions, etc. While the other might contain your job info?
  7. d__l

    d__l Network Guru Member

    birbjo, yes you would find a little Panasonic lithium coin battery in there: See:

    How to open it is here:

    I would try yanking the battery myself, but I'm not as desperate as you to reset my back up jobs. :D Opening the box would probably void your warranty. Especially if you crack or break some of the case opening it. It is easy to do. I've voided my warranty long ago by overclocking the processor and soldering on a remote power switch attachment.

    AsGF2MX, you can remove all the drives and the back up jobs are still there. The passwords, shares, and groups are all removed with the drives.
  8. AsGF2MX

    AsGF2MX LI Guru Member

    Didn't notice as my NSLU2 has been running non stop for the last 3 days with the HD attached :grin:

    Just a pity that my PPC doesn't see it :(
  9. birbjo

    birbjo Network Guru Member

    thx d__l, I will probably try this......

  10. d__l

    d__l Network Guru Member

    When you re-install the coin battery, be certain to put it back in the proper orientation.

    On the RV082, Linkysys warns against the end user even touching much less changing the battery after it has expired as it can explode if installed backwards. They must think all their users are incompetent idiots.
  11. birbjo

    birbjo Network Guru Member

    Idoit? Who? ME?


    Txh, will watch my fingers.....
  12. Toxic

    Toxic Administrator Staff Member

    NSLU2 v23 r72 ???

    I have a newer version here than the v63 that linksys show.. there is a UI binary also included in teh zip file but no changelog. this is a beta.
  13. birbjo

    birbjo Network Guru Member

    So there's a new firmware on the loose, but just a BETA..
    I'm not sure if I dare install it......maybe some new problems will arise to clouden my horizon.....
    I'm starting to think of the Netgear Sc 101 as a replacement.
    But first I will try with a "battery-removal-operation"....will see later
    today if that will help the situation, removed the battery last night.
  14. ytsejam

    ytsejam Network Guru Member

    I'm having the same problem running firmware v63. I even took the battery out for a minute or so put it back in and I still cannot create any backup jobs (Error: Too many jobs, cannot create more). I don't even have any jobs created!!! I also tried downgrading to v24, v25, and v29, they all had the same problem. However, initially when I used these firmwares there was no problem, the problem only arose after I used v63. I have done a hard reset to no avail. The only thing I have not tried is "Reset Default Config" in the Administration/System tab, but this will probably do the same thing as the hard reset button. My next two options are trying the BETA firmware v72 (It's actually two months older than v63) that TOXIC posted. The other option is flashing an Unslung firmware, try to create some backup jobs and then revert back to v63.
  15. d__l

    d__l Network Guru Member

    ytsejam, had you ever created any back up jobs and erased them or did you get that error message when you went to create your very first back up job?
  16. ytsejam

    ytsejam Network Guru Member

    I had backup jobs and then deleted them. At first, I was trying to modify one of the jobs because it was doing a FULL backup instead of Synchornizing like it was scheduled. When I tried to save the modified job, I first got the error. So I figured I would delete all 5 jobs (thinking this would clear the cache). And now I have no jobs scheduled and cannot create any, due to the error message.
  17. d__l

    d__l Network Guru Member

    OK, that pretty much matches what I saw. So the way it stands now, you can create up to 5 jobs in older firmwares and carry them across an upgrade to R63, but you can't modify them then. If you delete any of those five jobs, you can't replace them.

    There is no known way to reset the back up job memory: not by erasing the jobs, not by hard resetting the unit, not by removing the HDs, not by reflashing the unit, and not by removing the battery.

    I wonder if NSLU2s with no back up jobs set before R63 is first used have this problem of non-modifiable back up jobs? Also does a new NSLU2 on R63 allow you a "lifetime limit" of five jobs too?
  18. ytsejam

    ytsejam Network Guru Member

    Yes and you can't even replace them if you downgrade the firmware to an earlier version. Linksys really needs to release a fix for this.
  19. birbjo

    birbjo Network Guru Member

    I ´now put the battery changes what so ever.
    Then I downgraded to R29. All of a sudden I no longer can reach my "brick", the (to be) green light on top only only flickers red now and my connection to the Internet gets disconnected all the time(?), until I turn of the "brick" completely.....haha!

    Bye Linksys........Hello Netgear!

    Thanks for trying to help me guys, but this just isn't funny anymore.

    Good luck in the future!

  20. ytsejam

    ytsejam Network Guru Member

    I upgraded to v72 and still the same problem. I'm going to try some more troubleshooting and post the results.
  21. d__l

    d__l Network Guru Member

  22. d__l

    d__l Network Guru Member

    ytsejam, after research and reviewing some Howtos here: it seems likely that the back up job settings are stored in the flash under SysConf area:

    Whether or not the reset button, would erase and reset the back up job memory in versions prior to R63 is unknown, but no one complained about it in those versions as far as I'm aware. I think the capability of telneting into RedBoot to reset SysConf was eliminated after version R25 (but some of the posts suggest it is possible in R29).
  23. ytsejam

    ytsejam Network Guru Member

    PROBLEM FIXED!!!! WOOHOO!!! Here are the steps I took, not sure which one was the key to the fix, but here goes:

    1. Upgraded to v72
    2. Clicked on Reset Default Config (in Adminstration/Systems Tab)
    3. Shut down NSLU2
    4. Unplugged Hard Drives
    5. Plugged a Flash Drive into Port 2
    6. Booted NSLU2
    7. Created a backup job on the Flash Drive (SUCCESS!!)
    8. Shut down NSLU2
    9. Plugged Hard Drives Back in
    10. Now I'm free to create AND delete backup jobs, I also modified the backup job I created for the Flash Drive to work with the Hard Drives.

    Please let me know if this works for others and good luck.
  24. d__l

    d__l Network Guru Member

    ytsejam, just to be clear, had you tried that clicked on Reset Default Config (in Adminstration/Systems Tab) at all previously when you were using R63 before you flashed to R72?
  25. ytsejam

    ytsejam Network Guru Member

    No I had not. Let me know your results.

    One other thing. What started all this was I noticed that with v63 my Synchronized backups were not working correctly. It would only do an Incremental backup. Something else to look out for with v63. The Synchronized backups work perfect in v72.
  26. d__l

    d__l Network Guru Member

    ytsejam, I can't believe it was that simple! Sheesh. Reset Default Config (in Adminstration/Systems Tab) did it and erased all my old back up jobs. I didn't have to change my firmware from R63.

    Poor birbjo needed to wait a just few more hours for your results.

    I did a config back up before the Reset. It wouldn't work to restore my old settings after the erasure. It said something about a corrupted file. I also had printed out copies of the various screens before starting the erasure and used those to manually rebuild my back up jobs.

    I think something about the jump between firmware versions made the config back up files useless for restoring settings.

    I only use Incremental back ups so I don't know about the Synchronized back up problem.
  27. birbjo

    birbjo Network Guru Member

    ......just a few hours to late.....

    What can I say.....but to paraphrase Monthy Python....
    "Life's a piece of shit, when You look at it...."

    I'm now one of the Netgear-guys anyway.
    Tried to save the erronious flash, but I never got the slug to red light, only red/green, no matter what I did
    to the reset-button.....

    I will now mix a bucket of concrete, carefully put the old slug in in it,
    and lower the lot into the ocean.
    The slug will not be missed by anyone.
    Good luck in the future......
  28. d__l

    d__l Network Guru Member

    Well, it might be a fun device to play with/experiment on for linux programming if you could ever get it restored. You have nothing to lose with it now. is the place to get recovery info in case you decide that a personal linux device is worth having.

    I didn't even know that Netgear made a NAS device. The reviews that I've seen of all NAS devices are a mixed bag vs. the NSLU2. Either they cost way more when you factor in the hard drive (but they are 50-100% faster) or they have even crappier support than Linksys (and I consider the help that you get here from people like ytsejam to be part of the Linksys support even though Linksys isn't paying for it), or they are even slower than the NSLU2.
  29. ytsejam

    ytsejam Network Guru Member

    Thanks for the kind words d__l and congratulations on getting your backups working correctly again. Glad I could help.
  30. d__l

    d__l Network Guru Member

    ytsejam, something I didn't post before, but I now believe that it may be prudent to use Reset Default Config to factory defaults before any flashes to other firmware versions. This is a standard best procedures practice when flashing many Linksys routers and probably should be applied to the NSLU2. It may be a pain to do this, but it is safer. Also it might be advisable to have the drives unhooked when resetting to factory defaults AND when flashing.

    Clearly the flash upgrade to R63 "locked" the back up jobs for us so not using Reset Default Config before flashing saved nothing as the reset had to be used eventually to fix the back up jobs.

    It is also probable that Config Backup will not always work across firmware upgrades. Sure you can try it to restore your configuration after an upgrade, but don't depend on it. Print out copies of all the set up screens as a fail safe back up plan.

    I want to say thanks for posting your procedure. It sure helped me fix my NSLU2 and this thread might help others too.
  31. Tevez

    Tevez LI Guru Member

    Dude, thanks for the advice but the links you give can't be opened.
  32. Qooop

    Qooop Network Guru Member

    I just want to add, since I have a total of 5 NSLU2s, not all external drives/drive enclosures are created equal. I have used a few different enclosures and have had intermittent problems with loss of connection and totally disappearing files that later reappear. After I switched to all new drive enclosures I no longer have any problems with any of the slugs. I am still using the R63, I am happy the way things are although I may experiment with the new firmware and a hub since one of my slugs is sitting idle.

    BTW, the new enclosures I bought are way cool with a fan mounted on the side
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice