Is there a trick in upgrading DD-WRT in a WRT54Gv4 & 54G

Discussion in 'Cisco/Linksys Wireless Routers' started by in8skillz, Oct 22, 2005.

  1. in8skillz

    in8skillz Network Guru Member

    I've tried several of the beta 1 & 2 DD-WRTv23's in them.

    I was able to upgrade to the newest official linksys firmware, but that's it. Trying to upgrade to DD-WRT firmware only comes back as "Upgrade are failed"

    Is there a trick to doing this on a 54GSv4 & a 54Gv4? I read others that have v4's under the dd-wrt forum have the upgrade working, but I can't get it to go on either of wrt's.

    Please help
  2. pecs_jr

    pecs_jr Network Guru Member

    I'll add in a second on that issue. I was able to upgrade to the current Linksys firmware but all attempts at changing over to DD-WRT and HyperWRT yielded the same "Upgrade are failed" and flashing power indicator, the Linksys official recovery hack does recover the unit.

    Speculation: there are some V4 units out there that are actually V5 without enough memory to support the current optional firmwares?
    Anybody know how to check available memory on a stock unit? Bueller?

  3. in8skillz

    in8skillz Network Guru Member

    Alright, oddly enough after 23 tries I got it to go. *at the moment, I'm working with the wrt54GSv4...I'll try the 54G later since I'm having the same problem with it*

    Basically the last steps I took were:

    1. Re-flashed to the newest linksys FW.
    2. Held reset for 30 seconds
    3. Unpluged the power, then plug it back in after 5 seconds
    4. Restored factory defaults
    5. Flashed DD-WRTv23b2 Standard for v4 (didn't work)
    6. Flashed DD-WRTv23b2 Mini for v4 (didn't work)
    7. Restored factory defaults again
    8. Flashed v23b2 Mini again and it took.

    So, I assume it's an absolute Pre-req to restor factory defaults.
    Also, judging by reading a few posts the v4's may need to start with a firmware closer in size to that of the Offical Linksys FW (<3MB) and that may be why mini worked.

    I also just tried flashing it to v23b2 VOIP but again, it didn't take. This is all leaving me really confused, but atleast I do have a standard version running on it.

    Till someone else can give a full explination I'll keep poking at it and hope to get a feature laiden version on it.
  4. Toxic

    Toxic Administrator Staff Member

    the problem seems to be new 4.20.7 firmwares wont allow firmware over 3Mb. if you use the mini version you'll get round this problem.
  5. in8skillz

    in8skillz Network Guru Member

    I gave it a few more shots.

    Note: All attempts I did were via the GUI - I don't know how to tftp yet.

    GSv4: seems to only take the Mini version upgrade, I couldn't get it any farther then that. So, it seems wouldn't take anything over 3Mb period. Although, it seems to work alright from what I can see. It took several resets to get it to function properly though.
    firmware used: DD-WRTv23b2 mini for WRT54GSv4 - I did not try any generic versions of Brainslayer's v23 firmware, just 54gsv4 specific

    Gv4: it took the Mini version, and worked alright. Then I went another level and made it to the Standard version and was successful. Sadly, after this it acted as if it were bricked but it's not. I can successfully change the color of the light behind the Cisco logo, and the power light doesn't blink endlessly. So, it's fine...I just can't access it, even manually setting up the IP doesn't work.
    firmware used:
    1. DD-WRTv23b2 mini for WRT54G
    2. DD-WRTv23b2 Standard for (WRT54G or Generic) I don't know which I did, I lost track during the many tries.

    So, I am again confused as to what happened and why. I'm realizing it'd be easier to go find another GSv2.1 or Gv3.1 or lower. Wasted lots of time on this, but I hope it's helping others out a bit.

    Anyway, is it easier or better to flash the f/w by tftp? I've read how to unbrick a v4 through this method, but is it wise to flash a different way then it's said on DD-WRT's wiki?
  6. danylati

    danylati Network Guru Member

    i have the same problem today with my new wrt54g V4, it failed to flash to dd-wrt 23b2, then i put the MINI 23b2 and flash is successful, then i flashed the Standard version and all is OK

    what is the diference in the mini and STD version???
  7. Aq_lynch

    Aq_lynch Network Guru Member

    How do I find a v 2.2 or v 2.0

    How do I find a version 2.2 or v. 2.0. When I got to the store the store ad said it was a 2.2 but when I opened the box at home it was a version 4. It will not let me flash any of the firmwares. Please help
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice