Is there any hope?

Discussion in 'Other Linksys Equipment' started by DaveJP, Aug 12, 2004.

  1. DaveJP

    DaveJP Network Guru Member

    I got my WAG54G 4 days ago and it's never worked properly for a single day. I'm running at 11Mbps at the moment. I'm on Pipex xtreme in the UK. I should say I had no problems using the same equipment with a Benq AWL700.

    Out of the box it had the .06 firmware. It dropped the wireless to my laptop (Origo PCMCIA adapter)and the Tivo (Asus WL-330) couldn't even connect. I updated to 1.02.3 and the Tivo connects ok now. The new problems I have are: The wireless link dies. I check the box and the green wireless light has gone out. A power cycle fixes it for a while and then it dies again. Secondly, the internet response drops to a crawl. I'm only on 256 ADSL and a speed test gives me about 230 on a good day. This drops sometimes to 130 and yesterday I just couldn't open pages at all. The speedtest gave me a result of about 30 but it just wasn't usable. A reboot fixed it short term.

    I plugged my old D-Link 300G+ modem in and the test produced 256.8kbps so there is no problem with my link.

    So shall I give up and try and send it back or do you think a new f/w update will fix it? If so, how long will it be? How often do these "fixes" come out? Does anyone get the full bandwidth on their ADSL link?

    I was going to buy a 3Com version but the Cisco name swung it for me!

    Thanks for taking the time to read all this.

  2. yonnage

    yonnage Network Guru Member

    Dave, following the update to 1.02.3 you need to do a full reset of the box to solve the wireless problem. push reset button in for 30 secs. hey it may even sort out the other problem
  3. Toxic

    Toxic Administrator Staff Member

  4. DaveJP

    DaveJP Network Guru Member

    Thanks yonnage.

    Toxic, thanks. Honestly, I had read the sticky but I was hoping there was a quick fix!

    I'll try the Restore Factory Defaults and see how I get on.

    Thanks to both of you.

  5. DaveJP

    DaveJP Network Guru Member

    I've done the reset and the speed test gives consistent results at 216kbps.

    Is this normal, as I said previously I got the full 256 with the D-Link. A loss of about 16% on an already slow line is really not acceptable.


    EDIT: 09:40 and the wireless link dropped again. By the time I got to the Linksys the light was on and when I got back to the laptop the link had recovered. This, I suppose, is a slight improvement.
  6. DaveJP

    DaveJP Network Guru Member

    Better news. The wireless link has remained up since my last post. Although the throughput is still slow at about 213kbps today.

  7. yonnage

    yonnage Network Guru Member


    Just a thought, try disabling the SPI firewall on the WAG. The Dlink DSL300G+ doesnt have NAT or SPI and it could be that which is slowing it down

  8. DaveJP

    DaveJP Network Guru Member

    Thanks for the tip, I just tried it and, sad to say, it made no difference.

    On a happier note though the thing has been a lot more stable since the firmware update. I did have a total loss of wireless yesterday even though the wireless led was still lit. a power cycle fixed it though.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice