Issue with the Bandwith Monitor this morning

Discussion in 'Tomato Firmware' started by spookyneo, Jul 24, 2010.

  1. spookyneo

    spookyneo Networkin' Nut Member

    Hi everyone,

    I had a weird issue this morning with the Bandwith Monitor.

    I am using TomatoUSB v1.27.9047 MIPSR2-beta16 K26 USB vpn3.6 on an Asus RT-N16 router. I am still new to Tomato, so please go easy on me if I have done something wrong:)

    When I woke up this morning, none of the Bandwith Monitor features were working (Real-Time, Last 24h, Daily, Weekly, Monthly). There were all doing nothing and showing a small error saying that rstats was not responding and could not be loaded.

    My current configuration of the Bandwith Monitor is this :

    - Save History Location to Custom Path : /mnt/FIXEDUSB/Bandwith Logs/
    - Save each hour
    - Save on Shutdown

    This is what I have done next to try to get back the Bandwith Monitor:

    - Rebooted the router using the Reboot... function in Tomato: Bandwith Monitor was still not working and showing errors of rstats
    - Put the Save History Location to RAM : It worked, the Bandwith Monitor was back on track but was missing my History details.
    - I loaded my History that was in /mnt/FIXEDUSB/Bandwith Logs/ and put the Save History Location to /mnt/FIXEDUSB/Bandwith Logs/ : Bandwith Monitor was gone again with the rstats error. However, I could see the statistics in Daily, Weekly and Monthly. Weird thing, yesterday night I downloaded about 6GB, which was missing in the statistics I restored. It lead me to something else, which I'll explain a bit later.
    - I then kept the Save History Location to /mnt/FIXEDUSB/Bandwith Logs/ and selected Create New File : the Bandwith Monitor was back and working, but all my History was gone.

    As I was saying earlier, when I restored my History it did not showed the 6GB I downloaded yesterday night. However, my Save Frequency is set to each hour. According to the timestamp of the file on the USB drive, the last time the History was saved on the USB is on July 23rd at 4h11AM, which is a bit more than 24h ago. It is then logical to say that the 6GB I downloaded were not in the file. I don't understand what happened, because my Save Frequency is set to each hour, remember. One thing I am sure of, is that Bandwith Monitor was working yesterday during all day. It seems that it decided to crash last night, around 24h after it crashed on the USB.

    FYI :

    - The FIXEDUSB is a USB Flash Drive of 2GB that is always on the back of the router. It will never be taken out. Its function is to record the Bandwith Monitor logs History in case of power failure.

    Any ideas of what happened ? Am I doing something wrong ?
  2. teetee1

    teetee1 Networkin' Nut Member

    1. avoid space in the directory/file name (ex. change "Bandwith Logs" to "BandwidthLogs")
    2. test to see if the usb storage filesystem is recognized by tomato by touch a file from the command line. For example:

    ssh root@<router IP> to log in and run
    # touch /<usb storage path>/1.test

    3. Reflash the firmware.

    4. Get a UPS for the router for the power failure. It helps in the long run.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice