Issues regarding IPv6 6to4 tunnel

Discussion in 'Tomato Firmware' started by Jermin, Jun 21, 2011.

  1. Jermin

    Jermin Networkin' Nut Member

    My network environment:

    Router: Buffalo WHR-HP-G54
    Connection: PPPOE
    PC #1: Windows 7
    PC #2: Debian
    Smart Phone: Motorola Milestone (Android)

    I've downloaded firmware tomato-K26-1.28.7821MIPSR1-Toastman-ND-MiniIPv6 and successfully flashed it to the router.

    Then I chose 6to4 Anycast Relay as the service type in Basic >> IPv6 sectoin in the router configuration leaving other fields at default and restarted PC #1.

    Issue #1

    After rebooting, I was able to visit IPv6 websites successfully. :thumbups: But soon I discovered that the IPv6 connection speed was a lot slower than that when directly dialing-up to the Internet. When connecting directly, I can watch 720P videos on Youtube (IPv6) without a hiccup. But when connecting through router, the 360P videos are caching every 5 seconds. :wall:

    After some experiments, I found out that the connections speed is going slower as connection time increases. If I disconnect Internet and redial, the speed is back to normal. But as time passes, it becomes slower and slower. But I haven't found any problem with other sites yet.

    Issue #2

    I had occasionally received a slow IPv6 connection when dialing-up to Internet directly. But this could usually be solved by a redial. However, after I redialed on the router, I couldn't connect to IPv6 websites anymore. :angry: And I found 2 IPv6 addresses when executing ipconfig /all in command prompt. The second one got depleted in a few minutes and then disappeared.

    Issue #3

    I need to use a hosts file to visit websites that have both IPv4 and IPv6 connection on both of my PCs and my phone. The content of the hosts file is provided here. This list is frequently updated. So I was thinking whether there is a simple solution.

    I have tried adding a IPv6 DNS server in the IPv6 settings of router and then shifted up the precedence of IPv6 prefix in prefix table. But I couldn't access any IPv6 websites after that.

    I've also tried uploading the hosts file to the router through WINSCP and then addn-hosts this hosts file in Dnsmasq custom configuration section. But the hosts file was reset to the original one upon reboot.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice