iTunes Home Sharing with Tomato Shibby?

Discussion in 'Tomato Firmware' started by veinypea, May 18, 2014.

  1. veinypea

    veinypea Reformed Router Member

    I am running Shibby 1.28.0000 MIPSR2-116 K26AC USB AIO-64K and I cannot seem to get iTunes homes haring to work. Anyone using Home Sharing and, if so, are there certain setting in Tomato that I need to enable?
  2. s44

    s44 Networkin' Nut Member

    You probably have to enable multicast...
  3. veinypea

    veinypea Reformed Router Member

    How do I enable multicast? I tried Advanced-->Wireless-->Wireless Multicast Forwarding-->enable for each frequency and still would not connect.
  4. mmosoll

    mmosoll Networkin' Nut Member

    I resolved problems with bonjour/multicast using the following parameters ( e4200 with TomatoRAF v1.28.9011 ):
    • Firewall/Multicast/Enable IGMPproxy and LAN: checked
    • Wireless Settings (2.4 GHz / eth1):
    Multicast Rate: 1Mbps
    Wireless Multicast Forwarding: Enabled​
    • Wireless Settings (eth2):
    Multicast Rate: 1Mbps
    Wireless Multicast Forwarding: Enabled​
  5. veinypea

    veinypea Reformed Router Member

    So with the above settings I can get the Remote app on my iPhone to connect to my iTunes library correctly. With this I can control iTunes on my computer from my phone. For this to work Home Sharing is supposed to be working.

    Going the other direction when I try to use Home Sharing to play my iTunes library from my computer to my phone it does not connect.

    For some reason when I change the multicast rate from Auto to 1Mbs and save it, it returns to Auto when I leave the wireless settings page and come back to it. Not sure if this is my problem. iTunes could be just messed up somewhere as well.

    Any other options?
  6. Edrikk

    Edrikk Network Guru Member

    I've also found this issue with setting going back to Auto just today.
    This is on Shibby 118 build, on an R7000.
  7. Chad Burks

    Chad Burks Networkin' Nut Member

    Had the same problem...Enable Udpxy at Advanced>Firewall>Multicast. That was the only thing I had to do. E4200 with Tomato RAF Firmware v1.28.9014 MIPSR2-RAF-v1.3d K26 USB.
  8. veinypea

    veinypea Reformed Router Member

    Perfect. That is all I had to do as well. Enable Udpxy and it worked. Thank you.
  9. veinypea

    veinypea Reformed Router Member

    This worked when I initially changed the settings. Now I can't get it to work again. On my phone I can see the name of my iTunes library but the circle icon only loads half way and then nothing happens. It very well might be something buggy with iTunes.

    Anyone experiencing similar intermittent connectivity with Home Sharing? What did you find you had to do to get it working again?
  10. veinypea

    veinypea Reformed Router Member

  11. Mangix

    Mangix Networkin' Nut Member

    LAN traffic is not blocked in any way by the router.

    Windows Firewall is a different story.
  12. JoeDirte

    JoeDirte Networkin' Nut Member

    I've had to disable IPv6 on my iTunes machine in order for it to "see" my apple tv and for home sharing to work consistently.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice