Jac4 Firmware NAS200 - NFS

Discussion in 'Cisco/Linksys Network Storage Devices' started by Jerome59, Jan 29, 2010.

  1. Jerome59

    Jerome59 Guest


    I want to enable NFS server on my NAS200 but i can't find any tuto to explain how to do it... I'm using Jac4 V3R79 alternative firmware.
    insmod nfsd.ko return an error "no such file or directory ( -1 )"
    I know i have to copy nfs binary but i don't know which, where and which files are to be modified...

    Thanks a lot... sorry for my english...
  2. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    The error occurs because you will need to install many more kernel modules. I think the Jac0 thread in this forum has a posting that contains a list of which modules to load, but then you're still not there yet: you will need the NFS tools and I'm sorry but I don't have those available...

    I think everyone lost interest in NFS when we found out that it makes the NAS even slower: between 1 and 2 MB/second. It just makes more sense to add Samba to your Linux machine.

  3. morgan_greywolf

    morgan_greywolf Addicted to LI Member

    Actually, Jac, NFS should, in theory, be faster. NFS is a much lighter and more efficient protocol than CIFS/SMB. Probably in order to get faster speeds, you need to tweak the NFS client with mount options like rsize, wsize, and probably the ac* options.
  4. gusotto

    gusotto Addicted to LI Member

    User Space NFS..

    Jerome, attached find the Userspace NFS server, that way no kernel modules are needed. Also included is the portmapper.

    These have been compiled optimized as much as I can..

    To install,
    a) Copy the files to /harddisk/Volume_x/conf
    b) create and exports file...
    something like: /path/to/export,no_root_squash)
    that will give all access to the exported directory from any machine in the network. (adjust for you network.. :-D)
    c) kill samba
    d) run portmapper
    e) run unfsd -e /harddisj/volume_x/your_exports_file

    Mount NFS volume from client..
    You can then figure out how to automagically run it with the early.sh script...


    Attached Files:

  5. josvankesteren

    josvankesteren Reformed Router Member

    Signed up to this forum to get unfsd.zip, but when I am logged in, I still do not have the permissions needed to download attached files.

    Could someone please fix this ?
  6. josvankesteren

    josvankesteren Reformed Router Member

    Tried again, and now it works.
    Whoever fixed this, thanks :)
  7. invcat

    invcat Reformed Router Member

    I tried to download, but I also received a message that I not have permission.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice