JFFS not working

Discussion in 'Tomato Firmware' started by nsymms, Jun 30, 2007.

  1. nsymms

    nsymms LI Guru Member

    I've recently installed v1.07.1040VPN and everything works well. Sort of.

    I want to store the OpenVPN certs in the /jffs partition because they're rather large. I enabled JFFS2 and then copied my certs there. OpenVPN runs fine, but when I power off or reboot, the JFFS partition comes back empty. And of course OpenVPN doesn't work until I reload the certs.

    Funny thing is that even when JFFS is empty, it reports "size/free 700K/380K". After loading my certificates I think the free size is around 372K.

    Any ideas? I've searched the forum and other places and nobody else seems to be having any problem with JFFS.

    Thanks. And, Tomato looks great from what I've seen. I really like the web interface and bandwidth monitoring. It's what every router should have. There's almost no need to telnet / ssh into the router.
  2. azeari

    azeari LI Guru Member

    it could help to post which device you've installed tomato on.

    also, i believe size/free refers to the compressed size and real size of the file system. (= beyond that its hard to diagnose the problem.

    Stuff you could try
    1. Disabling, and reenabling jffs2
    2. reformatting the flash system
  3. nsymms

    nsymms LI Guru Member

    Yeah, sorry for not mentioning the hardware. It's a WRT54G v1.1. And I tried disabling JFFS then rebooting, then re-enabling, reformatting, but still the data in /jffs gets lost when I reboot or power off.

    There are workarounds; I'll wind up putting everything in inside nvram. But it would be nice to get it working with jffs.
  4. azeari

    azeari LI Guru Member

    hmm i guess this could be logged as a problem with the v1.1s.. (= for now i guess you'll have to live with the workaround
  5. MarioT

    MarioT LI Guru Member

    I get the same issues (with a WRT54G v1.1 too..) From the logs, all I can see is that while mounting the partition, it complains about invalid entries and takes care to wipe them out. I decided to use cifs intead.
  6. mstombs

    mstombs Network Guru Member

    I don't currently have access to tomato to test but - does it have the Linux or busybox "sync" command which flushes cached entries to file, or can you stop any processes that are accessing the partition and dismount it with "umount". A good flash filesystem management process minimizes writes to minimize flash wear but should clear any ram cache before shutting down.
  7. nsymms

    nsymms LI Guru Member

    Tried the sync / umount / mount sequence. Same story. I did like MarioT and looked in the dmesg output. When mounting the /jffs partition, the tail of dmesg looks like this:
    <4>nvram_commit(): init
    <4>nvram_commit(): end
    <4>nvram_commit(): init
    <4>nvram_commit(): end
    <5>jffs2_scan_dirent_node(): Name CRC failed on node at 0x00090050: Read 0x29be688b, calculated 0xfebfef8a
    <5>jffs2_scan_dirent_node(): Name CRC failed on node at 0x00090108: Read 0x304680db, calculated 0xdd720ec1
  8. azeari

    azeari LI Guru Member

    i guess it could be a case of old and failing flash memory on the router, how old is the router may i ask?
  9. nsymms

    nsymms LI Guru Member

    The router is over 6 years old, but I doubt it's an NVRAM failure. Are there any tools to check?

    I've recently converted to Tomato from OpenWRT and never had any problems with NVRAM before.
  10. MarioT

    MarioT LI Guru Member

    Any success report for WRT54G v1.1?

    Before blaming the flash chip itself, I'd like to know if someone has been able to get JFFS to work normally on that specific router: WRT54G v1.1

    I know they're not recent machines, but I find it weird that flash would already be worn out, unless JFFS was used before to keep files that change too much.

    Also, I would expect failure while loading the base firmware image too.
  11. digitalgeek

    digitalgeek Network Guru Member

    As there are two V1.1's in this thread with similar problems, could it be an incompatibility with the older hardware...

    nsymms: is there a problem with storing this info on cifs and having your openvpn point here instead of jffs?
  12. nsymms

    nsymms LI Guru Member

    No problems storing it in cifs or in nvram variables. It's on a cifs share now.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice