jffs2 bricks router

Discussion in 'General Discussion' started by redcow, Sep 14, 2006.

  1. redcow

    redcow LI Guru Member

    I'm sry if this is the wrong section but it affects so far every third firmware so...

    i got a WRT54GL 1.1 and flashed it at first with dd-wrt 2.3sp2 and used jffs2 with no problems after that i tried the tomato firmware no problems so far but i wanted to use jffs2 and it didn't worked so i played around with the mount command to mount it manually but the jffs2 partition by dd-wrt created seemed to be corrupted:

    so i thought maybe a tomato bug and reflashed back to dd-wrt after a few lockdowns and recovery's by tftp even dd-wrt didnt recognize the jffs2 partition or couldnt format it:

    so every time i use the jffs2 partition my router gets bricked and i have to flash back to the original linksys firmware and after that to the third part..

    My question is there a way to "clean" or reformat by the "hard" way the jffs2 partition? something like overwriting with zeros using dd or so. It looks like /dev/mtdblock1 is the jffs2 partition so maybe with dd + /dev/urandom.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice