Jumbo frames on ASUS rt-n16?

Discussion in 'Tomato Firmware' started by rs232, Dec 27, 2010.

  1. rs232

    rs232 Network Guru Member

    Hello, I'm running the Victek module and have been playing with the jumbo frames settings.
    I don't see a way to make this working, the interface doesn't change the actual interface/vlan/br MTU
    I've tried to change this manually using ifconfig and vswitch but despite the new mtu is accepted and changed according to the system this still doesn't work.

    I've verifying this using a ping from my windows 7 laptop pinging the IP of the router itself (as a starting point)

    e.g. ping -f -l 4000 x.x.x.x

    This is not working unless I drop the length to 1500 or below (thus no jumbo frames are sent or received)
    Has anybody managed to make this working?

    The nic of my LAN devices (atheros and broadcom) all support gigabit speed and jumbo frame. I've manually set these to use jumbo frames up to 9K.

  2. occamsrazor

    occamsrazor Network Guru Member

    I created a new thread here as I've a similar question but about a different router (E3000) however you may find some of the links there useful...
  3. rs232

    rs232 Network Guru Member

    Thanks! i did my homework with google before posting and run pretty much on the same links :)
    I don't have an answer either... my feeling is that the HW can but the current software is not pushing the HW properly. Perhaps an input from the mod developers can help? Teddy_bear? Victek? Anybody else?

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice