just fried my wrt54g when flash from Alchemy6 to -> Hyper

Discussion in 'HyperWRT Firmware' started by azz777, Nov 18, 2004.

  1. azz777

    azz777 Network Guru Member

    SOS, please help, thanks alot in advance.

    "No, this step in not really needed when updating from linksys or hyperwrt firmware, but highly recommanded when upgrading from sveasoft or wifibox. Will change this step to optional on my site."

    I just fry my wrg54g when I tried to flash back to HyperWRT from Sversoft alchemy v6 without "reset to factory default". I am able to tftp with linksys firmware now only wireless works but all the 4 switch lan ports fail to get ip. and wrt54g can't get ip from my cable modem. I am able to login to the web admin through the wireless, but that is.
  2. u3gyxap

    u3gyxap Network Guru Member

    Do a hard reset.
  3. azz777

    azz777 Network Guru Member

    you bet I hard reset it hundred times. in fact, I even able to get into its web admin interface through wireless, but just not lan on the 4 switch port and no internet. I just found same problem with this guy here:

    (My Linksys WRT54G *sob sob*)
  4. Toxic

    Toxic Administrator Staff Member

    hard reset (press reset for 30 seconds) then make sure your 1st PC is wired to Router. once this is done make sure the PC either has a local static IP of or it is automatically assigned. then cablemodem may need either the router to have the mac address cloned (set in Router), or the cablemodem needs to be rebooted.
  5. toolio

    toolio Network Guru Member

    There are many ways to bring your router back to life, Most of them are well documented on the Sveasoft forum. Since you were using Sveasoft firmware, you are familiar with that forum. Look around there.

    Try this: Since you have wireless access but no connections to wired ports, reflash your WRT54G using wireless. I have brought my router back to life this way after suffering exactly the same problem as you. It's not the preferred way, but will work fine if you have a stable wireless connection.

    I would recommend flashing with an official Linksys software first, then go back to hyperwrt. There is also a special reset version of software on the Sveasoft site which will flash your router back to basic settings. Look for it and follow the instructions. Do not use your router with this--upgrade to another firmware after using it.
  6. Avenger20

    Avenger20 Network Guru Member

    It's best to reset Sveasoft firmware to default before upgrading to HyperWRT or any other firmware. When too much services are started , the free memory may become low and upgrade may fail.
  7. azz777

    azz777 Network Guru Member

    (I manually set ip on my pc and continue pinging the router.)

    to Toxic: I tried that too. in fact, I put back linksys firmware to wrt54g through tftp using wired port 1 since everytime when I reset the wrt54g, I got 5 sucessful pings through lan port1. It said successful after tftp, and I confirmed it when I login to the wrt54g through wireless.

    to toolio: after I login the the admin page through wireless, I also try to flash to other firmware from linksys, but non work.

    I also tried shorting pins 15-16 on the amd flash (no intel flash), it basically reset the router itself. I spent over twenty hours reading many place likes svasoft forums, here and googling. Still no go. Please feel free to say your thoughts as I'd like to try again to bring it to life. Thanks in advance.
  8. Toxic

    Toxic Administrator Staff Member

    so you can ping your router yet you say it is dead?

    if it is dead it will not respond at all.

    I just upgraded from ALchemy 6 to Hyperterminal just now without any problems.

    If you can ping your router then it will respond to tftping a binary (less than 3mb though)

    firstly download on of the linksys window updater and try flashing with that first.


    run that and try upgrading the router that way first

    if not

    download a 2.02.2 again to a new folder and use this tftp file.


    extract both the tftp.exe from zip and the 2.02.2 binary into a folder.


    then run the tftp file and enter passowrd admin and selct the WRT54G_2.02.2_US_code.bin file. then try upgrading.
  9. azz777

    azz777 Network Guru Member

    hi Toxic, I said "continue to ping the router" and "everytime when I reset the wrt54g, I got 5 sucessful pings through lan port1"
    I were able to tftp to the original linksys firmware in that few seconds, however, that's the only time I got sucessful pings through any of the wired lan ports. As from the link I have in my first post, that guy said his wrt54's expensive switch, it is the same here.
  10. azz777

    azz777 Network Guru Member

    hi Toxic, I just realize the firmware in your previous post is for wrt54g v2 only, mine is the V1 with AMD flash memory. I used version for tftp.
  11. azz777

    azz777 Network Guru Member

    to Toxic, I take that back. firmware 2.02.2 is for both wrt54g and wrt54gs. I just flash that too. same old thing. only wireless, no wired. :(
  12. toolio

    toolio Network Guru Member

    Don't know whether you fixed your problem, since it has been a few days since the last post.

    One other possibility is that you have to clear out the nvram. This will get rid of any strange configurations that might stick even after a firmware upgrade.

    I've done it before to solve lingering problems, but unfortunately I can't remember how. I would search the words "nvram erase" on the Sveasoft forums. It has been explained there a few times. Or perhaps somebody reading this can recall the method.
  13. azz777

    azz777 Network Guru Member

    no, I still have not fix it yet. I'll try to find info. on clearing out the nvram. thx
  14. atzplzw

    atzplzw Network Guru Member

    I also got some problems today when upgrading different firmwares.
    My router ended up with the power led flashing all the time.

    So I thought I have to use the voidmain trick. But this wasn't the case.

    I just used the instructions on the HyperWRT pages (Case 2).
    I needed to wait at least 5 minutes.

    Even the flash was ok the led wouldn't stop flashing. Then I left the router and when I came back after 5 min it was just there as normal...

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice