KNOWN BUGS: found one? Let us know! Wondering? Look here!

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by jdepew, Apr 23, 2004.

  1. jdepew

    jdepew Administrator Staff Member Member

    At a members suggestion, I'm going to start this sticky for all to see. This may become something common to the hardware forums if it proves to be sucessful.

    So, you wanna know what bugs there are in a firmware? Well, here's the chance to put them all in one place. If you know of a bug, let us know!

    Include the Product, Hardware revision, Firmware version, Official Linksys hacked firmware, and of course the problem.

    For example -
    I understand there is are issues with establishing sucessful reliable VPN connections in the WRV54G (if you've got details on it, by all means...share).

    WRV54G, ver1.0, Linksys v 2.25.2

    Have at it - I will update this post as you find new bugs!
  2. Anonymous

    Anonymous Guest

    Bugs I have found

    VPN passthrough does not work. The only way to get native Windows VPN to work is to put the VPN server in the DMZ. For small networks with only one server this means your only server and active directory, exchange, etc must be exposed.

    Also about once a day the wireless access goes away. The router continues to work fine but the wireless doesn't register and the router must be turned off and on to regain access. The longest it has ever stayed up is 2 days without a reset.

    BTW: Linksys will not acknowledge either of these bugs, though they will admit to multiple reports.

    WRV54G, ver1.0, Linksys v 2.25.2
  3. Nige

    Nige Network Guru Member

    I bought a WRV54G the other day, because I wanted the VPN functionality and I was upgrading from the BEFW11S4 which had got into the habit of dropping the connection from my Samsung X10 on a very regular basis. I know it's not the X10's fault because other wireless routers and access points behave impeccably with it.

    However, since I bought it it has been extremely troublesome. I immediately upgraded to the 2.21 firmware, which was the latest that I found from the UK web site links. I can't remember what the firmware was before I upgraded it, I didn't check. I had loads of trouble getting back into the router after upgrading the firmware, the only way that I could manage it was eventually doing a hard reset, which meant that I had to re-enter all the router settings too.

    So anyway, now it kind of works. I say 'kind of' because it needs to be powered off and on at least every day, usually more than once, because the built-in wireless access point disappears. This is a pain, and from the other posted messages I see that others have had the same problem, and that it is not isolated to this version of the firmware.

    So I'm still running with 2.21, but if the firmware version 2.25.2 doesn't fix the bugs that bug me, and I have no interest in using the Boingo features, I see no real reason to upgrade until Linksys decides to fix the existing issues.

    WRV54G, ver1.0, Linksys v 2.21
  4. Toxic

    Toxic Administrator Staff Member

    OK guys sveasoft is gonna take a look at the firmware. he cannot promise anything but here's hoping.
  5. jdepew

    jdepew Administrator Staff Member Member

    Good news Simon. And to everyone submitting bugs so far - good looking out!
  6. JonAlthoff

    JonAlthoff Network Guru Member

    I spoke with James a while back. I haven't heard anything from him lately. Just about everyday I try to compile the firmware for the WRV54G without luck. I don't really know what I am doing but I am learning. No one else seems to be doing any work on trying to compile the firmware. I posted a message on the forums in Sveasoft firmware.

    Here is the Link:

    Is there anyone else interested in compiling firmware?

    I just realized these are also old messges from May. James had said he wanted to purchase a unit to test on. I went ahead and subscribed hoping my little contribution would help.
  7. roognation

    roognation Guest

    WRV54G Troubles

    Running 2.25.2 firmware from the Linksys site.

    I have to reboot this POS about three times a week due to some kind of DNS failure. Normally, I am able to browse the web without trouble, but the router likes to lock out name recognition after a couple of days. This is the only thing I can relate, as browsing to an ip address like is fine, but trying fails. Power cycling the unit fixes. Running this unit behind a Toshiba cable modem: PCX-2000; not sure if that has anything to do with it.

    Also wondering about VPN, and maybe I haven't done my homework, but I can ping my remote vpn client, but am unable to browse the shared files/resources on that machine. Is there some magic software glue that will make these two machines see the shared resources (using WinXP Pro) ?

    Would love to know about some hacked firmware to try, but nothing appears to be explicitly designed for the WRV54G, and it looks like there are compile duties required, not one of my specialties.

    After I get those two items up and running, I will venture down the wireless path to see if anything is amiss there.

    Any help is greatly appreciated!
  8. Razor

    Razor Network Guru Member

    WAP incompatibility

    Hardware rev0.2
    Firmware 2.25.2

    This router will not work with a Netgear WG111 - see by me
  9. yonnage

    yonnage Network Guru Member

    I have an RV082. using load balancing. When I log into the web based GUI I cannot see anything under system information. Or more precise, there is no system management button. its gone. This is the second unit this has happened to now. first one lasted 3 weeks, this one 23 hours
  10. stability

    stability Guest

    WRV54G and PPPoE don't mix. (v2.36 firmware)

    using the WRV and my broadband PPPoE connection isn't possible, the router appears to work fine with static IP or DHCP setup but when I connect it directly to my broadband connection ( instead of behind another router ) it fails to asign the correct subnet mask ( and won't let me designate the subnet ) the radius server it connects to sends all the correct info but instead of accepting the information from the RADIUS server it sets the subnet mask to (class A network) and will no longer route between internal and external networks, also it can't even ping (using the diagnostic feature on the admin setup page ) if I give it an IP address which I know exists.

    After spending HOURS on the phone with linksys tech support and doing the same mindless tasks repeatedly they told me it must be the router and I returned it, got a new one and Yeah, I have the same problem.

    Hopefully they can get this fixed, I picked it up for the VPN and Wireless capabilities and I need both, not just one :(
  11. JonAlthoff

    JonAlthoff Network Guru Member

    BEFVP41 V2

    On a VPN tunnel's Remote Security Gateway you cannot use a public IP address with 255 in it. I am trying to connect an older functioning location with a BEFVP41 V1 and a new BEFVP41 V2 with 1.00.13 firmware. I cannot enter 255 on my IP address for the other VPN Router. It works fine on the BEFVP41 V1.

    An easy solution was to create an addtional DNS name. This has solved the problem.
  12. mmeysarosh

    mmeysarosh Network Guru Member

    Have beta firmware and direct support for Linksys/Cisco


    I am an admin for a midsize engineering firm and we run the mix of the Linksys and Cisco router series.

    I had recieved direct support from Cisco about the two RV016 routers that I have and I do have the WRV54G (for our IT director) at the other remote site.

    I currently have a beta firmware for the RV016 at version 1.32 from Cisco directly that I know resolves the VPN issues that does exist on the unit. I believe that the version on the website is 1.2.3.

    Unfortuantly it appears that the RV082 is the unit that recieves the most attention from the group but I can directly address the technical staff at Cisco as I am about to do so today with the load balancing issue I have today (not really a bug but more of an oversight).

  13. JonAlthoff

    JonAlthoff Network Guru Member

    BEFVP41 Ver 1

    I thought I put this on here but cannot find it.

    I have 2 sites that will not connect VPN. I am using client on a workstation. The IP address pulled from PPPOE on one site is for example: and I'll call it site 1

    The other end (both BEFVP41 Version 1 routers) is: and I'll call it site 2

    >From a UNIX machine I can ping from Site 1 without probems. From Site 2 on another UNIX machine I can ping site 1 and receive a response from I am guessing that since I am trying to ping a broadcast address that is why I am getting a reply from myself. Windows 98 machines on site 2 can ping the public IP address of site 1 no problem. I would guess the DNS servers entered take care of this.

    My question would be: Is this a problem with Linksys hardware not being able to connect to the 255 broadcast address or is this a problem with the subnet mask assigned to me by my ISP? Is there a way I can determine the sub-net mask of my public IP? Would this be DNS functions in the routers firmware causing the problem?

    My solution was to unplug the router for 5 mnutes so I could get a new IP address from my ISP for both sites. unfortunatly I still received as a replacement IP address. Only changing site 1 fixes the problem.

    -----===== Response from Linksys =====-----

    Have you tried pinging the computers hooked up on each network? If you are able to ping the computers on the network, then the tunnel must be connected. As of the moment the latest firmware available for this router is firmware version 1.41.1 for BEFVP41 and firmware 1.00.13 for BEFVP41 version 2.

    Email us for any feedback. Thank you and have a nice day!

    If you have further questions, please contact us at (800) 326-7114 or send us an email at so that we may further assist you. Please use this phone number given as reference for future support calls.

    -----===== My reply =====-----
    Ping which computers? When the VPN tunnel tries to initiate site 2 simply tries to connect to itself. It will never reach site 1 because of the 255 broadcast IP address. Site one contacts site 2 but never receives a response from Site 1.

    Obviously the customer called me with a problem using the VPN. My troubleshooting lead me to the problem and the resolution. What I need to have done now is to have Linksys check the firmware in the router and double check the problem exists or does not exist and fix the BUG in the firmware. The thing that makes me uncertain of the problem is the public IP address and sub-net of the public IP address. I am not very clear on sub-net masks.

    If I have a computer with a public IP address with sub-net and another public IP address on with sub-net wouldn't they be considered to be on the same network? The communication I send to being a broadcast address sends it to 23.24.25.ALL right? Shouldn't my sub-net mask be something like or even? Can I check this in any way?

    I just re-read my message. I states that I cannot connect VPN therefore pinging computers on the opposite side of VPN tunnel will fail every time.
  14. TazUk

    TazUk Network Guru Member

    Re: BEFVP41 Ver 1

    It should say on the Status page on the router.

    Personally I'd say this was an ISP related issue rather than a bug in the Linksys firmware as a .255 address would not normally be used. Although that is dependant on the subnet mask used.
  15. JonAlthoff

    JonAlthoff Network Guru Member

    This maybe should be moved since it's going to be a discussion.

    WAN information given is only IP and DNS. Subnet mask is not given for PPPOE and I wold guess... I'm checking another remote location... or 2. I have another one I checked Static and it does report Subnet mask and another that is Road Runner and DHCP. It gives the Subnet mask as well.

    I checked another location with PPPOE. PPPOE does not give the subnet mask and gateway information. These are all version 1 BEFVP41's that do not report GW and Subnet mask on PPPOE. I checked a version 2 BEFVP41 and it reports subnet mask and gateway.

    Why would I want a subnet mask of and not something more confining? I'm not 100% understanding of subnet masks but have a good basic idea of how it works.
  16. TazUk

    TazUk Network Guru Member

    I'm not familiar with PPPoE I'm afraid as it's not used in the UK :?

    The more subnets you have the less usuable IP's ;) For a subnet mask of you will loose the first and last IP's as they are reserved for the network and broadcast addresses. If you decided to split that into two smalled subnets then each of those would need a network and broadcast address so you would loose 4 addresses out of the 256, and so on,
  17. JonAlthoff

    JonAlthoff Network Guru Member

    I only get one IP address from my ISP. Why would I want my subnet mask to to contain any other IP address?
  18. TazUk

    TazUk Network Guru Member

    It's not for your benefit it's for the IPS's :)

    For one thing they couldn't subnet it so you only had one IP address, the smallest would be two. To give you those two addresses they would need to allocate a block of 4 IP's, the two usable plus network and broadcast addresses. As you can see this wastes a great deal of addresses so out of a block of 256 IP's they would only get 64 customers.
  19. JonAlthoff

    JonAlthoff Network Guru Member

    That makes sense to me. It's just that the ISP is going to 255 and they should stop the block of IP addresses at 254. They should not be using: through

    It should be split through through
    and through

    I suppose saving a few IP addresses may be a big benefit for them vs. the trouble it will cause for the few. Can there be other issuses arise due to this? I would guess so. I suppose the individual IP addresses should not be communicating between each other but... 2 Unix computers through a router that need to connect to each other could have trouble with communications.
  20. LoneRegister

    LoneRegister Network Guru Member

    Blow up the router

    I have noticed that my BEFVP41 V2 dies and resets when hitting it with DSL reports bandwidth tester. Additionally, it also appears to reset during other high bandwidth times as well.
  21. Johnster

    Johnster Guest

    I am wondering if this is a fluke, and other are using this configuration, or if it is a bug that needs to be corrected.

    I have tried to install a RV016 16 port VPN router, when I set up everything and test it from home, it works great. (With a dynamic IP.)

    But at the customers, I set up the router with a static IP, and it will not connect. I cannot ping the gateway.

    But if I connect anything else direct to the DSL modem I am connecting to, it works fine... the only configuration that doesn't work is when I connect the RV016.

    I contacted Linksys support... had one technician tell me that he would send me a firmware revision of 2.0.4, which was in beta, which is known to correct this issue (I am currently running 2.0.3.)

    But because they had the wrong email address (Thanks in part to outsourcing to India, or whatever 3rd world country it has been outsourced to.) I never recieved this firmware revision.... So I asked the next technician if he would resend the firmware.

    Well, the next 4 technicians I am transferred to all say there is no 2.0.4 revision. (Although one of them tried to tell me that 2.0.0 is the most recent firmware for the router... so I imformed him that I am running 2.0.3 now.)

    So, it is either a bunch of bad technicians, or one really bad technician that would outright lie to me about what he would do to correct the problem. (I'm torn... the technician that told me he would send the 2.0.4 seemed the most familiar with the problem... but he could have just told me something to get me off the phone.)

    Anyway, I would like to know if anyone else is using this router with a static IP now. (It seems unlikely that no one else is using it with a static IP.)

    It's either a huge bug they need to squash, or a defective router... I guess I will know soon enough. :roll:

    RV016 will not connect to a static IP.

  22. NeoTech

    NeoTech Network Guru Member

    RV082 v1.1.6.11 failings

    What the RV082s can NOT do is

    1) Use their routing tables to allow IPSEC0 as an interface in a static route to route traffic via a VPN.

    2) Propagate routes via RIP1 or RIP2 over VPN tunnels for effective dynamic routing.

    3) Use their routing tables to determine the interface for an internal DIAGNOSTIC PING (one VPN endpoint cannot PING the other VPN endpoint).
  23. jatkins679

    jatkins679 Network Guru Member

  24. blacklotus

    blacklotus Network Guru Member

    i have setup extensive access rules based on time of day and i noticed that if a tcp session is inprogress when a deny rule kicks in, it will not interrupt that session. it mostly renders these rules useless.

    also, when is there going to be AES for the RV082 and QoS for the RV042?

    i would install so many more RV042's if they supported QoS. port based qos is ok but the ability to handle Layer 2 TOS or Layer 3 Diffserv or even to define rtp traffic to prioritize (and possibly tag it) would be nice.
  25. BigLeagues

    BigLeagues Guest

    RV042 Quick VPN

    I have spent a good part of the last ten days back and forth with Linksys Tech support with regards to getting a Quick VPN connection established on the RV042.

    I'm not sure how many other people reading this may have had an issue with this, but I'd like to hear if you found a solution. I now suspect, though Linksys won't acknowledge, that the firmware is a complete disaster.

    Without getting into the blow-by-blow account of the 10 phone calls and several emails . . . here is a brief synopsis of where I'm at:

    1) Using the out of the box installed current firmware version . . . No matter what Username and Password combination I created, none worked but one . . . . User: test, Pass: test

    2) Tech Support didn't believe me. So I granted them access to my network, they tried everything they could think of . . . I was on hold for 25 minutes. They came back, admitted they got the same exact result . . . that they couldn't connect with a Username and Password other than test:test

    I was told that I would recieve an email with a "Beta version of unreleased firmware" to try. The tech told me he was confident it would solve the problem. "You'll have the firmware in 3-4 hours" I never got the email. I called the next day and apparently they had mispelled my email address. Linksys corrected my address, then told me they would send the email right away . . . "expect it in 20-30 minutes" Three phone calls later that day, I was told that there was no unreleased Beta Firmware. That I need to downgrade my firmware to

    3) I install firmware. Input a username and password other than test:test, try and connect using QuickVPN, begins the negotiation process, and hangs on verifying network . . . and eventually states that it is disconnecting from network. Then I try using test:test . . . and I get the same result . . . hangs on verifying network, then disconnects.

    So has anyone had similar issues? Solutions? Based on this experience and all the wasted time, I have no desire to use this product again, but I am curious if anyone has any similar experiences.
  26. rangermonk

    rangermonk Network Guru Member

    The WRV54G (fw. 2.38.6) problems I've experienced:

    1) Microsoft PPTP server won't work behind the WRV54G. It will not forward GRE 47 to the PPTP server. I can put the same PPTP server behind a WRT54G, and PPTP server works great. Seems through lots of testing from alot of ppl on this site, that Linksys has disabled it to utilize their QuickVPN client software with the WRV54G, and nothing else.

    2) I haven't been able to use the QuickVPN client software and the site to site tunnels at the same time. I can disconnect the site to site tunnel, QuickVPN works fine. I reconnect the tunnel, no QuickVPN.
  27. Parkoon

    Parkoon LI Guru Member

    RV082- incoming & outgoing log table.

    How to view all logs on RV082(Firmware

    RV082 have 4 log option buttons.
    - View system log
    - Incoming log table
    - Outgoing log table
    - Clear log

    Shoud I set something on the RV082 or PC to view incoming and outgoing logs?

    or Just click its, then Incoming/outgoing logs shoul be shown?

    If I have to check something to use that funtions.
    Kindly, Let me know what it is.

    *I tried to change Firmwares : / ===> Same.... There was no log infomations on log table.

    **Not easy to understand this? Sorry, I'm poor in English..... =)
  28. Toxic

    Toxic Administrator Staff Member

    Selective Acks are Blocked from Operating system. confirmed using

    report shows Selective Acks OFF even though Operating syetm has them enabled.

    Throughput is thus lower across WAN at least. not tested via LAN.

    can anyone confirm the WRV has this problem as well?
  29. Xphyr

    Xphyr Network Guru Member

    NAT and Multiple subnets

    This has been an outstanding problem since I bought the RV082 and thus far I have not been able to get anyone to acknowledge this is even an issue. But if you take a look at this posting you will see that it is more than I having this problem. Anyway, the issue is trying to NAT two subnets (ie. 192.168.1.X and 192.168.2.X) This works on EVERY other Linksys router without a problem. (Well I can't say all, but the BEFSR41 and the very first Linksys router worked ok anyways). The way it should work is that the RV082 should NAT anything outside and route anything on the inside...

    ASCI ART removed .... couldnt get it to format correctly...

    The setup is Cable modem into the WAN port, and DSL into the DMZ/Wan2 port on the RV082. The RV082 "hosts" 192.168.1.X I have a few PCs on that net, and a server or two. Then I have the WRT54G with a cable pluged inbetween the RV082 and the WAN port of the WRT54G. the WRT54G is set to be a router, and it "hosts" 192.168.2.X. I have RIP2 enabled on the WRT and on the LAN side of the RV082, and the routes show up correctly when you look at the rout tables. The problem is the RV082 drops all NAT that is not 192.168.1.X as its origination.

    The RV082 is in NAT mode, and the WRT54G is in Router mode. If I replace the RV082 with a BEFVP41 configured similarly to the RV082 the above setup works. It would be amazing if this problem could get fixed. I attempted to report it almost a year ago and got so frustrated that I gave up. I have had to move back to the RV082 because I now need the backup/load ballance features.

    Is anyone else running into this, or something similar? Maybe if I can get enough people to see/notice/report this problem we can get it fixed.

    NOTE: This is the setup I want, I don't want seperate v-lans (I want to be able to talk between 192.168.2.X and 192.168.1.X) and I want both nets to be able to talk to the internet. I know this works, and is valid... I just cant get the RV082 firmware to work correctly.

    (P.S. sorry for the double post, I placed this in the beta firmware area as well, but this is probably where it really belongs)
  30. Toxic

    Toxic Administrator Staff Member

    could you do something with the Ascii art it makes no sense.

    I take it the WRT54G is plugged into your internet connection and the RV082 is on the WRT yes?
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice