Large file transfer problem -solved-

Discussion in 'Cisco/Linksys Wireless Routers' started by gertvdijk, Aug 20, 2004.

  1. gertvdijk

    gertvdijk Network Guru Member

    My brand-new WRT54g (EU) with 2.02.7 firmware has got a weird problem... My computer is connected hard-wired and my laptop is wireless connected. My laptop has a Intel PRO 2200BG mini-pci card. I'm running Windows XP on both pcs. I'm using the Intel software to connect to my WRT since XP zero config drops my connection randomly. I've secured my network using WPA-PSK AES & MAC filter. Also Frame Burst is enabled. My laptop is only 1 meter away from my WRT54g.

    My pc has a raid configuration which has 120mb/s throughput. NVIDIA Gigabit LAN onboard NIC.

    When I try to transfer a large file over the network, it stops after 20 seconds and my DU meter shows only 2 mb/s throughput. Sisoft Sandra shows me it's capable of 3,4 mb/sec. After 60 seconds doing nothing (only 4 - 5 kb/s transfer) the wireless connection drops and I'm unable to get it back, unless a full restart of Windows XP :S

    Frame burst disabled, but still doesn't help...

    What can I try? the firmware is not known to be this crap, is it?

    Thanks in advance.
  2. fact

    fact Network Guru Member

    You might want to look into the zero-config problem, perhaps XP on the laptop is giving you problems. Somthing to try would be to switch off all security and see if WPA and/or MAC filtering are causing the problem.

    What if you move the laptop a bit further away from the AP, you might have too much signal for the receivers.

    - Harald.
  3. gertvdijk

    gertvdijk Network Guru Member

    Now I've set WPA to TKIP, but now it's even worse!
    Pining to my router from my laptop gives 30% loss and a average ping of 900ms. Although I'm very close to the router (1 meter) the speed jumps from 54 to 12 and back all the time. Sometimes the speed is 1 mbit!

    I'm not using Windows XP zero config, but Intel PRO Wireless Software.

    I'll try some other things and I'll keep you updated.

    edit: found something VERY interesting in the log of the Intel software:
    Signal quality: 40%
    Signal strength: 100% (of course)
    Missed TP things: 56%
    Attempts to transmit again: 73%

    It seems I have to choose another channel...

    I've solved my own problem: switched to channel 13 and everything is fine...!!! I choose channel 3 because my site survey showed me channel 6, 9, and 11 were in use. But it looks like a very strong signal of a channel 3 device is polluting the air.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice