Large number of UNIX sockets

Discussion in 'HyperWRT Firmware' started by mattiL, Dec 30, 2005.

  1. mattiL

    mattiL Network Guru Member

    Hi all

    My first post, so this must be historical..

    I noticed in my WRT54GS v1.1 with
    Firmware Version : v4.70.6 - HyperWRT 2.1b1 + Thibor11
    that a large number of UNIX sockets of the type DGRAM
    were shown when I ran netstat.

    I do not see anything like this in my Debian Linux, just 12 DGRAM there.

    Is this normal for a router running for :

    Uptime : 4 days, 23:49:00
    System Load : 0.00 / 0.00 / 0.00

    LAN (rx/tx) : 544.71 M (0.01 K/s) 6.23 G (0.08 K/s)

    WLAN (rx/tx) : 452.48 M (0.00 K/s) 2.71 G (0.07 K/s)

    WAN (rx/tx) : 6.13 G (0.01 K/s) 597.16 M (0.01 K/s)

    >netstat -an

    Active UNIX domain sockets (servers and established)
    Proto RefCnt Flags Type State I-Node Path
    unix 2 [ ] DGRAM 2451433
    unix 2 [ ] DGRAM 2440696
    unix 2 [ ] DGRAM 2440688
    unix 2 [ ] DGRAM 2440685

    And the list goes on, a total of 197 lines.

    Any ideas/comments ?

  2. zaphod

    zaphod Network Guru Member


    for me it seems its not a normal behavior of your router.

    i run netstat -an on my gs and got 19 DGRAM entries...

    aire you running some p2p-software like bittorrent or emule?

    have you scanned your pc for any virus, trojan or something like that... ?

    first step i would reset the router and flash it again with the thibor 11.
    (dont forget to erase nvram;reboot)

    then after setting all up again check if there are any changes...


  3. mattiL

    mattiL Network Guru Member

    Hi Zaphod

    I shut down my dreambox, printserver and my second computer was also stopped, so the only machine running was my Debian Linux machine (my workstation).

    So, no p2p software or trojans or viruses or anything else. Just my recently reloaded GS (four days since reload WITH erase nvram)

    Now it's up at 214 DGRAM...

    Oh dear..

    Thank's for the suggestions, I may try it tomorrow.
    Do you think I can restore a backup with my settings after reloading FW ?

  4. zaphod

    zaphod Network Guru Member

    cause there are many problems suggested reloading the saved-settings-file.. just take the settings complete new..

    its a try...


  5. mattiL

    mattiL Network Guru Member

    Hi again

    I reloaded the WRT with Thibor's latest (w wol) and typed in all my configurations again (and with erase nvram;reboot+ firmware defaults ).

    With uptime at
    14:20:02 up 1 day, 1:02, load average: 0.15, 0.15, 0.06

    I already have 50 DGRAM lines in "netstat -an". (it started at 13 DGRAM's)
    They may get created by the kids usage of bittorrent,
    but I do believe the should get flushed at some time.

    Is that wrong?

    Sounds like this can be some kind of resource leak.
    Would be nice to have the -p option in netstat (as in my debian)
    (please.. ! ; ) )

  6. tofu

    tofu Network Guru Member

    This may be related to the udhcpc fd leak that koitsu fixed. You can read about it at HyperWRT's forums.
  7. mattiL

    mattiL Network Guru Member

    Hi tofu

    I just recently found that thread, but thank's anyway!

  8. mattiL

    mattiL Network Guru Member

    Latest update.

    After running for 11 days (11 days, 02:24:24) the count of DGRAM's dropped from ~300 to 72, no idea why.

    WRT54GS v1.1
    Firmware Version : v4.70.6 - HyperWRT 2.1b1 + Thibor11

  9. mattiL

    mattiL Network Guru Member

    And some hour later it restrarted by itself...

    17:43:26 up 19:35, load average: 0.00, 0.00, 0.00

    Looks like some kind of starvation, or?

    Will try out Thibor12 this weekend..

  10. Thibor

    Thibor Super Moderator Staff Member Member

    with my latest, i'm currently running bittorrent and the output of "netstat -an | wc -l" is "25"
    uptime is 1 day 22 hours 28 minutes
  11. zaphod

    zaphod Network Guru Member


    what latest version? the public one (1201) or yours (1801) ??



  12. Thibor

    Thibor Super Moderator Staff Member Member

    that was with my internal, but the differences between that and 120106 are minor at the moment and wouldn't affect the number of open sockets. it's just some changes to the firewall, port forwarding and "ip neigh" addition
  13. mattiL

    mattiL Network Guru Member

    The (almost) latest Thibor12 (Jan 12 2006) does seem to have
    made some difference.

    Now I only see 5 DGRAM's with "netstat -a|grep DGRA|wc -l ".

    12:50:26 up 1 day, 1:43, load average: 0.01, 0.02, 0.00

    Firmware Version : v1.05.6 - HyperWRT 2.1b1 + Thibor12

  14. mattiL

    mattiL Network Guru Member

    With Thibor 12 it seems the DGRAM problem is gone.

    Uptime : 14 days, 02:18:46
    System Load : 0.02 / 0.01 / 0.00

    And still only 5 DGRAM's.

    Will Thibor 13c with codebase 4.70.8 go back to the old (bad) ways ?

  15. Thibor

    Thibor Super Moderator Staff Member Member

    netstat -a | grep DGRA

    unix 6 [ ] DGRAM 238 /dev/log
    unix 2 [ ] DGRAM 1342
    unix 2 [ ] DGRAM 601
    unix 2 [ ] DGRAM 377
    unix 2 [ ] DGRAM 255

    Thibor13c(and every version i have made since the problem was corrected)
  16. mattiL

    mattiL Network Guru Member


    Thank's Thibor, will try 13c tomorrow.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice