Latest ADSL2MUE New Firmware ?????

Discussion in 'Other Linksys Equipment' started by MrFLY, Dec 7, 2005.

  1. MrFLY

    MrFLY Network Guru Member

    Hi !

    Ihave read the new notice at this address


    At this address the screenshot of the new Firmware.


    I Have Burn 3 Adsl2Mue whit other firmware,not this.

    After the upgrade all modem are died :(

    In this moment i dont have much money for test this new release of this firmware but if you want test this relaese please post the results. Tanks


    Download at one of this link



    From eSnips :) Rate iT TNX

    Hi and tanks
  2. MrFLY

    MrFLY Network Guru Member

    Hi at all.
    I have buy another ADSL2MUE for test the latest beta firmware.
    I have upgrade the firmware with the file linked into the previous post

    :cheer: :cheer: :cheer: :cheer: :cheer: :

    :clap: :clap: :clap: :clap:

    Please read the doc include into the zip

    high id and port forwarding: works

    this relaese is very linksys style

  3. drewland

    drewland Guest

    a port fowarding query

    I have the ADSL2mue with the above firmware.

    now I have a query with the portfowarding interface.
    the modem is currently in nat mode.
    What I want to do is foward all ports to the firewall I have inbetween the modem and my lan

    so I have set a custom portforward from to my firewall ip.

    start port 1 end port 65535

    after clicking save the interface adds in a port map of 1

    what does this mean.
    one of the things I am trying to get going is a site to site ipsec vpn. that dosnt seem to work at the mo

    here is a pic of my port forward

    thanks inadvance Drewland
  4. joseangel

    joseangel Network Guru Member

    Hey, I love this firmware. Looks cool, far many more options to let it be a very single-ethernet router. Still not a modem, but at least it looks like a very nice router now tweakable enough to let our WRT54G hold the public IP address given bythe ISP and still work smoothly.

    I still culd not find where that firmware came from so I will run a few security aditting over it before trusting it, but it still looks very promising.

    Thanks for the link and the announcement. :) I already installed it. :D
  5. MrFLY

    MrFLY Network Guru Member

    Hi in this moment I working for interface the adsl2mue on my wrt54gs for obtain an high id on emule.

    Only the modem whith DMZ enabled work very well.
    The modem on the router dont work on emule for the lowid problem.

    Teorically the adsl2mue modem whit this new firmware is a very,complete and complex router.

    An Idea is . I have two routers... not a modem and a router but two routers.
    In this moment i test the new method to interface the adsl2 routers/gateway and wrt54gs router/ap.

    the problem is the cisco metric????

    I dont know but i test many configuration but the id is ever low.

  6. joseangel

    joseangel Network Guru Member

    I have the following:
    • Between ISP and ADSL2MUE: Point to point network configured on ADSL2MUE with a private IP address, i.e: pointing default route to
    • Between ADSL2MUE and WRT54G I have the ethernet with the public addressing given by my provider (static IP). My public IP address is configured on WRT54G so I can take advantage of its better firewalling capabilities on my OpenWrt firmware. The interface on ADSL2MUE has one (any) IP address within the same range my public IP is. Then, default on WRT54G points to the public IP address (actually stolen) on ADSL2MUE.
    • WRT45G is the DHCP server and firewall so my computers connect directly to it.

    Dead easy as long as you do not need PPPoX.

    If you do, use NAT translation on ADSL2MUE statically to convert IP into the private addressing of your WRT54G.

    If you do not have any other advantage using both routers, the use just one. The simpler, the better. As long as both can do the job.
  7. MrFLY

    MrFLY Network Guru Member

    I dont Understand !!!

    I Have this Hardware:

    Linksys ADSL2MUE whit this fantastic firmware:

    Product Information
    Model Number AR7RD
    HW Revision Unknown
    Serial Number none
    Ethernet MAC N/A

    Software Versions
    Gateway 2.17-TI
    ATM Driver
    DSL Datapump Annex A
    SAR HAL 01.07.02
    PDSP Firmware 0.49
    Boot Loader

    And the router WRT54GS whit firmware v4.70.6

    The class of IP manually assegned are :

    for the modem
    for the router

    My ADSL connection is 12mbps (italian provider)

    The parameters are

    PPOA - 8,35

    If i use a connecction in PPOE mode I use the modem in bridged mode and the autentication is possible whith the wrt54gs.
    If i use the PPOA mode the autentication not i spossible whit the router but only whit the modem.

    The problem when i using the PPOA mode is low id on file sharing.

    I dont undestand where is the correct setting on the modem for open the port for file sharing.

    I have setting in the modem the port forwarding and the program that assign the port forwarding.
    I have activate the dmz into the router and into the modem on my network ip but nothing, lowid is persistent on mi connection.

    HOW TO WORK this new and complex firmware.

    Tanks a lot

  8. MrFLY

    MrFLY Network Guru Member

    :cheering: HAPPY NEW YEAR :cheering:
  9. joseangel

    joseangel Network Guru Member

    I think I could point a few thing that might be of use to you.

    PPPoA cannot be bridged directly over Ethernet. That is, PPPoE is not the version of PPPoA just over the Ethernet. I am working on it to let ADSL2MUE behave as a modem even with a PPPoA type of ISP connection, but by now I know no way of doing so.

    With PPPoA you can only use ADSL2MUE as a router with static NAT. Put your WRT54G internet interface on any network you may want and get the ethernet of your ADSL2MUE on the same network. Then, configure ADSL2MUE to do NAT with the "Lan Client" you prviously created wit the IP of your WRT54G (that way all incoming traffic should go to your WRT54G).

    That configuration will prevent you fron doing a few things that may be useless to you (like IPSEC non-nat-traversal). Be emule should do just fine.

    Stay tuned when the time the OpenWrt AR7 Port is finished and I had time to implement that PPPoE/PPPoA bridge that would let ADSL2MUE be the modem it claims to be (I am planning on letting WRT54G get (by means of PPPoE) the public IP address given by the ISP dynamically (by means of PPPoA). Would be kind of triky, but should work fine.

  10. joseangel

    joseangel Network Guru Member

    BTW, I forgot to update on the topic of the thread. After a few days testing this firmware I can say it works like a charm. I detected no security flaws nor instability issues. ADSL line synchronizes perfectly, firewalling works and its behaviour as a router is perfect (no drops nor noticeable transmission delays).

    I would recommend using it (but of course, I shall not take any responsability if you do so and brake your piece of hardware or anything else). :rockon:
  11. MrFLY

    MrFLY Network Guru Member


    i dont understand last topic.
    Where is BTW

    I have ever only id... but at this moment i test a new configuration of my lan

  12. cgondo

    cgondo Network Guru Member

    can anyone direct me to the 4.12EU firmware?

  13. cgondo

    cgondo Network Guru Member

    or anyone has the 4.12-UK firmware?
  14. Sp00k13

    Sp00k13 Network Guru Member

    or the 4.19 one that is the one im intrested in ;)
  15. cgondo

    cgondo Network Guru Member

    i have the 4.19 UK one but for some reason my device just wont accept it. I am thinking of downgrading my current firmware to 4.12 then go to 4.19.

    Would you happen to have a copy of 4.12?
  16. FiveHorse

    FiveHorse Network Guru Member

    we now only need the original authors of this firmware to update it to support ADSL2+
  17. sss4

    sss4 Network Guru Member

    i have a question:

    i live in italy andmy adsl2mue have 4.12 EU firmware , my provider (fastweb) required only " Bridged RFC 1483" ( pppoa/pppoe/bridgeonly = dont works) .

    Can i upgrade the new firmware or it's not compatible width my modem?

    If something go wrong can i reload the 4.12 EU firmware?

  18. sss4

    sss4 Network Guru Member

    yeah! seem work fine!

    after the upgrade , i set the port forward for emule and now i have the right ID ( green arrow)!
  19. cgondo

    cgondo Network Guru Member

    do you have a copy of the 4.12-EU firmware?
  20. sss4

    sss4 Network Guru Member

    Is not this? ADSL2MUE_GPL_4.12.tgzADSL2MUE_GPL_4.12.tgz


    my Linksys is made for Italian market and originally have the 4.12EU ..try to send an email to linksys asking for the firmware in question.
  21. MrFLY

    MrFLY Network Guru Member


    HI. I write hour here the solution for all.
    The best solution has been found from 8bits in the official forum of EMULE.
    IS useless to drive crazy with old firmware, used all the last one release, that I have inserted some topic more over.
    The new one firmware allows to personalize the modem whit our requirements.

    The solution for HigID is following (quote from a post of eightbits in official emule forum)

    In this moment I have shaped my hardware in the described way over and I work wonderfully all.

    I want to signal the link to you where I have discussed this argument.


    For the download of the firmware pleas you read mine topic previous.

    thanks to all and good download By MrFLY
  22. n3oNx

    n3oNx Network Guru Member

    The firmware is ok and works fine. The problem seems to be my modem... Sometimes I can have the PPPoE login in the modem and sometimes I can't. It just won't do the login: the Internet LDE blinks one time red, blinks the second time red and then it stays off.

    This happens with this firmware, with the 4.12EU and with the 4.19UK.

    But sometimes it works fine. It's beyond my knowledge and patience.

    I'll take him for repair under warranty.

    PS: In Bridge mode it works perfectly.
  23. MrFLY

    MrFLY Network Guru Member

    Ypur problem is very strange

    please reset the modem and insert your provider settings.

    The carrier led is green but the internet led if is red the problem is an error on the autentication.

    Post the setting of your provider vpi vci llc etc.

    In the bridge mode on a router? Where is the router?

  24. n3oNx

    n3oNx Network Guru Member

    The problem is a faulty modem. I send it to warranty. I dind't work at my house nor at my friend's.

    Only in bridge mode. The router is an WRT54GS.
  25. MrFLY

    MrFLY Network Guru Member

    before sending the router in warranty it tries to reflash with the software linksys tftp, you found the instructions for reflash in the attached of the software. Hello Attention the modem does not work well only when the led power it remains always red or it flashes
  26. MrFLY

    MrFLY Network Guru Member

    after one month

    of tes this firmware is very stable
  27. joseangel

    joseangel Network Guru Member

    I've seen lately that my ADSL2MUE adsl interface s flapping. From time to time it just starts synchonizing and when succedded after a few seconds, it losses sync and starts resync again and again.

    Any other ADSL router/modem syncs perfectly stable. I am going to flash the old original image to find out if it was the firmware or the hardware.

    Did any of you see the same issues?

  28. MrFLY

    MrFLY Network Guru Member

    Hello joseangel! I have tested is the old that the new firmware for adsl2mue. With the old firmware I do not have never synchronization problems.
    With the new firmaware I have not never had synchronization problems.
    Both turn out stable.
    only problem of the new is that in case of lacked feeding does not save the configuration. At least in my case. HELLO
  29. joseangel

    joseangel Network Guru Member

    Uhm, then it should be the hardware. Too bad. :cry: I will anyway use the openwrt firmware and the original one to be sure, but if is the hardware that got broken I would have to say :sadbye:

    Thanks, MrFLY
  30. fommes

    fommes Network Guru Member


    Were any of you able to get to the 4.12 fimware?
  31. MickK

    MickK Guest

    I've tried the 4.17 TI firmware and it does give all the options you could possibly want. Unfortunatly it's not very stable and you will take a hit in network performance if you decide to install it.

    My DSL speeds (3MB down/384k up line) from 2.65MB down to 2.25MB on downstream, and 320k down to 265k. Worst of all my Quality of Service dropped from 99% to 73% which is a huge hit in my opinion.

    I swapped in my spare modem and my original speeds returned, so it's definitly the 4.17 firmware's fault.

    If you can take the speed hit then go for the 4.17, I couldn't find the 4.12UK software anywhere on the net so I installed the 4.22EU firmware (still doesn't have the advanced menus) and the modem returned back to it's normal performance and stability.

    4.22EU firmware is available at the following topic...
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice