Latest WIndows Update for Wireless-G PCI Adapter Broken?

Discussion in 'General Discussion' started by Anonymous, Jun 13, 2005.

  1. Anonymous

    Anonymous Guest

    I have a home network consisting of the following:

    * Linksys WRT54G Router, hardware version 1.0

    * XP Home Edition machine with a Linksys Wireless-G PCI Adapter card.

    * Windows 2000 laptop with a Aterm Warpstar WL54AG PCI card.

    Up until now, this has all worked absolutely seamlessly.

    The other day I did a Windows Update manual update, and saw the following:

    Cisco-Linksys LLC - Networking - Wireless-G PCI Adapter
    Date last published: 3/26/2005
    Linksys, A Division of Cisco Systems, Inc. network software update
    released on December 22 2004.

    I installed this update, and since then have had nothing but problems. My
    connection on the XP machine will drop, and nothing, including rebooting the router, will work. I end up having to reset the router back to its factory settings.

    I've tried uninstalling the update, and rolling back the driver. Even now,
    I'm connected, but only to an unencrypted network - and even then, the network icon in my taskbar shows my machine as not connected! Every so often, the connection drops and I have to repair it.

    Has anyone with Linksys network router/cards had the same problems lately?

  2. BTQ1

    BTQ1 Guest

    Yes, I have had the exact same thing happen to me in the last twenty four hours.
    I have spent hours trying to repair the problem today.
    My network is well and truly hosed.
  3. fred89

    fred89 Network Guru Member

    Answer I hope

    >Has anyone with Linksys network router/cards had the same problems lately?

    yes - linksys wireless-g pci adapter v2(v2?)

    I too, installed the optional MS Update related to this card/hardware
    and then my computer running XP SP2 BLUESCREENed upon boot.

    I solved it by

    (a) turning off the computer
    (b) removing the linksys wireless-g pci adapter card
    (c) Starting up the computer
    (d) deinstalling all the inksys wireless-g pci adapter software
    (e) rebooting
    (f) deleting the following file:
    (g) turning off the computer
    (h) putting the linksys wireless-g pci adapter card back in
    (i) Starting up the computer
    (j) Installing the linksys wireless-g pci adapter driver and utility from the
    CDROM which came with the card.

    Then it worked again!

    I may try the later linksys drivers for this at
    Driver Version :
    (non USA/Canada) for WMP54G - Wireless-G PCI Adapter v2

    Driver Version : 3.30.15
    (for USA/Canada) for WMP54G - Wireless-G PCI Adapter v2

    If someone can tell me how I know that I have a
    Wireless-G PCI Adapter v2 card
    rather than
    Wireless-G PCI Adapter v4

    I would love to know!

    I know that v4 drivers
    seem only for USA/Canada. I'm in the UK and this one doesn't work for me, the problem is the card never gets a DHCP IP address assigned to it.

    For international it seems only that v2 of this PCI is available?

    Anyhow v2 drivers and software work for me.

    Agreed that the MS Update for this card seems to be faulty?- causing
    a BLUE SCREEN of death for me.
  4. fred89

    fred89 Network Guru Member

    looking for replies
  5. fred89

    fred89 Network Guru Member

    additional info

    I'm using a WAG54 ADSL Gateway/Firewall/Router
    with the firmware : WAG54G_AnnexA_ETSI_v1.03.0_beta4_00_code

    recently installed.

    previous to this I was using WAG54G_AnnexA_ETSI_v1.02.7_03_code
    which was at least stable, unlike my experiences with
    WAG54G_AnnexA_ETSI_v1.02.5_07_code which I dumped after about 1 day.
  6. howardp6

    howardp6 Network Guru Member

    Re: Answer I hope

    TYou can open the computer without removing the card. The WMP54Gv2.0 is wider that tne WMP54Gv4. If you want to remove the card, the FCC-ID has the version number on it. You can go to the FCC.GOV website amd look up both versions on their database.

    The PDF file for the WMP54GV2 can be found at:

    And for the WMP54Gv4:

    Never use a driver for Linksys adapters from the Microsoft Update Website.
  7. fred89

    fred89 Network Guru Member

  8. Anonymous

    Anonymous Guest

    Need Help

    I have the same problem with the link sys wireless G class pci card and a ADSL Router
    CAN any one able to solve the problem

  9. Anonymous

    Anonymous Guest

    card version

    to find card version it shoul be a white blokk of text printed right onto the pcb. For the versio 2 card it is located face up top right hand croner as such p1-100_v02<<<version2
  10. ianf

    ianf Guest

    I get a similar problem only my card doesnt hit the network, sees the SSID ok but wont connect.
  11. Anonymous

    Anonymous Guest


    I am having the same problem, my router light will not even come on now. I don't know what to do.

  12. kissels

    kissels Guest

    Wow... I'm not alone. Anyway, you can also tell the difference between the v2 and the v4 by simply looking at the installation disk that came with your adapter; it will either have a v2 or v4 at the end of the model number.

    Anyway, about 3 weeks ago, I all of the sudden started experiencing slowed page loads, stalled page loads, stalled e-mail downloads and other downloads, disconnection problems. I shut down and reset my modem and router more times than I can count. I don't remember installing any updates, but I may have, especially if it was an automatic Windows update. I was using a WMP54Gv4 wireless-G PCI adapter with an Access Point (router + 4-port switch). I naturally assumed it was my modem/DSL and having made 4 calls to SBC, they sent out a tech who tested both the modem and problems there. About a week ago, I started working with Linksys techs who (after 3 calls) determined I had a "bad" adapter and I needed a new one. It was only 2 months old, so I had to find my receipt and call them back with info from the receipt to get it replaced (my 4th call to Linksys). They sent me a came was the wrong one. I was using a v4...they sent a v2. Unfortunately, the disk for the v2 they sent wouldn't run; it would flash the blue start-up screen and die, so I had a brainstorm and used the v4 disk just to get start-up screen up, then switched to the v2 disk, finished running the v2 disk, then shut down and put the adapter into the CPU, rebooted, and (because the v2 disk wouldn't automatically finish the install), finished the installation of the driver by going to Control Panel -> System -> Hardware -> Device Manager -> Network Adapters -> double-click Wireless-G PCI Adapter -> Driver -> Update Drivers -> click the radio button for Install Automatically (Recommended) -> Next, etc....

    The strangest thing about the problems I was having with slow/stalled page loads, downloads, etc... is that even though I stopped using my computer wirelessly about a week ago, (I hardlined directly to the router), I was still having slowing and stalling problems, just not AS slow or as many stalls as when I was wireless. Only after I was able to get the new v2 adapter installed did the problems stop altogether. So apparently, just having the "bad" adapter installed on the system seems to cause these problems whether you're connected to the internet via the adapter or not.

    Don't know if any of this helps anyone. I sure hope so....
  13. jgutz20

    jgutz20 Network Guru Member

    This can usually be solved by changin the Wireless Channel and or the SSID on the netwrok. if still no luck, change the encryption type or at least password
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice