Latest WRV54G Firmware?

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by nindustrial, May 29, 2006.

  1. nindustrial

    nindustrial Network Guru Member

    Hello all,

    Does anyone know where I can get the latest WRV54G firmware? The downloads link here only has 2.38.6 as the latest. Some people have mentioned 2.39 and I saw it was available on the China Linksys site, but is that safe to use?

    I am trying to get a WRV54G setup at an office so I can VPN into it from home. I would like to be able to use QuickVPN and am dreaming of the day it will work as easily as described in DocLarges guide. No matter what I try, I am unable to get it working for me at home (i've tried a few various firmware versions now).

    Also, at home, my computers are connected to a WRT54G (running the HyperWRT firmware). Does anyone know if this is whats causing a problem for me? I have tried connecting directly to my DSL modem too, but nothing works so far. I would like to give a new firmware a try next, but don't know where to get them.

    Thanks sincerely...
  2. DocLarge

    DocLarge Super Moderator Staff Member Member

    Can you get to the router's internal web page?
  3. TazUk

    TazUk Network Guru Member

    It's 2.39.2 on the China website and yes it's safe to use, it's what I'm running :D
  4. nindustrial

    nindustrial Network Guru Member

    Thanks TazUk, I will give 2.39.2 a try from the China website then.

    DocLarge, thanks for your awesome guide and various posts here. Yes I can get to the routers setup webpage (is this what you mean?). I can do so either from the office, or remotely from home (having turned on remote admin). So I know the IP, etc is correct. I dont have any upstream router at the office (the WRV54G is at the perimeter) and at home, I am using the WRT54G (with the HyperWRT firmware). I have followed the steps in your guide, but still get no connections, even if I disable Windows firewall, and connect directly to the DSL modem (without my home router).

    I know its tough to troubleshoot every possible network configuration, and I'm starting to wonder if maybe my ISP (Telus here in Vancouver, BC, Canada) is causing a problem (or maybe the DSL modems at either end).

    Any tips you guys have are greatly appreciated. Or alternatively, maybe some other way to access a windows share from home? All I want to do is mount a shared folder from work, on my computer at home. Maybe VPN is overkill for this?
  5. eric_stewart

    eric_stewart Super Moderator Staff Member Member

    I know from experience with a couple of my customers that Telus (here in Ontario) made some changes in their network which made IPSec VPNs very sensitive to the MTU of the VPN gateways' WAN interfaces. I changed the MTU on a Cisco PIX 501, and a WRV54G, for example, to <1450 bytes and a problematic VPN magically connected right away. This was a site-to-site VPN, but an IPSec VPN is an IPSec VPN. Won't hurt to change your MTU to some manual setting, 1400 bytes for example. Once the VPN is properly established you can change the MTU upwards until you get a connect problem again.

  6. nindustrial

    nindustrial Network Guru Member

    Thanks Eric, I was worried about something like that, but hopefully thats not the case here.

    I tried with firmware 2.39.2 from the china linksys website, and that seems to have done the trick as far as VPN connectivity goes. Now I am going to try to get the office windows share to mount as a drive at home, and the various posts here by DocLarge and others about user-accounts and permissions, should be helpful.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice