Limited connection on Win Vista & 7 ONLY

Discussion in 'Tomato Firmware' started by drunknmunky1, Jan 11, 2010.

  1. drunknmunky1

    drunknmunky1 Addicted to LI Member

    Since I installed Tomato on a new WRT54GL router, I've been having network trouble with Windows Vista and Windows 7 computers only. XP, Mac and Linux computer all work with no problems.

    The problem occurs in all situations, ie any combination of wired/wireless and static/dhcp address.

    What happens is that after connecting to the network, Windows thinks for a second that the connection is fine, but upon trying to open a webpage or using anything else on the internet, the connection appears to be did. This can be observed by running a "ping -t" in the command prompt while first connecting to the network. For example, when disabling the network connection and reconnecting, it will show something along the lines of:
    general failure (network card is disabled)
    general failure
    ping from 1 ms (right after enabling)
    request timed out
    request timed out

    Pinging the computer from the router using the web interface or the CLI interface shows that the router is unable to ping the computer either.

    However, during all of this, the computer is still able to access any local resources OTHER than the router. For example, the connection to the media server on my network is never lost during all of this.

    There have been two semi-solutions that have sort of solve this problem. The first one involves running a torrent client and as long as some sort of torrent is uploading or downloading, the connection will not disappear. However, as soon as the torrent stops, the connection dies.
    The second solution is to use the scheduling function on the web interface to constantly ping the computer which appears to keep the connection alive. However, there are at least 6 computers on the network at any given time and more of them are switching to Windows 7 now so this solution is becoming more complex and not as useful.

    So, what appears to be happening is that as soon as there is no data transfer occurring, the connection drops and they're unable to reestablish the communications.

    From what I can tell, this has nothing to do with the DHCP server - static IPs have the same problems and there is never a problem getting an IP address.
    This is not a wireless issue either since wired connections have the exact same problem.

    I have tried changing every network setting that I understand (most of them) and changing values to no effect.
    I just upgraded to the most recent version of Tomato and the problem has persisted.

    I used to use DD-WRT but I much prefer Tomato's interface - especially the live bandwidth and connection speed monitoring - and would like to keep using Tomato. There were no problems at all using DD-WRT so somehow this is a Windows Vista/7 + Tomato issue and I'm hoping the issue lies with Tomato since MS will never fix this if it's on their end.

    These forums seem like the best place to ask so I'm hoping someone can help. I tried searching Google and these forums to no avail - the search terms are too general and I just get a bunch of unrelated results.

    I'm happy to provide logs and anything else that will help.

  2. deboyz1014

    deboyz1014 Addicted to LI Member

    Just asking the obvious, did you try clearing out the nvram after upgrading?
  3. drunknmunky1

    drunknmunky1 Addicted to LI Member

    Ya I did.
    Would clearing it again now do anything other than lose settings? Won't take long for me to re-enter them.
  4. bagu

    bagu Network Guru Member

    A small question : why ?

    The default router adress is
  5. drunknmunky1

    drunknmunky1 Addicted to LI Member

    habit, and i already had several static devices set up in the range before i set up tomato and it was easier just to change the router IP than to change them all.
    i can't imagine how this would be a problem though
  6. bagu

    bagu Network Guru Member

    Just because if you tried to ping and router was, the test must fail. So i must verify.
  7. drunknmunky1

    drunknmunky1 Addicted to LI Member

    Makes sense. thanks for the help.

    i think this may be a bug though.
    im not sure if the devs read this forum but id like to help try to troubleshoot it if possible
  8. bagu

    bagu Network Guru Member

    Just for information, i have many routers.
    I've made a try with a wrt54gl v1.1 with the latest tomato non-ND and win 7 :
    work like a charm.

    So, can you verify that your cards are in DHCP mode ?
  9. drunknmunky1

    drunknmunky1 Addicted to LI Member

    My network is reasonably complex for a home network and I think that may have something to do with the problem. I'll do my best to explain it.

    in the house there are: 1 router (tomato), 1 5-port gigabit wired switch, 1 8-port wired switch, 2 old routers functioning as switches (nothing plugged into the internet port, all dhcp, wireless, internet functions disabled). the wireless comes from the tomato router.

    the 5-port and 8-port switches are plugged into the tomato router. the 2 other routers are plugged into the 8-port switch (it lives in a wiring closet with network cables going to each room).

    1 Win 7 laptop, 1 Vista Laptop, 2 XP laptops, 1 linux (ubuntu 9.10) laptop, 4 xbox 360s, 1 ps3, 1 wii, 1 iphone, 1 htc magic (android cell phone), 1 ipod touch all connected via dhcp
    1 linux server (ubuntu 9.10), 1 win 7 desktop connected via static ip

    there are also occasionally other people here (usually macs) that connect via dhcp

    the 2 windows 7 computers and the vista computers are the ones with issues. i've tried all of them on both static and dhcp and there is no change in the problem. currently they all experience the same issues.

    each computer with problems is plugged into different switches/routers and has the same problem whether it's on wireless or wired. i've also tried unplugging all the switches and plugging my desktop straight into the router but it still had the same problems. the wireless computers have the same problems as well when everything is unplugged from the router.

    hopefully this answers any potential questions about the network setup.
  10. LanceMoreland

    LanceMoreland Network Guru Member

    I suspect that you need to reboot your modem, if you haven't. If your mac address on the router changed during the firmware upgrade (it could happen if the previous mac address was cloned or a random selection and clearing the navram would have done that) your ip address will no longer be valid.

  11. drunknmunky1

    drunknmunky1 Addicted to LI Member

    thanks, i tried that but it didn't change anything.

    note that the internet works for most of the devices with no problems. it's only the 3 computers with either windows 7 or vista that have issues. that's why this is so baffling to me. microsoft clearly introduced something in vista that remained in windows 7 that doesn't get along with tomato in my specific network setup.
    it's obviously not a widespread issue though or the forums would be flooded with people complaining about vista and 7 not working with tomato.
  12. LanceMoreland

    LanceMoreland Network Guru Member

    Yes, I have no less than 9 Windows 7 machines and 5 Tomato routers with no similar issues. Hope you get it sorted out. One last thing that may help. Right click on your network icon in the system tray on one of the Windows 7 machines and select "troubleshoot problems".

  13. Toastman

    Toastman Super Moderator Staff Member Member

    Are you using an ND version of Tomato? With the non-ND driver, it was quite common to associate but not be able to access the internet - it was usually something to do with the wireless cards. Usually, the reason was that no actual communication with the router was taking place, and no IP address had been obtained by DHCP. Why the PC was not talking to the router I never established. But, often giving a PC a static address would allow it to work, but not always.

    I believe you did say that the same thing happens with Static IP addresses, so it's a bit of a mystery. We've got many 7 systems, but never seen this problem.
  14. drunknmunky1

    drunknmunky1 Addicted to LI Member

    I'm actually using the MLPPP fork of Tomato since my ISP offers it and it allows me to bypass torrent throttling.
    It's based off an ND version of Tomato though.
    I plan on installing the vanilla build of Tomato though and seeing if the problem persists. I know that using DD-WRT the problem did not exist.
    Once that's done I'll post back here with the results.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice