Limited or no connectivity - IP address not assigned by DHCP

Discussion in 'Networking Issues' started by MikeS, Aug 20, 2005.

  1. MikeS

    MikeS Network Guru Member

    I have a linksys wireless router (WRT54G) to which I am connecting via my PC using a linksys wireless USB Network Adaptor. I was, until recently, also connecting via my Linksys Wireless-G Notebook Adaptor (WPC54G).

    However, I recently reinstalled windows on my laptop and now I cannot acquire an IP address. This only happened after I installed Windows XP SP2 so I suspect this has some bearing (despite the fact that my PC also has SP2 installed)

    I can set up a static IP address manually and connect to the network but I have no internet connectivity.

    What I want to do is to by dynamically allocated an IP address by the routers DHCP server. Does anyone have any ideas why I cannot do this?
  2. MikeS

    MikeS Network Guru Member

    More information

    I should have said I have setting the WEP settings, tried turning security off, MAC address protection off etc - I've basically made my network unsecure in an attempt to get it working.
  3. MaureenMun

    MaureenMun Network Guru Member

    Mike, did you ever find out what was wrong? I am having a very similar problem: laptops can see my access point and show a strong signal, but, (after trying for several minutes) can't get an IP address from the WAP. If I put in a static IP address on the notebook they connect just fine (even to the internet, I put in our ISP's DNS servers as well as a 198.168. 1.X IP address) -- even though I'm not changing a thing on my Linksys WAP54G. It's very annoying to have to do this every time someone want to use the network. What's weirder for me is that it started suddenly, I didn't change a thing, but all the laptops so far have been XP SP2 so I can't tell if that's a factor or not.
  4. Mike70

    Mike70 Guest

    Did you check the firewall that comes builtin/enabled with XP SP2, it might be preventing connectivity.
  5. bulletspunge

    bulletspunge Network Guru Member

    Another workaround would be to change you APIPA IP and DNS.

    Go to your wireless network adapter and double-click on the TCP/IP properties page. Select the Aternate Configurtion tab and choose user configured. Input your IP and DNS info and it should revert to this IP.

    I use this setup at home since I connect to multiple wireless networks. My home network is all static IP's and the other networks are DHCP. So when I connect to my home network and it doesnt get an IP(usually < 10sec) it uses the APIPA which is in my network range.


    Hope this helps....
  6. TMAC

    TMAC Network Guru Member

    try changing the channel and SSID(wireless network name) that might work. If still the same try assigning static IP to the PC.
  7. icarus

    icarus Guest

    Anyone tried rebuilding and registering their WMI repository? If its corrupted on the host machine it will most certainly cause the problem of the client not being able to get an address. Full instructions can be found here:
    I did this and solved the limited or no connectivity problem. I can now auto acquire an ip address for the client (one communicating with adaptor) and it has solved my no limited or no connectivity issue which some of you seem to be having. I have the Linksys WAP54G V2. Hope this may help.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice