Link speed stuck at 1Mbps :?

Discussion in 'Cisco/Linksys Wireless Routers' started by Essi, Aug 31, 2004.

  1. Essi

    Essi Network Guru Member

    Hey people,

    I've just purchased the WRT54G and the WUSB54G for my laptop. For some reason the wireless connection between the two is stuck at the lowest speed possible :( . The connection itself is fine through the entire house but the speed never increases.

    I've spent ages changing settings etc with the router but nothing seems to help. This includes putting the router onto G mode only and changing transmit speeds from Auto to 54Mbps. Even putting the WUSB54G into other PCs and changing the location of the router does nothing the speed always remains at 1Mbps ( even when signal strength is excellent).

    I'm using the latest linksys firmware and the systems run XP Pro. I've also tried the latest HyperWRT firmware but this also does not help.

    Any help would be great.

  2. Toxic

    Toxic Administrator Staff Member

    what are you using to test throughput between the two pc's
  3. Essi

    Essi Network Guru Member

    So far I've just been using Bandwidth Monitor while I have been sending large files between systems. Currently the speed seems to float around the 100KB/s mark.
  4. Toxic

    Toxic Administrator Staff Member

    is the signal strength good?

    try a full reset first on the router and try again.
  5. Essi

    Essi Network Guru Member

    Yep currently I'm getting full bars on the signal strength. So far fully resetting the thing hasn't helped but I'll give it another go and change channels again and see if that makes a difference.
  6. Esquire

    Esquire Mesquire Staff Member Member

    Are you using USB 2.0 compliant USB ports on your computers to connect your WUSB54G?
  7. Essi

    Essi Network Guru Member

    Yep the ports are all USB 2. I'll try flashing it with some different firmware and see if that helps. If its still not working by the weekend I'll give tech support a call.

    Other than uninstalling and reinstalling the WUSB54G drivers is there anything else I can do with it incase the problem is with that and not with the router?
  8. Essi

    Essi Network Guru Member

    Cheers for the people I have now fixed the problem. It was with the WUSB54G and not the router. All I did was update the drivers for it from ( the ones that came on the disc ) to which are available on the linksys website.

    Must say I'm also impressed with the Satori-4_0G firmware. I noticed an increase in signal strength as soon as I installed it.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice