Linksys 16 port switch not connecting after upgrade

Discussion in 'HyperWRT Firmware' started by ngiovas, Sep 3, 2006.

  1. ngiovas

    ngiovas Network Guru Member

    I recently upgraded to hyperwrt 2.1b1 on my WRT54GS and since doing so I have not been able to connect to the router through any device that is connected to my Linksys EZXS16W switch. All of the lights light up, but I can't even get assigned an IP from the router. Any device (other than the switch) connected directly to the router works fine. I have tried multiple cables and still no luck. It worked fine before. Is it a fluke that my switch died around the same time that I upgraded, or is there something obvious that I am overlooking?

  2. jgutz20

    jgutz20 Network Guru Member

    are you able to connect to the router directly and not through the switch? that would single out where the problem is
  3. ngiovas

    ngiovas Network Guru Member

    Yes, connecting to the router directly from any PC/device works fine. As soon as I connect the switch and try and connect to the network through the switch, I have a problem. I don't know if the router has just "gone bad". There isn't much too it, but I'm sure it could happen.

    I was just hoping that I was missing the obvious. I was tempted to roll back to the default firmware and try it, but I just have a hard time believing that would be it.

  4. ngiovas

    ngiovas Network Guru Member

    Just for future reference if anyone is searching through the old posts - the Linksys switch has a 5 year warranty (I had assumed it was only 1). Linksys agreed to swap it for a new one.

  5. swinn

    swinn Network Guru Member

    Did you flash it with HyperWRT 2.1b1 or with HyperWRT 2.1b1 + Thibor 15c? The firmware at is years old. Thibor 15c is the latest at ... Not that I would think this would cause your problem but never can tell.
  6. njeske

    njeske Network Guru Member

    if the switch is an active/managed switch, it probably has its own IP addressed leased from the router's DHCP pool. if you haven't already, reboot the switch to make sure it leases a valid IP from your router. any time you reboot your network DHCP source, it's good practice to reboot any network device that relies on DHCP for it's IP information.
  7. ngiovas

    ngiovas Network Guru Member

    I tried rebooting it several times with no luck. Any device connected to the switch received a strange IP address (or no IP address) and couldn't access the network. Linkys offered to replace the switch for no cost, so I took that option.

    For the person who asked about which version I am running - yes, I have the latest version. The router itself hasn't had any issues at all since the upgrade.

    Thanks for all of the suggestions. I was just hoping there was something obvoius that I was missing. Oh well, at least I don't have to buy a new switch.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice