Linksys and Intel 3945ABG problem - Please help!

Discussion in 'Networking Issues' started by NJRonbo, Apr 11, 2006.

  1. NJRonbo

    NJRonbo LI Guru Member

    People have got to know about this problem because
    it's being discussed on many laptop forums.

    Seems that there is a problem with Intel 3945ABG laptop
    network cards communicating with certain Linksys routers.

    I should know. I have the WRT54GX4 SRX400 router.

    I just bought a Lenovo dual-core notebook with an Intel
    3945ABG wireless card.

    The notebook will not connect to the Internet. When it does,
    it throws all my other laptops off the wireless network -and-
    my wired desktop off the Internet.

    At first I thought I had a defective laptop. From reading
    a large handful of posts on Internet forums, it seems that
    there is a huge compatability problem amongst people who
    have laptops with that Intel card + a Linksys router.

    I just updated my firmware to release 1.00.15 but that
    doesn't solve the problem.

    Is Linksys aware of this problem? Is there a fix available?

    Thank You!
  2. bummpr

    bummpr Network Guru Member

    Dual core with Intel 3945ABG woes

    I've had the exact same scenario...proudly booted my new dual core Thinkpad for the first time and knocked down all my other laptops from my wireless network.

    After rebooting all network and PC devices several times, I was able to get both the old and new laptops back online...but, of course, I am trying to use the WRT54GX4 with so many little buggies, that my performance and connections are always flakey.

    I think I am at the point that I am going to relegate this expensive GX4 into a simple switch to handle hardwired PC's and printers's not worth the hassle of trying to get this thing to work when it obviously is not capable of working.
  3. NJRonbo

    NJRonbo LI Guru Member

    So it is the router. Just as I figured.

    I contacted Linksys Tech support via email on this and
    they have yet to respond. Not sure if they are even aware
    of the compatability problems.

    There are two options here....

    IBM does have an Atheros network card (#40Y7026) that
    replaces the Intel 3945ABG card. I could try replacing that
    network card.

    The other is to just ditch my Linksys WRT54GX4. I hate
    to do it because really, it's the best router I ever bought
    and up until the arrival of my Thinkpad, it worked flawlessly.

    What other brand and model would anyone recommend
    that provides the power and ease-of-setup that Linksys does?
  4. NJRonbo

    NJRonbo LI Guru Member


    I dumped the Linksys WRT54GX4 router.

    I bought the Belkin Pre-N router that a member of
    the Thinkpad forum suggested I do.


    That's right folks -- it was the friggin' Linksys router!

    I now have a properly functioning wireless connection.

    It is working in conjunction with Thinkpad Access Connections.

    It is working with the original Intel network card drivers.

    It works PERFECTLY, as it should.

    The Moral of this story....

    If you are having connection problems with your
    Thinkpad and own a Linksys router -- there should
    be no second-guessing to what the problem actually is.
  5. howardp6

    howardp6 Network Guru Member

    At Tomnetworking there was a reported problems with the Intel duo CORE, with the card you have with some routers, I am not too sure it is the router. It was listed as a duo core bug. It may be the router. The Xbox360 does not work with the WRT54GX4 or the latest Netgear RangeMax router, But the old xbox wirleless adapter works with both. It is interesting that both the xbox320 and your minicard are 802.11a/b/g devices. The chipset in the two router were designed to work with an additional 802.11A radio for 802.11A and 802.11G/B. Maybe there is a problem it the 802/11a radio is not installed. Then it is a router problem as you stated.
  6. mrrouter

    mrrouter Network Guru Member

    It's not the router

    I too have an IBM Thinkpad. I got an X60s with a Centrino Duo and the Intel 3495 ABG wireless. When I first booted it up as well I connected briefly and the damn wireless radio kept shutting off or I was getting kicked off. I have a WRT54GX4 as well.

    I did the following and things are working perfectly now:

    Prior to upgrading my WRT54GX4 I was running 1.00.13 firmware
    I upgraded all my drivers for the Thinkpad (from Lenovo's website) but occasionally was still getting drops. Then I went to Intel's web site and downloaded the latest Intel PROSet wireless drivers for the 3495. This really seemed to fix things as I wasn't getting drops anymore.
    Finally I upgraded to 1.00.15 on my WRT54GX4 and it seems more rock solid than ever.

    The router seems great to me. I'm running two laptops off it at full 54Mbps and in the basement my main computer which has the SRX400 NIC I get 108Mbps as reported by Windows.

    On top of all this I have a NAS and an HP 2710 inkjet hardwired into the router.

    Hope this helps.
  7. mrrouter

    mrrouter Network Guru Member

    thinkpad connections

    btw, I also disabled the ThinkPad Access Connections service and the ThinkPad Ac Profile Manager.

    I'm using solely the Intel PROSet manager and whatever else Windows XP has.
  8. mrrouter

    mrrouter Network Guru Member

    one last thing

    I am also using WPA2 Personal with Shared Key and AES encyption. I read somewhere in this forum that TKIP doesn't work too well and I noticed that too.
  9. mrrouter

    mrrouter Network Guru Member

    hmm, maybe something is weird

    can't exactly pinpoint it but recently we had the issues that njronbo described. all the clients get kicked off and you have to wait or do some kind of reset to get them back.

    i can't tell if it's a combination of having 2200g clients and 3495 clients or the router itself not liking stuff.

    i did a complete wipe/hard reset of the router, reflashed the 1.00.15 firmware, another wipe/hard reset of the router and put everything back onto the intel proset wireless config.

    if it is indeed the router and the firmware still having bugs linksys please fix this damn thing soon. it'll begin to drive a bunch of people really crazy and you'll lose some supporters of what otherwise is a great piece of equipment able to sustain some phenomal rates.

    anyone else got any other ideas as to what else could be wrong?

    i'm going to turn on some logging on the router too.
  10. darkj2k

    darkj2k Network Guru Member

    Here's my problem w/ ThinkPad T60 (Intel 3495abg) and Linksys WRT54G V.3:

    I have one ThinkPad T40 build-in Atheros mini-PCI abg card and it works fine w/ WRT54G almost one year w/o any problem. I also have one Fujitsu P7010 (Intel 2200BG) connected to WRT54G and sharing files w/ T40 via My Network Places.

    After I replace Fujitsu P7010 w/ T60 two weeks ago, My T60 and T40 can not find each other via My Network Places. The Internet connection for both notebook is no problem but just cann't find each other via MS Windows Network.

    I've been using file sharing for years so I suppose the settings for both notebook should be not a problem. Actually my T60 file sharing function in my company is ok by D-Link AP so I suspect the problem could be my AP at home. Any suggestion?
  11. Toxic

    Toxic Administrator Staff Member

    i take it they have the same Workgroup name and have folders on each PC that are shared?
  12. darkj2k

    darkj2k Network Guru Member

    Sure. Just updated firmware of Hyperwrt_G_Thibor14 and still cann't see each other. Now I'll try another one: dd-wrt.v23.
  13. darkj2k

    darkj2k Network Guru Member

    Well, I just figure out what went wrong. It's my Symantec Client Firewall configuration problem. After fine tune it the file sharing function is back. It's not WRT54G problem. :grin:
  14. doru31

    doru31 LI Guru Member

    T60p and WRT54G Associating... FAILS


    I also have a thinkpad T60p Core Duo, running WinXP Pro SP2, that I am trying to connect to the router wirelessly. I even changed the wireless security to disabled and I still can't associate to the router. I am able to see my router hotspot using my T60p and when I try to connect to it, it just keeps saying: Associating ... but then it fails to connect. I've tried connecting to other hotspots and it seems to connect just fine. Is there an incompatibility between T60p and WRT54G router (Firmware Version: v4.21.1)? The reason I'm asking is because I aslo have a T41p which has no problem connecting to my WRT54G router.

    My T60p Network adapter:
    Atheros AR5001 11a/b/g Wireless LAN Mini PIC Express Adapter (Driver Version:

    Thaks for any help you can provide.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice