Linksys EA6200 Tomato version?

Discussion in 'Tomato Firmware' started by Rich Schmidt, Aug 18, 2015.

  1. Rich Schmidt

    Rich Schmidt Reformed Router Member

    Hi, Everyone,

    I am a longtime Shibby Tomato user running it on various Broadcom based routers.

    I recently picked up a linksys EA6200 and was wondering if I should give a tomato upgrade a try using the Asus rt-68 image?

    Has anyone else attempted this?

  2. Monk E. Boy

    Monk E. Boy Network Guru Member

    DD-WRT unofficially supports it with an AC56 build.

    I don't know if a similar Tomato build would support it or not. The question is... would you mind losing it if you brick it? If not, then flash it. If you do, then it might be best to wait for someone else with access to the appropriate JTAG cable (in the event flashing completely hoses it) to try.
    Dr Strangelove likes this.
  3. Monk E. Boy

    Monk E. Boy Network Guru Member

    I should probably mention that the reason I came up with that answer that fast is that last Friday I inherited an EA6200 from our new construction. Previous tenant left a bunch of hardware behind so I scooped up everything I thought might possibly be useful and let the demolition guys have the rest (cable modems + switches). So I've been poking at it. Got the Feb-4-2015 build of DD-WRT installed and running but everything newer won't light up the 5Ghz radio.
  4. Rich Schmidt

    Rich Schmidt Reformed Router Member

    Thanks Monk.
    It seems a lot of people have been able to run specific dd-wrt versions on this router, but none are official.
    I am hoping that an official dd-wrt or even better, a tomato version is released.

    I would be happy to donate for an official release...

    Otherwise..I may attempt to load the feb-4-2015 version of dd-wrt.
  5. Monk E. Boy

    Monk E. Boy Network Guru Member

    Oh yes, it's unofficial support only at this point, which is probably why the radios come and go. FWIW I went straight from the original OEM firmware to dd-wrt using the built-in web server, which I reset to defaults using the reset button, then didn't let it log into Belkin/Cisco's nebulous cloud-based management site. Stupidly the firmware upgrade feature is hanging off connectivity, in case you sit there casting about for where the hell it's located in their poorly designed firmware.

    There are basically two partitions in the firmware, each containing a full version of the firmware, but dd-wrt can only write to partition 1. If you find yourself resetting it and it ends up loading the Linksys firmware, try loading the default firmware again, which should flip it's boot partition from 0 to 1, at which point you can load dd-wrt into it. Since now the default firmware is set to load from 1 and dd-wrt is in now in 1, even when you reset it to defaults it'll stay booting at 1, no script needed.

    The original OEM firmware is available from Linksys's site, I didn't trust the download link in that reddit thread. The 2/4 build I mentioned is linked from that thread. I walked through the beta tree it was stored in and scooped up 6 or 7 newer firmwares without luck, even a Kong firmware someone else mentioned elsewere as compatible. Everything recent is 3.0 (the working build is 2.4) which is probably why it has issues.
    Last edited: Aug 21, 2015
  6. Julia!

    Julia! New Member Member

    Hi Monk E. Boy,

    I guess I am facing the same problem with my router. I tried to load the original linksys firware, and after that, the asus_rt-ac56u-firmware.trx so I could use the dd-wrt. However, when I finished the last step and tried to acess the web interface, it asks for a login and password that I don`t have. I tried every single combination of login and password I could find on internet and it didn`t work. Do ou have an idea of what`s going on? And what can I do to solve this problem?

    Thank you very much,

  7. Monk E. Boy

    Monk E. Boy Network Guru Member

    You likely need to reset the NVRAM to default settings using the reset button, otherwise it will try to use the values stored in NVRAM as-is. Since DD-WRT stores its values in encrypted form, it's comparing what you type against the encrypted values stored in NVRAM, which won't match. After you reset the NVRAM it should be back to the default, which I think is admin/admin.
    Sean B. likes this.
  8. Julia!

    Julia! New Member Member

    Thank you! I thought I would receive some kind of alert by e-mail saying that you replied me. Anyways, thank you very much for your answer!
  9. KateSix

    KateSix New Member Member


    Just wanted to say this I've tried flashing several different AC56 builds of Tomato to this router (the Linksys EA6200), both from the web UI and from the CFE prompt via a serial port connection and couldn't get any of them to boot. If there's any other routers that you guys think might be close enough to be worth trying I'd be happy to do so -- the serial connection makes it pretty easy to recover from a bad flash. Makes it pretty easy to reliably flash to the "backup" partition too to avoid the reversions to the stock software.

    For now I have the 1/31/18 AC56 build of ddwrt on it.
  10. txnative

    txnative Networkin' Nut Member

    sell it and buy a different linksys ea version that is supported. Ebay has them priced from 29.00 to 40.00 pending on free shipping, etc
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice