Linksys Nightmare Please Help Me!!!

Discussion in 'Other Linksys Equipment' started by EvilRyu, Feb 21, 2005.

  1. EvilRyu

    EvilRyu Network Guru Member

    I have had the worst time trying to setup a wireless range expander. I can not get the red light to go off at all. I have exchanged out the range expander 2 times already, I am going to exchange another today. I have spent a total of 5 hours on the phone talking to the sorry Linksys Tech support. That had me doing the same thing for about 4 hours. I have tried all different kinds of firmware. I am at a point now that I do not know what else to do. I have joined this forum in hopes that my nightmare will be solved. My routers are wrt54g and the wrt54gs. I have even place all of the antennas of the routers and range expander within centimeters of each other and yet they still cant find the range expander. Please help I am almost at the point of tears now.
  2. linksysonline

    linksysonline Network Guru Member

    What are some of your router settings?? (ex: do you have wep on, SSID broadcasted, etc.) What things have you alreayd tried?
  3. EvilRyu

    EvilRyu Network Guru Member

    I have tried with and without the WEP settings and still nothing. The setup wizard always says it can not find the range expander.
  4. Toxic

    Toxic Administrator Staff Member

    have you installed the latest firmware for the WRE54G ?

    a new one was released last week, v1.04.17

    try resetting the routers to factory defaults first of all.

    then try connecting the WRE54G

    btw you are trying to conect one wrt at a time aren't you?
  5. EvilRyu

    EvilRyu Network Guru Member

    I can not even connect to the WRE54G at all. I have tried every firmware I can find for my router but I can not even log into the WRE54G at all.
  6. Toxic

    Toxic Administrator Staff Member

    and you have reset every device?

    reset 1 WRT54G wired to your PC

    reset WRE54G

    and no connection at all even with official firmware?

    then looks like both WRT54G and WRE54G are screwed.

    I know the WRE54G is hard to connect but if you have tried all methods of connection and firmware and RESET the router as well as the WRE then there is nothing you cna do except take the WRE54G back and demand your money back.
  7. EvilRyu

    EvilRyu Network Guru Member

    my WRT54G is fine, but this will be the 4th WRE54G that I have swapped, so far. I have even tried a different store just to make sure nothing is going wrong, or maybe that store got a bad batch of them. Right now I need an guaranteed alternative to this WRE54G if todays swap does not work for me.
  8. howardp6

    howardp6 Network Guru Member

    First reset the WRE54G to factory default setting by pushing a unbent paperclip into the hole that the rest set button resides for at least fifteen seconds.

    I found it is best to the router that you want to repeat the signal to transmit your SSID. The repeater must be entered in the list of allowed PCs to access the router. For now, disable your encryption temporarily.

    I would turn off any other router in the area that you own.

    Press the auto-configuration button in for about fifteen seconds and release it. Both LEDs should flash and then blink blue.

    At this point the repeater associates with the router, you want it to connect to and you can use your browser to futher set it up.

    Start your browser and type in, which is the default IP- address of the repeater. You should be prompted for your password and you should enter the default pass word of "admin" in lowercase and without the quotes.

    You do not have to enter the MAC Address of your router or the channel at this point, since it has already be set, but you should change the default passord and save thes setting. Unless your have 802.11B devices set the repeater mode to "G" only and save the setting.

    Set the encription at this point and save the setting. If you have firmware 1.04.17 you can use WPA-PSK AES or TKIP and save the setting.

    Reset the router to the type of encription you prefer to match the repeater, which will lose its connection to the router unless both match. One both have the same encryption both LEDs on the repeater should again blink blue. Move the repeater to the area you wish to place it. It will repeat the signal of your router and relay thae signal to our other wireless devices .

    I would start the other APs or Router in your area at this point.

    You should keep the SSID broadcast of your router set to enabled.

    Be aware, that the repeater has two drawbacks. Thre first is that is defeats the MAC Address filtering of your router, since it retransmitts the packets with its own MAC Address. The second is that it reducing the bandwidth of your network in half, since it only has one radion and it can only send otr receive at one time. It alos increases the traffic on your new work. Your routers should have the latest firmware, sinct the firmwork on the router must be a least a certain version.

    I would suggest you invest in better antennas instead of using the repeater, because of the drawbacks. I retired my WRE54G after upgrading to the WRT54GX, since that router has better bandwidth and range at a much higher costs. It is on sale periodically for 179.99. If factor in the cost of the repeater, better antennas or the WRT54GX are better options. Another option is to increase the paower output of your roter, but you have to have four times the power to get twice the range. In addition, increasing alos increases the noise and may interfere with your neighbors and should only be used at the last resorts.

    I hope this helps.
  9. Billmac

    Billmac Network Guru Member

    Your post was very helpful, I have had the same problem.
    I have been unable to use the linksys range extender. I run XPwith SP2, set windows firewall off. Turned off Norton firewall (but not antivirus). With WEP on or off software reports that WRE54G is not present (placed it in next room and tried next to the linksys router). With WEP off I tried the automatic setup button, link light turns briefly blue then red again, software does not pick up the extender. I need to boost the signal in the attic. Will try antenna upgrade but since I have 2 range extenders I'd like to set up at least one. SSID is set to broadcast on the router. I have never been able to get to the range extender on software. I will try your advice but this setup is not a piece of cake.Would that WRT54G solve my problem? --Bill
  10. demisoda

    demisoda Network Guru Member

    I have the problem of the red lights from WRE54G range expander. Finally I found its the firmware problem. Login to the web based of range expander & upgrade the firmware. This will solve the problem. I think this is the problem of the old version firmware problem. But u need to reset the expander first.
  11. eldoctor

    eldoctor Guest

  12. Billmac

    Billmac Network Guru Member

    RE: Upgrade firmware for the range extender. How?

    I cannot get the system to agree that a range extender is present. I have worn out a paperclip resetting it. The software says it cannot find the range extender.
    Since it is, in fact, there, and since it is plugged in, I assume that there is something on my system blocking recognition. Would the firewall on the router cause problems? I have turned off about everything else.

    Turning off the WEP and having the software fail is a nuisance. I have to go around and reset it on the other machines to use the network.

    I would not recommend this piece of hardware as it stands but I'm willing to keep trying. O the other hand, doing the same thing over and over and expecting different results is a marker for insanity. --Bill
  13. kempo

    kempo Guest

    A different twist

    I just purchased the wre54g and am(was) having the same problems decribed in this thread.

    But, a strange thing is happening. I took my laptop into the room where I wanted to be able to connect. The Link light on the wre is red. But my laptop is showing that it is connected @54Mbps! I have never been able to get any connection in this room before.

    To confirm, I powered down the range expander and sure enough, the connection was lost. Powered up and the connection returned. so, not only is the link light red, but I'm connected at full speed!

    Anyone heard this before? Think it'll last.

  14. doehlsen

    doehlsen Guest

    I had the same set of problems. Spent 2 hours on the phone with Linksys support. I read in another forum that SP2 might be the problem. I uninstalled SP2 on both the hardwired and wireless PCs, updated the router firmware to the latest version (Linksys tech had me roll it back to 2.07. I had already updated the range extender firmware), and rebooted everything. The range extender worked first time and has worked without a hitch ever since.

    However, I'm now running SP2 on a second wireless PC without problems. Go figure!

    Also, I just upgraded the router firmware to Satori v.4 and followed the instructions elsewhere in this forum for setting up the range extender. Everything continues to work without problems.

    The range extender makes a big difference once its working. Good luck.
  15. xfratboy

    xfratboy Guest

    What Worked For Me

    Here’s the fix (in a round about way)…

    1. Before starting obtain the latest installer for the WRE54G. There are two versions of WRE54G. You must use the installer from Linksys’ website. Don’t use the CD that came with your product. Even if you have 1.0 version use the 2.0 installer/setup wizard.

    2. While you’re at Linksys’ website pick up the latest firmware also. There was nothing on my WRE54G to indicate what hardware revision so I downloaded the firmware for both 1.0 and 2.0 (it won’t let you update using the wrong one so you can just use the process of elimination).

    3. Connect your computer (wireless adapter) to your existing wireless network. Also plug in the WRE54G at this point. If you have had previous failed attempts then you need to reset the WRE54G. Hold the reset button in (use a pin or paperclip) for at least 15 seconds. If you have successfully reset then the top light will turn RED.

    4.Unzip and run the Setup.exe program you downloaded in step 1. The version should read or higher (in bottom right corner of the setup screen). NOTE: I couldn’t get the program to work with my Addtran 802.11b PCMCIA adapter. It gave errors about “No wireless Network Card found.†I had a Linksys card in a desktop PC so I switched over to the desktop and tried (WMP54GS PCI Adapter) and the setup started successfully.

    This is where things get really important.

    5. The install will find your existing wireless settings (i.e. the SSID of your existing wireless network). Click YES to accept the settings.

    6. The next step will search for any existing WRE54G’s . It should find your WRE54G. It will say something like LinksysBzr1234?? as the SSID. DON’T select it or go any further in the setup/wizard program!! Don’t close the Setup Wizard either. Instead, open a browser (I used Mozilla because IE did funny things with the Java and closing windows/popups).

    7. Type this address in your Mozilla browser.
    leave username blank & password is: admin

    8. Verify your gateway is the IP address of your DHCP server/router. My gateway was

    9. Enter your network’s SSID but DON’T apply the settings yet.


    11. Now click the ‘Edit Security Settings’ button. Generate or paste your WEP key into the appropriate box. Click the ‘SAVE Settings’ button (the one within the WEP Key window. NOT the one behind it).

    12. At this point you’re browser will likely time out. Reason is because it just reprogrammed the WRE54G. If it doesn’t time out, then click the “Save Settings†button on the main screen.

    if everything goes correctly you should see two blue lights on the WRE54G. If not, then you messed up somewhere. If you get two blue lights then you should be able to refresh your wireless adapters’ discovery of existing wireless networks. I’m using the Linksys software vs. XP. You can identify the WRE54G by the MAC address (located on the back of the WRE54G). Attach to the WRE54G and you should be up and running.

    Alternate method (abbreviated):
    1). Manually assign an IP Address to the TCPIP settings of your wireless network card.
    IP Address:
    Subnet Mask:
    DNS Server:

    2) Start at Step 7.

    3) Once reprogramming of WRE54g is complete, change your IP settings back to “obtain Automatically.â€

    4) Reattach to your wireless network.

    If you can get to the router using a browser (again, Mozilla is what I use) click on the “Help†link at the top of the screen (to the right of the password link). Proceed with Update of the firmware. I updated the firware using my alternate method of manually assigning an IP address, then changing it back once the firmware completed.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice