Linksys RT31P2 firmware? - found it and upgraded :)

Discussion in 'Linksys Official Firmware' started by medic, Aug 9, 2005.

  1. medic

    medic Network Guru Member


    I've got the RT31P2 (unlocked) but with "old" firmware (1.20.00). Does anyone have a newer firmware or can anyone tell me where to get it? And does anyone know why Linksys are not making them available at their website?

    Thank you!
  2. Toxic

    Toxic Administrator Staff Member

    the RT31P2 was afaik soley for Vonage at one time. they handled the firmware update themselves which is done remotely. I take it you are not on Vonage then?
  3. medic

    medic Network Guru Member

    No I'm not using Vonage.

    I live in Denmark (Europe) and have purchased the router from a Danish VoIP provider. They told me to contact Linksys and Linksys told me to contact my provider. Great! :eek:
  4. medic

    medic Network Guru Member

    Upgrade completed!

    I've successfully upgrade my router using the firmware link posted by Toxic in this thread: :D

    Direct link here...

    I used and everything seems to be fine, and I can still access the voice configuration at On the "Info" page it says "Customization: Not Customized" so I guess the firmware is generic and clean.

    By the way my unlocked router is from
  5. RuMoR

    RuMoR Guest

    I have been looking for a firmware upgrade, only because I was having some issues with my router. I didn't get mine from Lynksys or Vonage. I got mine from, they sub contract from

    I have been unable to find a working firmware upgrade
  6. menot23

    menot23 LI Guru Registered

  7. mazilo

    mazilo Network Guru Member

    This firmware is old, the newest one is RT31P2_NA_v1.30.07_000_VM_3.1.09_LId_combin_code.bin

    On the same page, if there is a mention of "P2NA", then you have an RT31P2-NA version. AFAIC, an RT31P2-NA will have customization set to Not Customized (even on this firmware RT31P2_NA_v1.30.07_000_VM_3.1.09_LId_combin_code.bin). On newest firmware, I believe it may get changed to Open as shown on a PAP2-NA when runs on a firmware newer than v3.1.10, IIRC.
  8. ckeith210

    ckeith210 Guest

    Well, here it is. The RT31P2, I've been working with this router since April of '05.
    From setting up private networks, FTP, MySQL DB's and hosting websites.
    I'm your man for this and I have this router down pat.
    I've had my problems along the way, but i can pretty much tell you anything.
    Well for the firmware upgrade 3.1.09 I can find that for you :).
    Here it is. Enjoy it and good luck!
    Linksys RT31P2 Firmware upgrade version 3.1.09

    P.S.- Check out my new MMORPG coming out in the Summer of '08. Just got some scripting to do, then its gonna be around town :)! So check out the website and the forums. The forums are also located on the website that I created. Please visit it.
    Black Rain Online
    Thanks again!
  9. kilgore65

    kilgore65 Addicted to LI Member

    I have tried to upgrade my firmware on this router, the RT31P2, to no avail. I've tried disconnecting the Internet, disconnecting the power, everything. Any ideas what I might be doing wrong?
  10. jersully

    jersully LI Guru Member

    I can't upgrade my firmware either. I get the message "Upgrade action is not completed!! Upgrade file pattern error."

    I'm not too worried about it, though. I've actually had the router for a few years and never used it. I'm only playing with it right now. I have 1.30.00 firmware, but thought it would be nice to upgrade 5o 1.30.07.

    What issue(s) are you having?
  11. kilgore65

    kilgore65 Addicted to LI Member

    I actually can't remember the issue but it has been resolved, consequently I am not concerned about upgrading the firmware. Thanks though.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice