Linksys RT31P2 router with two voip phone adapter (Vonage)

Discussion in 'Other Linksys Equipment' started by 4skin, Jul 14, 2005.

  1. 4skin

    4skin Network Guru Member

    On the Linksys driver support page, the driver and firmware downloads are greyed out, and can't be downloaded. I assume this is because Linksys and Vonage don't want this router (that is provided free from Vonage) to be used with any other voip providers. This however is what I want to do. So, does anyone out there know how I could get some unlocked firmware???
  2. Toxic

    Toxic Administrator Staff Member

  3. Digger

    Digger Network Guru Member

    Anyone get this to work with an rt31p2-uv with 1.28.00?

    I get either of two things happening:

    1. Firmware upgrade starts and gets to "Please wait! Setup will take a few minutes..." but seems to hang at that point and still has old firmware after reboot, or

    2. Upgrade bails out earlier with "Upgrade action is not completed!!
    Upgrade file pattern error."

    Does anyone know of any way other than the admin web pages to load firmware on the rt31p2?

    (Or password for Voice_adminPage.htm ???)

    Also the login to this box seems to be password only (like my befw11s4). "Bolox" seems to work fine as a used id.


  4. Digger

    Digger Network Guru Member

    Did a bit nore searching and tried the tfp method (with password diabled), but get:

    tftp> put RT31P2_NA_v1.28.03_000_VM_3.1.03_LI_combin_code.bin
    Error code 4: Invalid Image !!
    Sent 1053696 bytes in 2.4 seconds

    And yes, I have re-downloaded the firmware form the South American site.

    The unlocked rtp31p2-na is distributed in North & Sourh America but to voip service providers only.

    There has to be a way to get this on my box 8O
  5. dimkasta

    dimkasta Network Guru Member

    The NA firmware has a word in its first line that sais


    I guess this distinguishes it as a NA firm and the locked unit denies to upload it.
    If someone can alter this to what the locked firmware has in that field, my guess is that tftp would work...
  6. Toxic

    Toxic Administrator Staff Member

    this is from the vonage forums:
    firmware is mirrored here:
  7. mazilo

    mazilo Network Guru Member

    RT31P2 firmware tools

    Perhaps, you may want to get this SPATools written by wafro to mod the SPA2K and PAP2 firmwares to unlock PAP2 units. This SPATools check the firmware header and modify it. Besides that, it also does the byte swap, IIRC. So, you may need to modify the source code to detect/change the firmware header and disable the byte swap. Good luck.

    Please do report back here.
  8. dimkasta

    dimkasta Network Guru Member

    I tried to replace the header in the NA binary using a HEX editor.

    The tftp did not complain any more about an invalid pattern but the upgrade failed nonetheless...
  9. mazilo

    mazilo Network Guru Member

    I reckon your problem is the device performs a checksum on the firmware to see if the firmware has been tempered with. As in your case, it has been tempered; thus, the device refuses to accept the firmware. Why don't you try the SPATools I mentioned above and use it to mod the firmware? Like I said before, you may have to make some necessary modifications to the source code of the tools.
  10. dimkasta

    dimkasta Network Guru Member

    I do not have the background to do that I'm afraid....
  11. mazilo

    mazilo Network Guru Member

    Do you have the RT31P2 firmware that you can e-mail to me? I can try to modify the source code; however, I don't have the device to test. Otherwise, I hope someone with such a background will read this and be able to help you out.
  12. dimkasta

    dimkasta Network Guru Member

  13. medic

    medic Network Guru Member


    I don't think the spatools will help much.

    It seems like the RT31P2 firmware is diveded into 2 parts (a router firmware and a voice firmware). The voice firmware which is at the end seems to be the same as for the PAP2. Just try to search for "LsInTeG FiRmWaRe" and compare it with a PAP2 firmware. I've tried to run the spatools on the voice part of the firmware and the tools seems to be able to parse the file... so the spatools will probably be able to calculate the correct crc, but only for the last part of the file.

    SPA2000 Firmware Upgrade Patcher for PAP2 by Wafro.

    This utility patches SPA2000 firmware upgrades to work on PAP2 boxes.
    Tested on spa2k-2-00-09-d.bin

    Input file: test.bin
    Output File: out.bin
    Ident: LsInTeG FiRmWaRe
    Version: 3.1.6(LI)
    Num Entries: 3
    Entry Length: 128
    This is not an SPA2000 Firmware Upgrade File!
  14. Anonymous

    Anonymous Guest

    At least you had made some progress that perhaps shook some people @Vonage ... :cheering: :cheer: :clap: :thumbup: :rockon:
  15. dimkasta

    dimkasta Network Guru Member

    any progress...?
  16. dbradford

    dbradford Network Guru Member


    Any have a hack for the RT31P2 Yet??

    If not, I am willing to donate one to the cause to help get this S.O.B. hacked and usable somewhere beside Vonage.

    Dickie :cheerup:
  17. killians913

    killians913 Guest

    Looking for hack on RT31P2

    Hey there! Can anyone provide this pls? Thanks much!


  18. dbradford

    dbradford Network Guru Member

    Nothing yet

    Nothing yet as far as I know.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice