LinkSys RVL200 & AM200 - A problem, a solution and a question

Discussion in 'Networking Issues' started by WillNDowed, Dec 18, 2006.

  1. WillNDowed

    WillNDowed LI Guru Member

    I thought I would post this here as it may help someone to save a couple of hours and a lot of bad language should they run into the same problem as I've just encountered with an AM200 modem and a RVL200 VPN router. (I also have a question though...:) )

    I wanted to be able to VPN into my network while I'm away, so last week I bought a LinkSys RVL200 and a LinkSys ASDL+ modem, a AM200.

    Following some useful help from DocLarge and Dellsweig, I configured it as follows:

    AM200 - Bridge-Only Mode
    RVL200 - PPPoE with correct user id and password

    (My ISP, BTBroadband, recommend PPPoA, but the RVL200 doesn't support this and I did test PPPoE on the AM200 which worked fine)

    Although setting the RVL200 to PPPoE gave my a 'Connect' button, it steadfastly refused to connect via the modem and always showed a WAN address of

    As the modem status showed that the link was UP I focused on the problem being with the RVL200 and first upgraded the firmware to 1.0.14 (shown as latest on the Linksys site) and then to 1.0.16 from here. I also tried just about every combination imaginable thinking I'd missed something simple.

    Still no joy, even after a 'Live' chat with LinkSys support.

    Then the breakthrough! Tonight I borrowed a WAG54GS, set it to Bridge-Only mode and BINGO, the RVL200 connected to my ISP using PPPoE.

    So the problem is actually with the AM200 that doesn't seem to 'Bridge' correctly.

    Now, that has identifed the problem and I've reported it to LinkSys but after reading this thread from here I have a question:

    Would setting a modem to PPPoA, allowing it to connect to the ISP and then setting the address of the RVL200 in the DMZ of the modem work for VPN access? If it would, and the performance wouldn't suffer, then this might be the answer while Linksys do something with the AM200 firmware.

    What do you think? Is that too simple a solution?

  2. mauromol

    mauromol Addicted to LI Member

    Hi Will!
    I was wondering if Linksys gave you any feedback on this problem...
    I have something similar: once I configure the AM200 in Bridge Only Mode, it works perfectly if I connect it directly to my PC and create a PPPoE connection in Windows, but if I connect it to an Asus WL-500gP V2 configured to use PPPoE, it always give a PPPoE authentication error, even if username and password are correct...

    I too suspected it was a router problem, but now I have found your message....

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice