Linksys won't work with my iMac G4

Discussion in 'General Discussion' started by Deltahedron, Mar 24, 2006.

  1. Deltahedron

    Deltahedron Network Guru Member

    My new Linksys WRT54GSv2.1 (latest Linksys firmware) doesn't work on the WAN with my iMac G4 (flatpanel, running OS X 10.4.5). Has anyone else had problems with an iMac G4?

    I've tried replacing the WRT54GS to verify that this isn't a hardware issue at that end. The G4 works fine on the LAN, but any attempt to access the WAN fails. Other machines on the LAN (including an iMac G5 running 10.4.5) can get to the WAN fine.

    The problem is the same whether I use the wired or wireless interface on the iMac, which suggests this isn't a hardware issue on the iMac. The problem goes away if I switch back to my old Netgear router. I configured the Linksys using a PC in the most standard manner, and the iMac is using DHCP with no manual setttings or firewall, etc.

    As an example of the problem, "ping" on the LAN works fine, but ping of an IP address on the WAN or a host lookup on the WAN both get error messages involving the phrase "memory allocation error".

    Has anyone else seen anything like this? Any ideas what to try to make this work? Thanks for any help!!!
  2. sreevas

    sreevas Network Guru Member


    hai i had gone through ur issue please try to assign a static i.p. to ur computer in the range of the router and enable DMZ on the router for that particular i.p. address and check weather ur able to ping the router or not and i hope it will work plps check this and mail me the result to in the mean time let me check for the other fixes bye
  3. Deltahedron

    Deltahedron Network Guru Member

    enabling DMZ didn't help

    Thanks for the suggestion, Sreevas.

    I tried enabling DMZ for the iMac G4 (with a static IP address) and this made no difference. I can still talk to machines on the LAN (including the router) but can't talk on the WAN. The failure is still the same: "memory allocation error".

    I also tried reducing the MTU setting in the router (to 1200) with no effect.

    Has anyone else had a similar problem? Thanks again!

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice