Linksys WRT54G - strange brick problem

Discussion in 'Cisco/Linksys Wireless Routers' started by petr__22, May 2, 2007.

  1. petr__22

    petr__22 Guest

    Hello, friend of mine give me WRT54G version 1.1 device which suddently died after flashing unofficial firmware (he dot know which one) with official one.

    When the device is started, it responds for ping few seconds and ther restarts and restarts again, power LED flashing. In these few seconds is possible to send new firmware with tftp or linksys flash utility.

    Uploading take cca 10 seconds to complete (everyone write about 2 minutes), flashing firrmware (time between sending file and automatic restart, when device dot respond) is about 30 seconds.

    Original linksys firmware: succesfull (???) flash, keep restarting forever
    Whiterussian 0.9: hang after boot, power and DMZ LEDs on
    Another firmware: no respond after boot

    After reboot is allways possible to send new firmware using tftp, therefore it is not totally dead. Strange thing is it take only few seconds to upload new firmware and when I use linksys original utility, it display previous firmwrae and new one - and there is nothing displayed as version in the device, even if i send original firmware before.

    Do anyone have experience with this problem, please ?

    I already tried to short pins 15 and 16, with same result - uploading firmware is allways possible, without shorting pins. The trick with pin 16 and antenna grounding have same result. Device respond to ping few seconds after reboot.

    There is a possibility to copy entire eeprom content from another linksys device, but it is only last possible try, because it need desoldering boths eeprom and doldering them back.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice