Linksys WRT54GC - died after firmware update

Discussion in 'Cisco/Linksys Wireless Routers' started by I_mak, Apr 16, 2006.

  1. I_mak

    I_mak Guest

    I have downloaded a firmware update from official Linksys wesite, went to to update via Admin tools and in the middle of updatng my router died. Power light is now always yellow.

    Any thought whether or not I can restore it or ...?

    Thanks in adance.
  2. eric_stewart

    eric_stewart Super Moderator Staff Member Member

    With the unit powered on, press the reset button until the LEDs all go out then flash again.

    The recessed reset button is under the swiveling foot on the bottom of the unit.

    Worth a try, though all this does is reset the configuration to factory defaults. Failing this, you can also try to push firmware up to it with a tftp client in the 1st 10 seconds as you boot the device.

  3. magnoxman

    magnoxman LI Guru Member

    I have this is exact issue... scares me that an official firmware update would do this... would love someone to post a fix for us :)
  4. siftspam

    siftspam Guest

    I just bought a WRT54GC today and tried to upgrade the fw from 1025 to 1028. The router stopped responding after redisplaying the fw upgrade web page after the (failed?) upgrade. Not a good sign. :(

    The reset button doesn't seem to do anything nor does power cycling the router. I ran ethereal (on linux) to sniff the interface connected to the router. The router isn't even responding to the ARP requests generated when I try to ping

  5. marcmarshall

    marcmarshall LI Guru Member

    I went through 2 of these routers trying to flash the firmware. I spent hours with customer support on chat and phone. Finally was told to get a WRTG instead!

    So what's up:
    Are these defective routers?
    Is the firmware code corrupted?

    I'm using my third one now and haven't tried flashing yet. Previosly I only used the web admin page. Maybe I'll try the TFTP program. The manual says this program is downloaded in the firmware download. IT IS NOT! You can get it on the FTP site. It didn't help me after the firmware flashes toasted my routers.

    This is my first experience with Linksys and I am not a happy camper!
  6. svg1

    svg1 Network Guru Member

    You guys must have terrible luck . I have flashed my wrt54gc at least 7 times . Curently using 1046 beta .

    Even flashed it with 10AC which turned out to be japaneese firmware & was able to flash us & uk firmware back to the router .

    I would try holding the reset button in while powering on the router & continue to hold for about 10 sec.
  7. magnoxman

    magnoxman LI Guru Member

    Tried holding for a minute, the router is toast. Time to return it to the store.
  8. marcmarshall

    marcmarshall LI Guru Member


    Well I'm afraid to try flashing and brick a 3rd router. If I get brave how did you flash? Did you use the web admin or TPFT program?

    What router is the 1046 firmware for? I read on the forum that we can't flash this router with 3rd party firmware. I don't see that version listed on the firmware tracker page either.

    Which firmwares can we use with this router? I found some EU version on the forum that supposed to be ok for the US versions as well.

  9. svg1

    svg1 Network Guru Member

    I use the web based UI to flash the router . Restore the router to factory defaults before & after the flash .

    Dont think the tftp app will work with the wrt54gc . Never seen it included with any firmware downloads for the GC.

    The 1.04.6 is beta firmware for the wrt54gc . There is no 3rd party firmware for this router since it uses a marvell chipset & will only run linksys firmware .

    Have tested 1.02.5 , 1.02.8 , 1.03.0 , 1.04.4 & 1.04.6 . & had no problems flashing any of them .
  10. marcmarshall

    marcmarshall LI Guru Member

    Hmm, tempting. Thanks for the info and the link. Does this firmware add any funcionality besides what the official 1.02.8 version on the linksys website does?

    A Linksys technician told me I could flash with the WRT54G-CA(FR) firmware. Although the model is listed under the WRT54GC model in the firmware drop-down list I can't find this model listed anywhere on linksys. It appears to be the Canadian version of the G (maybe FR is for French) so I doubt I can flash with it.

    also, I assume it's ok to restore a saved profile after flashing?

    thanks again................marc
  11. svg1

    svg1 Network Guru Member

    Dont know if it adds anything since it didnt come with release notes .

    I have flashed my us version with UK , CA firmware . The only real diffrence i see is the addition of channels 12 & 13 with UK firmware .

    If your saved config profile is from US firmware then you restore it to the router running UK or CA firmware it may brick the router.

    linksys internation ftp server

    Dont use the DE , GE or IT versions unless you can read those languages .
  12. marcmarshall

    marcmarshall LI Guru Member

    Well, Itried a flash with the 1.04.6. followed your suggestions carefull. Bricked again! That's 3. At this rate I'll have enough bricks for a house soon.

    The flash hangs at the end, the browser times out, and the router turns into a switch or something. I can connect to the internet but not get into the admin page. All the green leds flash in unison.

    I wonder if can be something with firefox or zonealarm?
  13. BlackDex

    BlackDex LI Guru Member

    Check if the gateway/router ip isn't changed or something.

    Disable Zone-Alarm before you update.
    And try to use IE.

    Some linksys products work better with IE as browser then with Opera and Firefox in my experiance.

    Also, turn of every proxy or web filtering program you have.
    Some Anti-Virus products scan web activity also, so try to turn this off as wel.
  14. IsLNdbOi

    IsLNdbOi Network Guru Member

    Booting up in safemode w/ networking is probably the safest way to flash your firmware.
  15. Trademark

    Trademark Network Guru Member

    Just wanted to share a successful upgrade story, that MAY help.

    Newly purchased WRT54GC for ~$20. Came with stock firmware version 1.02.5. I was a little hesitant doing a firmware upgrade after reading this post, but also feeling pretty confident since I have never had a firmware upgrade issue. So, I decided to go ahead and give it a try.

    I first plugged in power to the router and let it settle for a minute. I then plugged an ethernet cable from my computer (Mac G4 OS X 10.3.9) to ethernet port 1 on the router. I opened Firefox (version, and accessed the router at with the default password. I then did a reset to default settings and waited for the router to recover.

    At this point, I "Clear Pivate Data" in Firefox. If I skip this step, I occasionally get a page not found error when applying changes to the router.

    Now it's time for the firmware upgrade. First I made sure my DHCP wasn't expiring anytime soon. I then used firmware 1.02.8 off the Linksys website. Watched the progress bar reach 100% and viola! Upgrade successful! Followed with a hard reset pressing the little button on the router for ~40 seconds.

    Can't say much has changed in the upgrade. "Disable" is still missing from wireless network mode. This was one thing I was hoping it would fix. Oh well. I think the "Access Restrictions " layout might have changed, but I wasn't paying enough attention.

    I never hooked it up to my cable modem or another computer, so I can't comment on speed, although I did notice it took more time to apply changes to it than my WRT54G & GS. Noticeably longer with wireless settings. Can't complain really though, for the price.

    Next comes 1.04.6. We'll see what happens.

    Thanks for reading, Cheers.
  16. marcmarshall

    marcmarshall LI Guru Member

    BlackDex and IsLNdbOi- I suspect it is something to do with my browser. I forgot I had the ff extension NoScript" running. This may have blocked something.

    Trademark- thanks for the info. I was hoping to be able to turn off wireless when needed also. The flash also allows entering of longer user id and/or pass words for ppoe config. This might be necessary if you use this as a portable router.
  17. Trademark

    Trademark Network Guru Member

    Well, 1.04.6 beta was successful, but weird. I never saw a progress bar during the upgrade. The screen just flashed for a moment, and the lights on the router blinked in many ways. I waited about 5 minutes and refreshed my browser, and my firmware read 1.04.6.

    Since this happened, I flashed back to 1.02.8. Only difference I could find with 1.04.6, was wireless ch 12,13 were added. Not feeling real good about this beta, so I'm sticking with stock for the time being until something official comes along.

    If anyone can confirm extra features included in the newer releases, let it be known. Thanks.
  18. spiderx1016

    spiderx1016 Network Guru Member

  19. magnoxman

    magnoxman LI Guru Member

    I was using a clean IE6 for the upgrade.
  20. zdensys

    zdensys Network Guru Member

    I upped mine to 1.4.05 without any problem..
    there seems to be a buffer overflow prob with 1.2.08 in the port setting..

    try any value above 40000 and u will get either 0 or other port number after refresh..

    this is fixed in 1.4.05..
  21. Trademark

    Trademark Network Guru Member

    Hmm, buffer overflow problems are not good, so I upgraded to 1.04.6 Beta again.

    To my surprise, I got the progress bar while upgrading. Good enough.

    Thanks for the info zdensys.
  22. Leonliaoxp

    Leonliaoxp Guest

    Try this one, v1.10.1_AU

    I've bought a Wrt54GC few days ago which included a CD that has a strange version of firmware, V1.10.1. It support Bigpond and so on, good for use in Australia. Just give me you Email so I could send you a copy if you want to try it.
  23. Trademark

    Trademark Network Guru Member

    You've got my curiosity Leonliaoxp. The CD that came with mine contains no firmware files.

    What is the modification date for 1.10.1? Did it come with any version info documents?

    1.04.6 shows Jan 19, 2006, and so far has been rock solid.

    If it is more recent and compatible with US hardware, I might take you up on your offer.

    Let me know. Thanks.
  24. Marclum

    Marclum Guest

    Hi I'm new to this forum and have bought a wrt54gc router (default firmaware version in box). Wanted to configure DDNS and was told by my friend who has done it 2 days ago. On the 3rd day the DDNS just stop updating. Any one may have this experience and how I can resolve this?
  25. kiboko

    kiboko Guest


    my wrt54gc sometimes loses the wireless connection, and he needs several minutes to comeback, even if I disconect the router from the plug.
    where can I get the 1.04.6 fw? I've looked at the ftp, but it's not there.

    btw, what is the diference between the v1 and v2? Can we use fw from v2 in the v1?

  26. n7okn

    n7okn LI Guru Member

    I have one as well, and I find that if I put too many ip addresses in the access restriction list (with specified time restrictions), ICMP packets (ping) get blocked for any traffic, although all other packets get through. This happens even when I have IP address ranges in the list of filtered PC's. Also I can't put in a TCP or UDP port with a value of over 20000 to be forwarded in the gaming section. This unit seems to have its share of problems. Also, is there any firmware available that lets you turn off the wireless radio?
  27. Kellson

    Kellson LI Guru Member

    Hi, I'm in Oz either~~~could you shard this version to me? and also i have figure out the way to unbrick this router (ive tried to flash other brand's fws such as Belkin, Sercom, and Hawking, works!!)~~~anyone would like to have a try??:biggrin:
  28. Kellson

    Kellson LI Guru Member

    Sry agin...where can i find the 1.046 fw?(i wanna try as well) the link in page 1 is dead...thx~~~
  29. angelcagemax

    angelcagemax LI Guru Member

    I need the 1.046 fw
    Help me plsssssss
  30. Trademark

    Trademark Network Guru Member

    PM me your email and I will send you a copy tonight.
  31. Kellson

    Kellson LI Guru Member

    I just got the v1.10.1 firmware~~~check it:
    I've upgraded my router with this version, and it works fine, just duno what r the differences compares with the 1.04.5 or 1.04.6beta~~hope u guys will enjoy it...^_^
  32. angelcagemax

    angelcagemax LI Guru Member

    many thanks, kellson
  33. zdensys

    zdensys Network Guru Member

    Kellson, can you verify if this v1.10.1 firmware has all the channels in EU mode?
  34. titelbaumd

    titelbaumd Guest

    As Ver. 1.10.1 is not (per Linksys) a supported version (at least for North America), what does it change from the current release, 1.05.7?

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice