Linksys WRTSL54GS on Tomato Firmware v1.27.8747 ND USB: Install and run Lighttpd

Discussion in 'Tomato Firmware' started by Aquafire, Jul 23, 2010.

  1. Aquafire

    Aquafire LI Guru Member

    Hi All,

    I am running (teddy_bear)Tomato Firmware v1.27.8747 ND USB vpn3.6 on Linksys WRTSL54GS running in PPoE mode, connected to a bridged DSL Modem.

    A 4GB USB flash drive is connected with separate mouted partitions for SWAP and "optware" as OPT. The opt partition is mounted and binded with the USB flash partition to install optware packages. Have installed IPKG to install and try various packages.

    IPKG is using the following repository.

    After some reading I have been trying to install a very basic lighttpd web server on the router.

    My main objective is to share and publish the shared directories (which are on connected NAS drive and/or home PC) on my home network to my friends for downloading music/data, optionally with a basic welcome page (HTML) and username/password authentication.

    I need specific instructions about how to do that.

    What I have tried till now is to install the lighttpd server from the IPKG repository with all its dependencies. The lighttpd version installed is as follows:

    Doing some reading I have tried to configure the lighttpd.conf file as follows, it resides in the folder /opt/etc/lighttpd:

    I dont really know which modules to enables and how to further configure them so I have enabled the minimum basic modules according to my understanding.

    Since the native tomato WebUI interface runs on port 80 (as it is opened by default whenever i type I have tried to set the lighttpd server port to 8080.

    I have also done a port forwarding of any external (WAN) port 8080 to the local router address port 8080 (dont know if it is needed or not).

    After that I manually log in the router via puTTY and run the following file
    which gives me a message

    So after all this, theoretically if I open the web browser and point it to then it should open the default index.html page. The index.html is placed in the /opt/share/www/lighttpd (the default location).

    But all in vain, the web browser keeps searching indefinitely and never opens any page.

    The error.log file in /opt/var/log/lighttpd is as follows:

    I cannot seem to understand what is wrong, and why I am unable to access the server on the defined port.

    So can anyone guide me how to make a working setup of shared directories (password protected) using lighttpd server.
  2. Aquafire

    Aquafire LI Guru Member silence...

    Looks like no one is running lighttpd on Tomato....strange anyways..
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice