Linksys WRVS4400n QuickVPN issues

Discussion in 'Cisco Small Business Routers and VPN Solutions' started by Incognito2112, Mar 13, 2008.

  1. Incognito2112

    Incognito2112 LI Guru Member

    Hello all,
    First off, I wanted to thank everyone who contributes this site, it's a fantastic resource for an amatuer such as myself.

    Ok, on to the issue - Recently I purchased a WRVS4400N gateway/router for my store and immediately updated the firmware to 1.01.03 and downloaded the latest version of the quickvpn utility for my my two remote users - one has Xp, the other Vista.

    I am able to get the green ball using the QuickVPN utility, but I always get the dreaded "Cannot connect to remote gateway" 20 seconds later.. Am I missing something?

    The store connection is a Qwest ADSL circuit running to a cable modem. The ISP provides one dynamic IP address and I have the line running to my WRVS4400n.

    I have configured the following on the Router:

    DHCP is enabled and shelling out addresses in the 192.168.100.x range
    I have configured static addresses for the printer and computer at the store.

    I have configurd DDNS with DYNDNS, and this seems to be working fine.

    Everything is enabled except for block wan requests

    VPN-> users have been configured and I see them connected when looking at the status
    I have all the passthough options set to enable

    Certificates have been generated and copied down to the quickvpn program directory for both clients.

    I have the following configured for my clients:

    The XP (sp2 without firewall enabled) is connecting over an ADSL line provided by the same ISP. It connects to a wireless 'Rangemax' router with DHCP and basic security. the IP rang used is diferent than my store: 192.168.1.xx. i am using the 1.10 quickvpn utility and I can connect, but recieve the dreaded "Cannot connect to remote gateway"

    Any help would be greatly appreciated.
  2. Toxic

    Toxic Administrator Staff Member

  3. Incognito2112

    Incognito2112 LI Guru Member

    Static IP's

    When you say give te clients static IP's, are you suggesting that I just give the remote PC an address n the 192.168.1.xx range? Or do you want me to turn off DHCP on the remote router all together?

  4. Incognito2112

    Incognito2112 LI Guru Member

    Enough is enough

    I have tried everything to try to get QuickVPN to be stable with this device with no success.

    I'm convienced that this product is not ready for prime time - It's good in theory, but I didn't sign up to be a beta tester for Linksys firmware issues, QuickVPN disconnects & constant router lockups.

    I need a router that functions as advertised. I am disgusted at the amount of time I spent trying to get this ill-designed brick to function. It became a challenge for me to try to get this thing to work. I tried every possible router setting, reg fix, static IP, multiple client ISP's, software versions, etc. without success.

    I just bought a Sonicwall TZ150 Wireless from Egghead for $280 and plan on buying 2 VPN clients at 40 dollars each. I am looking forward to having VPN client software that behaves like a virtual adapter instead of the black magic/voodoo quickvpn crap.

    I just wish I had spent the extra hundered bucks in the first place, I would have saved myself the fraustration.

    I appreciate all the help though, good luck everyone.
  5. jeru

    jeru LI Guru Member

    Thats pretty much my same sentiment. I never got it working either so I just reverted to openvpn on a linux server behind it. I could get it working by statically setting up the ipsec tunnel but the quickvpn function is fundamentally flawed along with their firmware. (though it would degrade over time and require a reset, it did work for a little at a time)

    Personally, my beef was with the access point constantly crashing on it so I tried to downgrade using their restore utility. I guess I should have known it would have turned that thing into a brick. I've learned not to expect anymore more than utter disaster from Linksys if the letter "N" is involved. I just replaced it with a WNR3500 from Netgear and imagine my delight when I found everything functioned flawlessly and as advertised.

    I really hope the 3rd party open source projects can help people with this router. I still have another one that I'm afraid to touch or look at incorrectly. That one people just deal with the access point constantly crashing and HUPing or whatever its doing. I had to replace all of the linksys wireless N cards in that location though. Every single one of them was either stalling the system driving the user crazy when the driver was installed or simply never got them working. Think that was probably due to their horrid Vista drivers, I honestly stopped caring to find out. I just replaced everything with Belkin and Netgear N cards and every single one works flawlessly despite the router there. They know how to yank the power cord to restart it every day to get wireless back up or to access something over FTP every day though. So I guess they are just trying to deal with it.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice