Linux Printing?: PSUS4 Print Server

Discussion in 'Other Linksys Equipment' started by eric_stewart, Oct 12, 2006.

  1. eric_stewart

    eric_stewart Super Moderator Staff Member Member

    I'm not a noob with Linux but I've tried all the obvious things in setting up my PSUS4 so that the CUPS printing system will print to it.

    Anyone have a working configuration they'd like to share?

    I'm running Ubuntu LTS 6.06 w/s. It's a mail server mainly, but I'm trying to tinker with some other features. I can ping/manage the device from the mail server.

  2. pablito

    pablito Network Guru Member

    I don't have that print server but google is your friend. :)
    I've read that most people are having trouble with using the IPP (CUPS) protocol with this device. However the fix is to use the LPD protocol. I typically use LPD against all print servers anyway since it is usually supported by all devices.

    So in CUPS (the web interface is easiest) you would select LPD/LPR and then the URL similar to: "lpd://192.168.XX.YY/name" with the p server IP address and port name (USB1?)

    This style of CUPS config has worked for me against even very old print servers.
  3. eric_stewart

    eric_stewart Super Moderator Staff Member Member

    Thanks. That's exactly the information I needed. I didn't know what to put in the "name" in that URL. I Google'd for the information too, but no one put a finger on precisely what to use for that field. I'll try it out and report back....

  4. jochen

    jochen Network Guru Member

    The printer queue name is "P1".
    An yes, IPP ist not working with this device. :-(
  5. mstombs

    mstombs Network Guru Member

    From windows XP I print via my PSUS4 using the following address, rather than use Linksys printserver utility
  6. Disman_ca

    Disman_ca Super Moderator Staff Member Member

    I'm not sure if this works but it worth a try.
  7. jochen

    jochen Network Guru Member

    Go to the web interface of the PSUS4 and select "Status", then "Printer". There you can see the printer name. Mine is "P1".
  8. kewashi

    kewashi Guest

    This is awesome... I had the exact same problem and eventually gave up and bought a copy of turboprint which I thought only worked if connected directly to my printer which fortunately has two usb ports on it. I would prefer to use the print server so I tried this and it worked like a charm. in Turboprint I had to use the "other URI" option and then typed the lpd://192.168.1.x/P1 where P1 is the default port on the PSUS4 server. Many thanks folks. By the way, I am still glad I bought turbo print since my printer doesn't work very well with the default Linux drivers.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice