Loaded 2.1b1, cant load anything else now?

Discussion in 'HyperWRT Firmware' started by kjmcdonald, Feb 8, 2006.

  1. kjmcdonald

    kjmcdonald Network Guru Member

    I downloaded HyperWRT 2.1b1 to my WRT54GS v1.1, and now I can't download any other firmware to it.

    I've tried downloading Linksys 4.70.6, Freeman 1.04, DD-WRT v23. All of them give me the 'Upgrade are failed' page.
    Other than that the Router appears to be working normally.

    Do I need to use the TFTP method? Where can I find a 'how-to' on that?

  2. Guyfromhe

    Guyfromhe Network Guru Member

  3. kjmcdonald

    kjmcdonald Network Guru Member


    That hot-to discusses using the linksys program that pushes the frimware to the router. The current firmware release for my router doesn't have one of those programs. It only has the .bin (or .code?) file.

    Also it says you'll need to try that method if you didn't get 'boot_wait' set.
    I thikn I do (or can) have boot_wait set. My router isn't technically bricked (yet :) )
    It seems to work perfectly except for downloading new firmware. If I do (or can) what's the method to get the firmware to the router using boot_wait.

    Isn't there a tftp program that sends the file while the router is waiting? Where do I get that?

    Thanks again,

  4. NateHoy

    NateHoy Network Guru Member

    If you are running Windows, TFTP is already there. Just go to a command line and type TFTP and hit ENTER and it will give you help text telling you the command line syntax it expects.
  5. kjmcdonald

    kjmcdonald Network Guru Member

    Ok.... It's different anyway.

    Well I 've been successful in tftping with the WinXP tftp (with the -i option for binary mode) program. I get the 'successfully transferred 3097xxx bytes (I don't remember the xxx but the number was over 3million - and under 3072K or 3MB)

    But when it boots it waits for the tftp again - well I assume it is, it doesn't comeup, and the tftp works again. I"m sure I've held down the reset button enough by now that boot_wait is now off, but I can still tftp.

    I know there's a 3MB limit on the TFTP loading, I don't think this image is that big (It's the 4.70.6 Linksys image.) but I don't have any that are smaller.

    Where can I get real old (smaller?) original linksys firmware images? their site doesn't have an archive section that I can find.

    I've been reading everything I can find, I've only seen the 3MB limit referenced once (and not in the link above.) Also I've seen somepeople say you need to upload a file named 'code.bin' does the file need to be named 'code.bin' on my PC before I send it?

    Does anyone have any ideas why 2b1 wouldn't let load any new firmware through the web interface to begin with?

  6. paulrolson

    paulrolson Guest

    I have the same problem identified in the first post. The one thing to note though is that the router is NOT bricked (although people seem to be alluding to treating it as such to resolve the problem). My router works fine, but whenever I try to upgrade it tells me that it has failed.

    I have a WRT54Gv2.

    If I login to my router is says that is a WRT54GS (which it is not) with Firmware Version : v4.70.6_Hyperwrt-2.1b1-(Thibor)

    Any other suggestions on how to resolve this problem other than following the procedure to unbrick?
  7. Zsankee

    Zsankee Network Guru Member

    first, try to reflash with the official linksys firmware. some router has problem with flashing if the flash image is bigger then usually 3MB. if you succeded, press reset button, then you can try with tofu firmware,if you have a wrt54g, if gs, then thibor.
  8. Zsankee

    Zsankee Network Guru Member

    Re: Ok.... It's different anyway.

    try firts flash the hyperwrt 2.0,then the 2b1 or some other firmware. Its funny, i hade the same problem, couldnt flash any new firmware after 2b1. so i tried to flah with the older one, and it worked, after that you can flash newer firware
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice