Local networking with the WAG54G

Discussion in 'Networking Issues' started by MakTheYak, Jul 7, 2005.

  1. MakTheYak

    MakTheYak Network Guru Member

    Hi! I stumbled across this site in the search for some solutions and so I thought I'd post and see if anyone else is getting this:

    I have a Linksys WAG54G (firmware 1.02.7) and all my machines can connect to the net just fine but when it comes to talking to each other... well it just doesn't happen. I can't ping between machines (I tried between and in both directions) but all machines can ping the router. I'm running windows XP with the windows firewall turned on and no settings modified from the default. I'm a bit of a novice at setting up routers so I can't figure out if it's the router or the windows firewalls (or both).

    Any suggestions?

  2. cyberaxe_uk

    cyberaxe_uk Network Guru Member

    no networking

    Argh!! I have the same problem EXACTLY. Both my PCs can connect to the internet just great through the gateway, but the local network doesn't exist.....and I'm running XP with SP2 on both so go figure :(
  3. tallicalord

    tallicalord Network Guru Member

    Errr... Did you guys check the option of File and Printer Sharing on Windows firewall exceptions? (you should check this option if you want netBios running between windows machines, so they can comunnicate with each other through this protocol)...

    I think even ICMP is not available if the option mentioned is not selected, and that's why you guys aren´t being able to ping between machines

    Try it... If I'm wrong, someone correct me!....

    Cheers...:) :thumbup:
  4. MakTheYak

    MakTheYak Network Guru Member

    Thanks for the suggestion... unfortunately I gave up and bought an Apple AirPort Express - so easy to set up and it just works.

    Hopefully cyberaxe will be able to sort his problem now though :) (and also whoever bought my Linksys router off me on Ebay ;) )
  5. cyberaxe_uk

    cyberaxe_uk Network Guru Member

    STILL no networking

    Funnily, I've even tried disabling windows firewall, but still no luck! And to top it off, after upgrading the firmware to see if that would help last night, I can no longer open the gateway start page!!!!! (, but I can surf..WTF. And I've pressed the reset button so many times my fingers hurt...it's going to be a long day (sob)
  6. cyberaxe_uk

    cyberaxe_uk Network Guru Member


    YES! You heard it right! I spent 6 hrs on the phone with Linksys (cough) support, listening to them tell me to check things I had already spent 2 days doing....then I remembered something I had read on another forum about someone changing the wireless channel in the web interface ( to channel 1 instead of channel 11, and I reflashed the firmware to 1.02.7, and VOILA! After rediond the network setup wizard, I completely stumbled across the fact that I could access files between my PCs!!

    So my advice is: don't ever give up, and always consider even the smallest detail or most ludicrous sounding solution...:)
    :cheer: :cheer: :thumbup:
  7. cyberaxe_uk

    cyberaxe_uk Network Guru Member

    Added thought

    One thing I also did which I forgot to mention is:

    right-click on your connection and select Open Network Connections. Then right click the wireless connection and select Properties. Then, under the General tab, double-click Internet Protocol (TCP/IP) and click on the Advanced tab. Next click on the WINS tab, and select Enable NETBIOS over TCP/IP and press ok 3 times. Do that on both machines and rerun the network setup wizard.

    Good luck

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice