log out, I must be missing something

Discussion in 'Tomato Firmware' started by luke-san, Nov 8, 2006.

  1. luke-san

    luke-san LI Guru Member

    Hi people,

    After toying around with dd-wrt for a while I decided to change to Tomato.

    I like it alot and I wanted to show of the firmware to a couple of colleagues at work.
    So after installing dyndns I can easily access it from anywhere.

    But, yes, that part, since I do not like to use the default user/pw admin/admin onto a device connected to the internet I changed the pw.
    So far so good.

    I logged on to the router using a colleagues pc without a problem, but when I tried to logout (left bottom) it wouldn't let me with either the admin/admin or my own created pw.
    I thought it was something I did wrong on the router,but after trying it on the local lan connection at home it doesn't work either.
    Am I missing something?


    Luc (aka Luke)
  2. mrdude

    mrdude Network Guru Member

    Same here m8, it must be a fault - just use internet explorer or whatever browser you are using to delete your cookies instead.
  3. turbo53

    turbo53 Network Guru Member

    I think Tomato just keeps a session cookie. All I have to do is close the browser and the next time I will need to log into the router again.
  4. Int15

    Int15 Network Guru Member

    That's funny, I was under the impression that the Logout was redirecting me to the login page. I always assumed that was the reason I was getting the prompt.

  5. luke-san

    luke-san LI Guru Member

    Jon's reply

    There doesn't seem to be a standard way of loging out using basic authentication... What Tomato does is tell the browser that the current username/password is wrong to make it ask for a new set. This forces the browser to clear its cached authentication. You don't need to enter anything, just hit cancel when the browser prompts you. What you should be seeing is the 401 page after logout. To log back in, go to the front page and it should ask you for a u/p again.
  6. digitalgeek

    digitalgeek Network Guru Member

    I just tried the logout... from a remote connection. I was immediatley prompted for a user name and password, once I pressed cancel I was given a 401 Unathorized page

    keep up the good work Jon!
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice