Long boot, possibly related to IPV6

Discussion in 'Tomato Firmware' started by decep, Jul 4, 2013.

  1. decep

    decep Reformed Router Member

    Router Info: Netgear WNR3500L v2
    Firmware: Tomato Firmware 1.28.0000 MIPSR2-110 K26 USB AIO
    Mod: shibby v104, v106, v108, v110

    I have been dealing with a "long boot" type issue where it can take 5+ minutes for the router to boot. The router appears to reboot several times during a normal start cycle. Initially, I was thinking it was related to the Core USB issue that others have reported in other threads, but I may have found another culprit....IPV6 related

    I have Comcast HSI and I recently focused my attention on getting IPV6 connectivity. All indications are that it is enabled in my area.

    Today while working through some of the suggested fixes with getting IPV6 prefix delegation working, I was running a tcpdump session on the router looking specifically at ip6 traffic, as soon as I received a dhcp6 response, I immediately lost my connection and the router rebooted:

    18:12:34.151365 IP6 fe80::201:5cff:fe53:e41 > ff02::1:fff6:8735: ICMP6, neighbor solicitation, who has fe80::21e:6bff:fef6:8735, length 32
    18:12:34.858553 IP6 fe80::861b:5eff:fee6:92c9.546 > ff02::1:2.547: dhcp6 solicit
    18:12:34.876808 IP6 fe80::201:5cff:fe53:e41.547 > fe80::861b:5eff:fee6:92c9.546: dhcp6 advertise
    18:12:34.878121 IP6 fe80::861b:5eff:fee6:92c9.546 > ff02::1:2.547: dhcp6 request
    18:12:34.892237 IP6 fe80::201:5cff:fe53:e41 > ff02::1:ff19:4d81: ICMP6, neighbor solicitation, who has 2001:558:4011:8a:215:a4ff:fe19:4d81, length 32
    18:12:34.903245 IP6 fe80::201:5cff:fe53:e41.547 > fe80::861b:5eff:fee6:92c9.546: dhcp6 reply
    I do not get an IPV6 delegation when my router boots normally. Is it possible my router is rebooting in rapid succession and Comcast's DHCPv6 server finally stops delegating addresses to me due to my repeated requests which leads my router to boot normally after several minutes?
  2. decep

    decep Reformed Router Member

    I failed to mention that when disabling IPV6 in the GUI, the router appears to boot normally, ie in ~60 seconds.
  3. koitsu

    koitsu Network Guru Member

    Can you try Toastman's firmware instead, just as a test? Please make sure to do a thorough NVRAM erase after switching. But before you switch read everything I've written.

    The router should not be rebooting -- that might actually indicate the kernel is panic'ing, in which case you can't really debug that without serial console.

    Have you actually looked at the "really big IPv6 thread" on this forum, where myself and others worked to test Comcast IPv6? (I use Comcast myself; I don't actively use IPv6, but I was one of the people who helped figure out what was busted/how to fix/adjust TomatoUSB to make it work properly).

    You can try the adjustment script to put into WAN Up here, but it may or may not work or solve anything for you (it's highly dependent upon which firmware version you're using):


    But this fix/issue was actually addressed in certain firmware versions (I don't follow Shibby firmware so I don't know if/when it was added to his), but then the next version or so resulted in folks trying to replace the IPv6 route announcement stuff with dnsmasq's new capabilities I think (rather than in-kernel if I remember right), but I don't know how that turned out (see the last post in the "really big IPv6 thread" for me asking about that) -- it may be triggering some bug, I don't know.

    I disclose in this thread here the exact version of Toastman's firmware I know factually to work with Comcast's IPv6 setup:


    Specifically this post in the thread (see first line):


    There have been other threads on DSLR about this relating to certain TomatoUSB firmware versions where folks here began "tinkering" but broke things, case in point:


    And finally -- are you ready? -- there have been confirmed cases of Comcast screwing up the IPv6 deployment in some areas. I'm trying very hard right now to find the thread on DSLR where a user was getting broken IPv6 RAs from Comcast's routers and the issue turned out to be a misconfiguration on Comcast's side, but I cannot for the life of me find it now. I'm looking really hard but I just don't see it in my history. I'm sorry. :/
  4. decep

    decep Reformed Router Member

    First off, let me thank you for the wealth of information you provided. It has been most helpful.

    I decided to get off my butt and hook up a serial console so I can see what is happening. It is just difficult to find the time when exactly 342 milliseconds after the Internet goes down, my family starts complaining they cannot get on Facebook. :)

    Turns out, I am getting kernel panics. I re-enabled IPV6 after having it disabled most of the weekend and it had a kernel panic almost immediately after "saving" changes.

    After performing a 30-30-30 reset, I configured the router again, this time disabling core-usb support. Everything worked swimmingly until I re-enabled QoS. Rebooting after enabling this caused kernel panics upon boot.

    The state of core-usb appears to have no effect on stability. Also, IPV6 appears to just work out of the box. No special configuration is needed.

    The issue appears to be a combination of IPV6 and QoS.

    The processes reported in the kernel panics were: mtdblock (90% of the time), httpd, echo, and modprobe

    Cpu 0
    $ 0  : 00000000 00000000 00000000 00000000
    $ 4  : 87f1a760 81155a40 87f1a760 00000000
    $ 8  : 0000003c 80005034 0000000b 00000000
    $12  : 00000000 00000000 000000a8 00000000
    $16  : 874a0160 874a0140 00000000 00000000
    $20  : 00000000 87f1a760 874aa800 81155a40
    $24  : 00000000 c00aa8ec
    $28  : 81154000 81155980 00000000 80235920
    Hi    : 00000126
    Lo    : 66666768
    epc  : 80235170    Tainted: P
    ra    : 80235920 Status: 11003c03    KERNEL EXL IE
    Cause : 00000008
    BadVA : 00000014
    PrId  : 00019749
    Modules linked in: ip6t_LOG ip6t_REJECT ip6table_filter ip6table_mangle xt_length xt_layer7 xt_IMQ imq nf_conntrack_ipv6 ehci_hcd vfat fat ext2 ext3 jbd mbcache usb_storage sd_mod scsi_wait_scan scsi_mod nf_nat_pptp nf_conntrack_pptp nf_nat_proto_gre nf_conntrack_proto_gre nf_nat_ftp nf_conntrack_ftp nf_nat_sip nf_conntrack_sip nf_nat_h323 nf_conntrack_h323 wl(P) dnsmq(P) et(P) igs(P) emf(P)
    Process mtdblockd (pid: 92, threadinfo=81154000, task=81152c00)
    Stack : 00000028 802ed198 8027a8c4 8027a7e8 87f07d80 81155a38 87f07d80 00000000
            00000000 802eb404 00000005 811559f8 874aa800 801b80d8 00000000 00000024
            00000028 811559f0 0ff00009 874a0140 874a0160 874a0140 81155a40 00000000
            00000000 00000001 874aa800 802ed1b0 80000000 80235920 874a0160 86ca7980
            86ca7980 00000000 86ca7980 8027a4f8 000000a8 874a0140 8033df10 c00ed000
    Call Trace:[<c00d4154>][<c00d40f8>][<8000150c>][<80001548>]
    Code: 8fb00050  03e00008  27bd0078 <8e420014> 30420002  1440ffef  3c038034  2463c070  8c620004
    Kernel panic - not syncing: Fatal exception in interrupt
    Rebooting in 3 seconds..Please stand by while rebooting the system...
  5. decep

    decep Reformed Router Member

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice