Losing settings normal on WRTSL54GS?

Discussion in 'HyperWRT Firmware' started by RoadRanger, Feb 7, 2008.

  1. RoadRanger

    RoadRanger LI Guru Member

    In playing around with 17RC3 I had a couple instances of doing a "save settings" at the bottom of a page, having the unit lock up, power cycling it, and the router went back to factory settings. :eek:

    At first I thought maybe this refurb unit was loosing the settings without power but I verified that wasn't so.

    No big deal if it happens once in a while and only when changing settings...

    Seems stable otherwise. :biggrin:
  2. Toxic

    Toxic Administrator Staff Member

    did you reset to factory defaults when you upgraded to 17rc3? press the reset buitton for 30 seconds and then setup your router again. make sure if your coming from an original firmware or other type you are not using any backup cfg to restore the settings, that will not work.

    17rc3 has been out a very long time, there is no point in reporting bugs, I doubt it will get fix soon. unless someone takes over the development.
  3. RoadRanger

    RoadRanger LI Guru Member

    I did the factory reset thing each time but not the reset button. Next time I load a firmware or it crashes while changing settings I'll try that - thanks!
    If I can get the source code there are some changes I want to do for my own setup. Some might be useful to other folks and I was planning on feeding them back to the developer. I can't use Tomato because I really want to use my WRTSL54GS's network drive capability. I was going to buy an NSLU2 but the AP in the WRTSL54GS with it's speedboost aka afterburner was a small upgrade over what I had - plus one less box on 24/7. If Thobor is looking for someone to take over development I might be interested but want to play with the code for a bit first. Searching around it sounds like most folks have already jumped ship to Tomato? If Thibor isn't going to be developed further it might be best to fold Thibor's USB support into Tomato? But if the Tomato guy doesn't ever want to fold USB support into his firmware either himself or with someone's help I suppose I could fold his stuff into Thibor?
  4. frenchy2k1

    frenchy2k1 LI Guru Member

    DD-WRT also has USB support, but not quite that simple either (from what I read).
    SL is supported only with the recent versions and you need to include the USB drivers in the distribution to make it run. Some forum member do it regularly though (with one or 2 versions delay on the V24RC).
  5. Toxic

    Toxic Administrator Staff Member

    I'll try and push Thibor in finding the src changes in rc3 :)
  6. RoadRanger

    RoadRanger LI Guru Member

    :) :) :)

    Running stable here with a 40gb 2.5" bus-powered usb drive running off of it with my music collection. It didn't recognize the drive at first (fat 32) but it reformatted it as fat 32 (different cluster size?) and worked. I found out it also supports NTFS volumes so I reformatted the drive - plugged into my laptop - and it worked fine also. So, the firmware is missing the ability to format as NTFS and has no "chkdsk" or defragment cabability - but I can do all that on the laptop when needed. I'm surprised it doen't allow Linux format (EXT3) drives? Anyways I was able to mount.cifs it on my Haupauge MediaMVP running MVPMC - my Argosy HD363N NAS box could only be mounted with the older smbmount which isn't included in the "stock" MVPMC build. This is one of the reasons I bought the WRTSL54GS so I'm happy. :)
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice