Loss of Power on the WLan

Discussion in 'Sveasoft Firmware' started by Gizmo, Oct 16, 2004.

  1. Gizmo

    Gizmo Network Guru Member


    I want to connect two networks via Wlan to share one internet connection.
    For this I used two routers Linksys WRT54GS.
    To connect the routers I need WDS, for this I made a firmwareupdate to Satori-4_0GS.
    After that I was able to get connection between the routers on short distance, but on far distance it worked verry bad.
    So I messured the output-power of the WLan. On one router I messured about 25mW, which is ok, on the other I messured less the 1mW.
    First I thought the second router is defective and I ordered two other routers - same result. So only one of four routers worked properly.
    I don't think that the three routers are defective.
    Since I have no normal WLan client I am not able to messure the WLan power with the original firmware.

    What could have happened?
    Is it possible that an internal parameter got set wrong with the firmwareupdate and deaktivated the amplifier of the WLan?
    What can I do?
    Is there a possibility to check all the parameters?
    Is there a possibility to reactivate the WLan?

    Thanks for your help

  2. grcore

    grcore Network Guru Member

    did you reset to factory defaults after upgrading?

    Note, on the wireless/advanced page you are able to set the tx power level.

  3. Gizmo

    Gizmo Network Guru Member

    I have done a reset after upgrading!

    I have changed the power up to 84mW, but there is no effect!

  4. grcore

    grcore Network Guru Member

    Couple of things to check:

    Make sure afterburner is set to "off". You may want to enable it, save the settings and then disable it again and save settings.

    Also make sure ap watchdog is turned off.

    Do these units work fine otherwise (ie not in WDS mode?)

    How are you measuring the output?

    Also, check to make sure you have the correct MAC address for the WDS link. The wireless MAC is different than the WAN MAC.

  5. Gizmo

    Gizmo Network Guru Member

    I think the Afterburner and the watchdog was off.

    The power was ok before I did the firmware update an enabled WDS.

    I used a 50Ohm Resistor on the output connector. I measured the voltage on these Resistor over a diode and a capacitor. I know that these is not very accurate but it allowed me to compare the power.
    An other method was with an antenna and a an a receiver.
    The result was the same on both messurements -> there was a big difference of the power between the routers.

    The WDS/MAC configuration must be ok, because I got a connection. Only the power was to low for bigger distances.
  6. grcore

    grcore Network Guru Member

    I know there was a discussion someplace (bbr?) regarding the difference in power output between the wireless driver versions from Broadcom. The newer versions were apparently not as good as older versions with this matter. I believe the hyperwrt firmware was addressing this by using the older driver (but with limited functionality).

    Untill Broadcom releases the source on the driver or releases a better driver, or someone builds a new one we may be stuck with what we have.

    I can't explain why 3 of your devices are basically not putting much power out (basically nothing). Have you tried going back to the old firmware to see?

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice