lost connection on all WRT54G UTP ports! Please help!

Discussion in 'Networking Issues' started by ppatrick, Aug 26, 2007.

  1. ppatrick

    ppatrick LI Guru Member


    I've been using WRT54G for a few years and never had any problem until last night. The WRT54G model has 4 UTP ports in the back and acts as an access point for other wireless devices (mostly laptops). My problem is that every desktops connecting to the UTP ports suddently stop working. I did the ipconfig to verify that the desktop receieved the IP from WRT54G (DHCP enabled). The ipconfig showed that the desktop received the IP ( with netmask However when I tried to ping the gateway (WRT54G), none of the ping packet reached the gateway ( Therefore the desktop could not access the internet. What really surprised me was that all the wireless laptops connecting the same WRT54G had internet connection!

    So, I used the laptop to connect directly to the WRT54G menu through web browser. I checked the DHCP Client table and everything looked fine. I found the IPs that were leased to the desktops on the table.

    Then I tried to reboot both WRT54G and the desktop. I turned off both WRT54G and the desktop. I turned on the WRT54G first then the desktop (Win XP Pro). The desktop had the following warning:

    Limited or no connectivity
    You might not be able to access the internet or some network resources. This problem occurred beause the network did not assign a network address to the computer.

    I checked the IP of the desktop again and found the WRT54G did assigned the IP to the desktop. I tried to ping the gateway again and it failed. I don't know what to do next. Does it sound like the WRT54G UTP ports are broken? I tried all four ports and they all had the same results. :-(

    Please advice,
  2. Slimey

    Slimey Network Guru Member

    What kind of network card do you have in your desktops? You could try downloading the latest drivers from the nic maker and then removing the network from device manager and reboot then update the nic with the latest drivers maybe that might help?
  3. ppatrick

    ppatrick LI Guru Member

    Hi Smiley,

    Thanks for your reply. The NIC of my desktop is CNet PRO200WL PCI Fast Ethernet. Honestly I don't think the problem is the desktop NIC because I hooked other laptops (which had different NIC) to the UTP ports and none of them had internet connection. However, when I unplugged the UTP cables and used the wireless NIC on the laptops, I've got the internet connection. It seemed like the problem was at UTP ports.

    Any advice/ideas are welcome.

    Thank you,
  4. frenchy2k1

    frenchy2k1 LI Guru Member

    I doubt, a reboot of the router or, even better, a reset to the default setting usually cures those problems.

    The risk here is that the default config does not have wireless enable. If you reset and the UTP ports are still non functional, you won't be able to re-configure...
  5. ifican

    ifican Network Guru Member

    It definetly sounds like hardware, if you checked the cables and tried all the ports then i am leaning toward the hardware itself, though i have never seen this type of router where the switch portion just dies one day. Possible but i have never run accross it. The only other thing you could try is reflashing the router, but again if you run into issues and have to hard reset and the ports dont come back alive then youll be locked out with no access.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice