Minor bug with Static IP names in Device List

Discussion in 'Tomato Firmware' started by lordfuzzz, Feb 11, 2009.

  1. lordfuzzz

    lordfuzzz Addicted to LI Member

    I'm having a small problem with Tomato's Device List and the Name column. I'm running v1.23 on a newer WRT54GL.

    Conditions: I've added all my devices to the static IP list. The static IPs are outside the range of the DHCP (as in the DHCP gives out addresses ending in .100-.109, and the static IPs are .110+).

    Symptoms: The Name column in the Device List page on Tomato frequently shows up as * or blank. The correct IP is assigned to each device as needed (I've verified this according to Mac address), but the name almost never shows up. When I first loaded the firmware, the problem wasn't there.

    Can anyone help me?
  2. occamsrazor

    occamsrazor Network Guru Member

    Can't help... but same here...
  3. Planiwa

    Planiwa Network Guru Member

    That's not the only minor bug on that page. :)

    FWIW, the page Tools > WOL gives a correct list of MAC, IP, and hostname.

    Also, the hostname works fine (e.g. ping hostname works), but only when, under Advanced > DHCP/DNS "Use Internal Caching DNS Forwarder" is checked!

    One good thing about non-names (which often are Mac computers whose users have not given them hostnames), is that their (re-)leasing tend to be simpler. Sometimes, when the "static" LAN name is different from the computers nostname, there seems to be some argument. :)
  4. pfoomer

    pfoomer LI Guru Member

    I concur

    This I believe has occurred since v1.21

    For me, its only apparent on wireless connections, ethernet connections are blank until the lease is renewed?, then they appear, but not for wireless
  5. bripab007

    bripab007 Network Guru Member

    This started happening for me in v.1.23. It worked fine/had no "*" hostnames in v.1.21.
  6. pfoomer

    pfoomer LI Guru Member


    Sorry, probably 1.22, which seems about right as I was on 1.22 for a long time.
  7. mstombs

    mstombs Network Guru Member

    I don't have a problem with 1.22 I call my router wrt54gs.lan then all the devices nslu2.lan, psus4.lan etc, all being in same domain may help?
  8. pfoomer

    pfoomer LI Guru Member


    all in the same domain, this used to work (pre 1.22) , but now, any wireless connection will be a star. all macs are set in static dhcp.

    Ethernet connection are blank sometimes until I request a dhcp update, then they become visible.

    Same problem with ND or non ND. i went to 1.23 from 1.23 ND to see if it cleared it.

    Not a mega problem for me, just weird.
  9. jdub8

    jdub8 LI Guru Member

    Same exact problem here. using victecs 1.23.8511

    What sucks is if you try to bind one of those static addresses to an IMQ it will blank out till the router decides to update it. Even then sometimes it randomly goes away =/
  10. pfoomer

    pfoomer LI Guru Member

    Please can you confirm settings?

    In Basic->Identification I have

    Router Name foo
    Host Name foo
    Domain Name local

    get the problem

    changing to

    Router Name foo
    Host Name foo.local
    Domain Name local

    Still get a star for the wireless connection

    The wireless system, when physically connected to the switch, gets its name ok in the list.

    When on wireless, its getting dhcp, but still a star in the device list.
  11. bripab007

    bripab007 Network Guru Member

    Happens for me with both wired and wireless clients. DNS is properly resolving their hostnames, too, just as it always has.

    It really appears to just be a bug in the device list page in the GUI.
  12. chip_r

    chip_r Guest

    It does appear to be a bug in the GUI.

    I found a work-around:

    1) Erase all data in NVRAM (thorough)
    2) Load firmware version 1.21
    3) Enter all of your settings, including all of your static IP names.
    4) Verify your static IP names are shown in the Device List.
    5) Load firmware version 1.23

    Worked for me with a WRT54G ver. 2.0

    One caveat is that adding more static clients in version 1.23 causes the problem to come back.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice