Missing 5GHz

Discussion in 'Tomato Firmware' started by jsnepo, Jan 17, 2018.

  1. jsnepo

    jsnepo Serious Server Member

    Just got a Linksys E2500v3 and installed Shibby v140 USB firmware. I noticed that whenever I add some lines in DNSMasq, the 5GHz wifi disappears. No eth2, not even in any of the settings? Do we have a fix for this? I've got some things I need to put in the DNSMasq but couldn't put all of it because then the 5GHz wifi disappears.
     
  2. jdesignz

    jdesignz New Member Member

    Same issues here... 5ghz goes dark after setting it up. Tired of resetting all over again. We need new firmware shibby


    Sent from my Moto G⁵ˢ Plus (XT1805)
     
  3. eibgrad

    eibgrad Network Guru Member

    Not sure how the use of DNSMasq customization affects 5GHz, but let's just assume it's related, somehow (maybe it's causing a buffer overflow, who knows).

    Instead of dumping a whole bunch of stuff into that field, place your DNSMasq directives into a file, store it in /jffs, and add the following line to the DNSMasq field.

    Code:
    conf-file=/jffs/dnsmasq.custom
    Maybe that's short enough to workaround the "bug".
     
  4. 9000cc

    9000cc New Member Member

    If you can return it, do so. The 5GHz chip on these is not connected via the PCI bus and is notoriously unreliable even with the stock firmware. It appears Tomato development for Broadcom hardware is in limbo.

    A TP-Link Archer C7 with LEDE/OpenWRT will be much more reliable and happily accept all your dnsmasq settings.
     
  5. Jacky444

    Jacky444 LI Guru Member

    Tomato was always "hacky" when it comes to latest Broadcom hardware. OpenWRT has their own drivers as far as I know, meaning its way better implemented than Tomato. But honestly I find Tomato much easier to use than LEDE. For some reason I'm not good at that ^^.
     
  6. Monk E. Boy

    Monk E. Boy Network Guru Member

    I believe the E2500 has its 5GHz radio hanging off USB like the RT-N53. Performance is less than stellar and the 5Ghz radio is flaky at best, even on OEM firmware.

    I'm all for assigning blame where the blame lies, and if the OEMs can't even make it work reliably then it feels a little odd blaming Tomato for it.

    On the N53s a NVRAM reset followed by a ~3 minute pause before initial setup tends to make the radio appear but anything that messes with the USB bus can bring it offline.
     
  7. tvlz

    tvlz LI Guru Member

    The USBAP models lose the 5GHz radio if you use more than 32k of nvram

    I compiled an updated build (under testing dir) that limits the nvram to 32k if you want try it.
     
    Monk E. Boy and Sean B. like this.
  8. jsnepo

    jsnepo Serious Server Member

    I found a workaround following your suggestions and they're a big help. This is more to give an update.

    Anyway, I enabled JFFS and put a custom HOSTS file in it. Then in DNSMasq, I entered this:

    addn-hosts=/jffs/hosts/hosts.custom

    This kept the NVRAM going above 32K thus keeping the 5GHz wifi working.

    Thanks for the help guys. :)
     
  9. jdesignz

    jdesignz New Member Member

    If I write it down on DNSMasq, will 5ghz show again?

    Sent from my XT1805 using Tapatalk
     
  10. mvsgeek

    mvsgeek LI Guru Member

    Perhaps not relevant since I'm running Toastman's firmware on an Asus RT-N66U, but the 5GHz SSID disappears as soon as I change the channel width from 20 to 40MHz. Removing multiple DNSMasq entries had no effect regardless of channel width setting.
     
  11. eibgrad

    eibgrad Network Guru Member

    It actually worked?! LOL What a crazy bug. Who would think messing around w/ DNSMasq would solve a problem w/ the 5GHz radio. It's certainly not obvious the two could be related.
     
  12. Sundar

    Sundar New Member Member

    I tried installing test build given by tvlz
    32K Nvram Builds
    and also followed below steps
    "
    Anyway, I enabled JFFS and put a custom HOSTS file in it. Then in DNSMasq, I entered this:

    addn-hosts=/jffs/hosts/hosts.custom
    "

    Still 5GHz doesn't work for me in Asus RT-N53, though for after restarting it is working for few hours/mins then it get disappeared.

    Even though my nvram size is less than 32K, nvram show displayed usage size as 29K
    Any idea how to debug/fix further?
     
  13. koitsu

    koitsu Network Guru Member

    I think it's more likely that clicking "Save" in the GUI is causing some re-initialisation or re-setting of something deeper within the code. There could be an uninitialised variable somewhere in TomatoUSB's mass of C code that is getting initialised after clicking "Save".

    The 5GHz interface doesn't have anything directly to do with dnsmasq, or vice-versa.
     
  14. Tony Ramirez

    Tony Ramirez Reformed Router Member

    Thanks. I have been using DNSMasq for extra DNS for months then all of a sudden none of my streaming devices would connect however my phone and computer was unaffected. I did a factory reset and did not set up the extra DNS and it is working fine. Now I know what the problem is I won't use DNSMasq anymore.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice