Mixing Novell network and wireless internet

Discussion in 'Networking Issues' started by Elmer99, Jan 12, 2007.

  1. Elmer99

    Elmer99 LI Guru Member

    My computer network knowledge is pretty slim, so I'm hoping someone can suggest an easy fix that I can understand.

    We have a small network using Novell Netware, and XP pro on the worksations. Our dsl internet connection is shared by a couple of stand-alone machines that are not on the network, using a Linksys WRT54GL router. We added internet to one of the networked machines via a linksys WUSB54G usb wireless adapter. It's been working pretty well for a couple years, occassionally buggy, but a quick click on the netset client would bring it right back up.

    A week or two ago, we could not get the usb machine on the internet. It will connect with the router and ipconfig shows both ip's, but no internet. I tried all the suggested fixes from Linksys and forums like this one, resets, firmware upgrade, system restore, security on/off, even buying a new adapter and router! Still no go...... Internet works fine on the cabled machines that are not on the network, and on my laptop through it's wireless card. If I unplug the ethernet cable on the machine in question and reboot it, it goes on the internet though the USB adapter fine. And once, for no ryme or reason, the internet did come up while both were plugged in. :confused: I can't use the netset anymore, because I upgraded the firmware on the router and it doesn't work with it apparently......

    Obviously this is a conflict between the ethernet and wireless adapters. The ip numbers are completely different, but the subnets are the same... 255 something....not looking at the machine right now.

    Linksys support told me that what we're trying to do isn't possible..... What's weird is that this worked for a couple of years.

    Anybody got an easy fix for this one?
  2. HennieM

    HennieM Network Guru Member

    When you say "no internet" I assume this means web access via a browser? Assuming so: From the machine with the 2 adapters (wired->Novell and wireless->internet), try to traceroute an address on the internet, like, in a DOS box, type

    tracert www.google.com

    If the traceroute attempts to contact your WRT, and subsequently your DSL modem, the routing is most likely OK. In this instance look at the proxy settings in your browser.

    If the traceroute above tries to contact a machine or router on your wired (Novell) net, your routing is probably screwed up. Look at your DHCP or static IP setup for both adapters - your wireless net must have the router as your WRT, while your wired net should most likely have no router setting.

    You can also test the routing setup by looking at the output of - on the 2 adapter machine -

    route print

    in a DOS box.
  3. Elmer99

    Elmer99 LI Guru Member

    Right, can't open a web page, or ping a web page, but the connection to the router is there, and can ping it. I'll take a look at it Monday and see if I can figure out your advice. :)

    In the meantime, I found the netset client software in my documents, and tried running it. After I run it, I can connect to the internet, but when I close IE and go back to using Novell, when I try and use IE again, it will not connect, unless I run the netset client again. So obviously it is changing some kind of setting. If I could just figure out what it is........
  4. Fast_Eddy

    Fast_Eddy LI Guru Member

    I'm guessing that you may have upgraded the Novell server and dropped IPX from the network. The workstation in question has a problem with its default gateway. If it's "talking" IPX to Novell and the IP to the Internet, no problem.
    But if it's talking IP to both, then it has to figure out which route to take.

    If you still have IPX on the Novell server, then enable IPX on the workstation and it may take care of your problem.
  5. Elmer99

    Elmer99 LI Guru Member

    That sounds right, we did have our netware upgraded a while back, I'll call our network guy and ask him. If the IPX is gone, is there anything else we can do?

    Thanks for the fast and great answers!!!
  6. Fast_Eddy

    Fast_Eddy LI Guru Member

    Well since your non-Internet PCs (the ones connected to the Novell server) don't need IP, there is no reason not to run IPX on the Novell server. I've done some testing and IPX is a much faster protocol than IP (ie in imaging, etc.).

    There maybe a reason why your network guy wanted to run a pure IP network, but IPX is still a a very useful transport protocol. As an example, if you use imaging software to setup workstations, IPX will restore the image in half the time.

    As for an easy answer to running two IP networks from a single PC, it gets very complicated. Not knowing your current setup, it is difficult to recommend a solution. Your network guy should be your first source of information as you depend on him (her) for day-to-day support.

    Keep the thread going and let us know how you're making out...
  7. HennieM

    HennieM Network Guru Member

    So how're you making out Elmer99?
    Forgot to mention - If your IT guy wants to maintain the TCP/IP on Novell, he can run both protocols (TCP/IP and IPX). You can then force the Novell client to use either, or both, protocols.

    However, I still think that your DHCP serves the wrong gateway to your clients, or the network adapters are incorrectly manually configured.
    Just to be clear: The wireless adapter must have default gateway configured as the internet gateway, while the fixed/Novell adapter must be configured for no gateway.
  8. pablito

    pablito Network Guru Member

    I've got an old Novell network that just won't die. :)
    IPX is indeed just fine and is faster for sure. I also run IP on it too since a few apps require it but file sharing is done with IPX. The only caveat is a much slower bootup if you use both Novell's NDS client and a Win AD login. No problem if using a simple Novell client without NDS

    FYI, I found out that an old WRT I have there as a simple AP won't pass IPX over wireless if I use WPA. Works fine with WEP but if I use WPA I can't do Novell.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice