Mount CIFS on Linksys NSLU2

Discussion in 'Tomato Firmware' started by wycf, Jan 29, 2007.

  1. wycf

    wycf Network Guru Member

    When I try to mount a shared directory on a NSLU2 (a network storage device) I always failed with this line in the log:
    Jan 28 21:56:21 Linksys user.err kernel:  CIFS VFS: cifs_mount failed w/return code = -6
    I can access this directory from another XP mechine like this:

    Attached Files:

  2. wycf

    wycf Network Guru Member

    What is the correct UNC for the shared folder in the above screen shot?

    I tried
    \\\DISK 2\Tomato
    \\\DISK 2\public\Tomato

    None of them works.

    Ths NSLU2 runing linux and the folder "public" mounted as "DISK 2" by default. It is a public share.

    please help.

  3. pharma

    pharma Network Guru Member

    Does it work when using just a shared folder on your harddrive ( C: ), ie, have you been able to get CIFS to work under any condition?

  4. bogderpirat

    bogderpirat Network Guru Member

    maybe this is case sensitive.

    "\\\disk 2\Tomato" should be completely correct.

    do you have any login//password set for the shares on the NAS device?
  5. wycf

    wycf Network Guru Member

    I created a new share from the NSLU2 web GUI called "tomatolog", then I successfully mounted it as CIFS by:
    user: root
    password: <password>

    This solved my problem but I still don't understand that why I can't mount the CIFS the way I tried before.

    Here are something I noticed:
    1. The NSLU2 is a network storage device. If I ssh/telnet to the NSLU2 I can see the default share is "/public".
    2. But if I browse from XP machine, the share is "\\Nslu2\disk 2".
    3. From the Linksys web GUI I can also browse this directory but the URL is "".
    4. This directory ("/public" i.e. "disk 2".) is a public share so everyone has right to read and write.

    Please note there is a space in "disk 2". Could this be the problem?
  6. bokh

    bokh Network Guru Member

    Could be... have you tried giving the share-name a somewhat different name?
    I would never go with a name like that BTW - I'd replace the space with a "-".
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice