mounting NAS200 shares via router?

Discussion in 'Cisco/Linksys Network Storage Devices' started by xb307, Jun 24, 2008.

  1. xb307

    xb307 Addicted to LI Member

    Accessing NAS200 shares via a router?

    I have a NAS200 device on network "A" and a WinXP PC on network "B".
    There is a router between "A" and "B", the PC can ping the NAS, the router
    does not perform any filtering or firewalling

    The PC needs to mount 'PUBLIC DISK' from the NAS

    The NAS is in the windows Workgroup same as the PC

    I have the NAS200 in the hosts and lmhosts files on the PC.
    NAS200 <IP_address>

    Trying to mount \\NAS200\PUBLIC DISK getting 'network path not found'
    The Drive mounting utility supplied with NAS is not finding the NAS as it
    appears to be only lookin on the local LAN which is network "A"

    How do I make this work? TIA
  2. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    I assume this is a real router, not a NAT router. I also assume that the router is configured correctly (i.e. doesn't block NetBIOS traffic on ports 135, 137 and 139) all involved machines are set up to use this router to reach each other (the NAS200 doesn't have the possibility of setting up complicated routing tables AFAIK). It should be possible to ping the NAS200 from the PC.

    You can also use IP addresses in UNC paths, e.g. "\\\DISK 1". Make sure "file and printer sharing" is enabled for the network connection in Windows XP. Also make sure you have LMHOSTS lookup enabled in your network settings (in the Advanced TCP/IP settings dialog in the WINS tab). You may also want to select "Enable NetBIOS over TCP/IP" in that tab.

    I'm not sure but you may also have to tweak your Windows XP firewall settings (or disable it temporarily until you can figure this out) to allow NetBIOS traffic to non-local networks: In the Exceptions tab, select the File and Printer Sharing item and click Edit, then Change Scope and set it to Any Computer (or Custom List for more security).

    I think the drive mounting utility is listening for broadcasts at the IP level or even at the Ethernet level. Either way I wouldn't rely on it to find the NAS in an extraordinary situation like yours.

    You didn't mention how you tried to mount the disk and you used no quotes and forgot the "1" at the end of "PUBLIC DISK 1". In a command window you would do something like:

    net use * "\\nas200\public disk 1" * /user:admin
    or something like:

    net use Z: "\\\public disk 1" secretpassword /user:jac
    You should also be able to add the NAS200 to your network places or to browse to it from the file explorer.

    If the above doesn't help, give us some more details (or use more explosives :))

  3. xb307

    xb307 Addicted to LI Member

    Done all that..

    System error 53
    Network path not found

    Checked the router debug log, all netbios connections seems to be going through

    net view \\nas200 outputs

    Shared resources at \\nas200

    Share name Share type
    PUBLIC DISK disk

    where to from here?
  4. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    Well, it appears that you can reach it and that the share is available. Strange that it's called "public disk" -- I'm guessing you're using a RAID configuration and that's why it doesn't add a "1" at the end. Make sure you use a user name and password that you created on the NAS200, otherwise it will use the user name and password from your current Windows session. If this is the only line you see in the output, chances are that you are logged in as guest, not as a user.

    net use * "\\nas200\public disk" * /user:admin
    should do the trick... If not, you may have to go in with a network analyzer such as Wireshark. But if you don't know what you SHOULD see and how you can fix problems, I expect that Wireshark won't help much either...

    You may also want to try net use /d \\nas200\ipc$ if you're having trouble connecting as a different user. That command disconnects you from the hidden share that every Samba server (and PC) uses to let you log in. Furthermore you can try net stop workstation & net start alerter & net start "computer browser" & net start workstation to restart all services that are required.

    Either way, in a pinch you should be able to access the files by FTP if you enabled the FTP server on the NAS... In Windows you can browse it by typing ftp://admin:password@nas200 in the address bar of a file explorer. You won't be able to directly open files on the device that way but at least you can copy and move files to and from your NAS.

  5. xb307

    xb307 Addicted to LI Member


    apparently the buggy NAS webgui under certain conditions creates RAID1 PUBLIC DISK with screwed up permissions so even admin is unable to mount it from a local LAN

    it is a shame that among a host of other missing things there is no command line interface in the linksys firmware..

    wiping out RAID, reformatting the disks back to default and recreating RAID has done the trick

    now the next challenge is to make the network drive on a remote PC come up without
    asking password for 'guest' every time, I mapped it in File Explorer, ticked 'reconnect at logon' and specified 'guest' and guest password in 'login as different user', but the bloody thing is still asking for password next time the PC reboots..I guess I need to stick a good old .bat file with 'net use ....' somewhere in startup..?
  6. WARPed-too

    WARPed-too LI Guru Member

    Create a text file of file-name.cmd and in it put:

    @echo off
    net use n: "\\ip-address\disk 1" password /user:admin

    Select your file name with the .cmd extension and edit the above line to reflect your drive letter(n) in this case, ip address, drive name (mine defaulted to disk 1) and your password.

    You want the echo off so others won't see the password used

    Then add the file you created to your startup folder so it will launch at boot-up.

    Also there is a new firmware that just came out that you may want to look at.
  7. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    My Jac0 firmware mod has full shell access through SSH and Telnet, but is unfortunately not compatible with RAID if you want to run custom startup scripts. Now that Linksys has a new firmware out (R75), I hope they put the sources online soon so I can release an update. And no, the 90MB file on the Linksys FTP site is not a complete set of sources.

    I think the problem may be that Windows apparently always asks if you want to change your credentials whenever it notices you are connecting as guest. If you use a non-guest account to log in to the NAS, it will probably stop asking. No need for a batch file (although that would work too, however it would also mean that the password is stored in that batch file in clear text of course).

  8. xb307

    xb307 Addicted to LI Member

    thanx ppl you have been most helpful!

    I have created batch .cmd startup files on my PCs to automount the share, it is a home network so I am not really concerned about hardcoded passwords

    could you please post the link to the Linsys new f/ware, tried to find it on their site to no avail

  9. jac_goudsmit

    jac_goudsmit Super Moderator Staff Member Member

    One way to find it on the website is to click "download" at the top of the page and then enter "nas200" in the search box; then select "version 1" from the dropdown box. This will take you to a page with all downloads for the NAS200.

    Once again, if you download the GPL sources and it's a 91MB file, it's NOT really the GPL sources, only the compiler. I encourage everyone to ask Linksys to put the full sources online.

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice