Discussion in 'Cisco/Linksys Network Storage Devices' started by NeuroticFish, Aug 13, 2006.

  1. NeuroticFish

    NeuroticFish Network Guru Member

    Hello all,

    I've got a problem getting this combination to work. My goal is to get SNMP-data from my WRT54GS with DD-WRT firmware to my NSLU2 and get it displayed on a public site (http://<my-dynamicip-site>:8888) ).

    So far I have been able to realize these steps:

    1. Building and configuring the webserver (folder /website) on the NSLU2 with thttpd
    2. Installing MRTG on the NSLU2 with required packages
    3. Configuring my WRT54GS to make SNMP-data "available" to devices that query it (the NSLU2 in this case). I've been using this site for this:
    4. Configuring the script to get the data of the WRT54GS

    I presume that step 3 and 4 have been executed correctly because when i look inside the mrtg.cfg config file, i see various interfaces that are available on my router and also the router-name itself (dd-wrt).

    However, i have some problems with this (i think im close to getting it work though).

    My main question is: how is the mrtg.cfg executed? Does it execute at the boot of the NSLU2 and write the information automatically at my public websited? Or do i have to do extra work and configure mrtg.cfg to execute it at the boot of the NSLU2?

    When i tried to execute the mrtg.cfg myself (i dont know if this is required or even wise :) ), i get the following error message:

    # /etc/mrtg.cfg
    EnableIPv6:: No such file or directory
    /etc/mrtg.cfg: WorkDir:/website: No such file or directory
    Options[_]:: No such file or directory
    Target[]:: No such file or directory
    SetEnv[]:: No such file or directory
    MaxBytes[]:: No such file or directory
    Title[]:: No such file or directory
    /etc/mrtg.cfg: 242: Syntax error: newline unexpected

    So this is where I'm stuck. I'm pretty sure I have got all the software installed, that i have a working WRT54GS-router that broadcasts the SNMP-data and that i have a working site.

    I've uploaded two files. The first one is a DOC-file which i write for myself to record my various steps while configuring my NSLU2. It's mostly copied messages from various forums/howto's, adjusted with comments and settings for myself. The second file is the contents of my mrtg.cfg file.

    If somebody has any ideas, please let me know, because im quite stuck now.

    Attached Files:

  2. NeuroticFish

    NeuroticFish Network Guru Member

    Has been solved by executing /opt/mrtg-2/bin/mrtg /etc/mrtg.cfg . Now i only have to configure crontab to let it run reguraly.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice