My life with a WRT54G is forever doomed

Discussion in 'Cisco/Linksys Wireless Routers' started by fresh, Feb 14, 2007.

  1. fresh

    fresh Network Guru Member

    One day I tried to use WDS with a second router and HyoerWRT 2.1b1. It didn't work, and made my network impossible to reconnect to until I cloned my MAC address and did a power cycle (unplugged for 30 seconds).

    Ever since this day, every few days my wireless network cuts out and refuses to reconnect (even though my network card can see the network) until I unplug or reboot the router. I have tried 2 routers with 3 different firmwares on each (Linksys, HyerWRT, tomato) as well as 2 network cards with upgraded, and then rolled back drivers.

    Today, I switched the routers again and updated the firmware to try it again. When I upgraded the firmware, everything went lovely, including the message telling me that the firmware was successfully installed! It reboots and YAY! My router is ruined! I'M SO LUCKY! WTF IS GOING ON WITH THESE POS? Why do they never work? This is what the router with the f'd up firmware now does. I can get to 2 screens from which I can do nothing. (The ampersand (&) is a link to the second page)
    By the way my conneection still cuts out. 1 router is a GL v.1.0 and the other is a G v.2.0.
  2. ifican

    ifican Network Guru Member

    Do a factory reset, (hold reset button for 20 seconds and release). Let the router reboot. That should reset the firmware then you can reload whatever you like. It sounds like something got gummed up along the way and has only gotten worse as you poured on more and more loads.
  3. ka9yhd

    ka9yhd LI Guru Member

    Also after updating the firmware did you clear the nvram? After every firmware update you should be clearing the nvram so there is no wierd settings in there. Also it is possible that you have a bad download of the firmware. Try downloading the firmware again.

    I have a WRT54GL ver 1.1 running Thibor 15c and have not had any problems.
  4. fresh

    fresh Network Guru Member

    Everytime I've put new firmware on, I've downgraded to the stock Linksys firmware first and then put whatever firmware on. I've never cleared the nvram, I don't know how to do that.
  5. vibe666

    vibe666 Network Guru Member

    there are lots of guides on the forums about upgrading firmware and using 3rd party firmwares. you'd be hard pushed to find one that doesn't include instructions on resetting the nvram and strong recommendations to do so.

    this is very likely the source of your problem. not to mention repeatedly going back and forth between stock and 3rd party firmwares without doing the nvram reset.

    do a search for the nvram reset in the forums and then do a hard reset and start again.

    you might also want to look for a de-bricking guide. you aren't quite there yet, but you aren't far off and a lot of the recommendations in the de-bricking guides will serve you just as well.

    above all else READ EVERYTHING you can about what you are going to do BEFORE you do it. the number one cause of problems after flashing WRT54G routers (or anything else dcome to think of it) is a lack of knowledge, not the hardware itself.

    sorry if i'm sounding harsh, but there's no end of information on doing what you are trying to do (including a simple search of these forums and some very good stickies) but you just jumped in with both feet without looking into it properly and now you're stuck.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice